LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-16-2006, 05:19 AM   #1
henkoegema
LQ Newbie
 
Registered: Jul 2006
Posts: 11

Rep: Reputation: 0
Unhappy vsftpd port higher than 1024


My ISP is blocking ports under 1024.
I have setup a vsftp server (SUSE10.0)
It works fine from insite my LAN.
From outsite (WAN, internet) no connection is possible.
Port 20 and 21 in my router are forwarded to my server.
How can I setup vsftp to run on a port above 1024 to allow anonymous uploads?
I have looked in /etc/vsftpd.conf
The only occurance of 'port' which I found in the file vsftpd.conf is:
# Transfer Settings
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
#
connect_from_port_20=YES

Can I change this to:
connect_from_port_9000=YES
if I want to use port 9000 for ftp ?

Or is the port settings for vsftp somewhere else?

Henk
 
Old 07-16-2006, 05:56 AM   #2
amitn16
LQ Newbie
 
Registered: Jun 2006
Posts: 1

Rep: Reputation: 0
use ftp on diffrent port

Hi Henk,

you can add below mentioned line in vsftpd.conf.

listen_port=xxxx
where "xxxx" is the port which u wants to listen your ftp server.

Amit




Quote:
Originally Posted by henkoegema
My ISP is blocking ports under 1024.
I have setup a vsftp server (SUSE10.0)
It works fine from insite my LAN.
From outsite (WAN, internet) no connection is possible.
Port 20 and 21 in my router are forwarded to my server.
How can I setup vsftp to run on a port above 1024 to allow anonymous uploads?
I have looked in /etc/vsftpd.conf
The only occurance of 'port' which I found in the file vsftpd.conf is:
# Transfer Settings
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
#
connect_from_port_20=YES

Can I change this to:
connect_from_port_9000=YES
if I want to use port 9000 for ftp ?

Or is the port settings for vsftp somewhere else?

Henk
 
Old 07-16-2006, 07:28 AM   #3
henkoegema
LQ Newbie
 
Registered: Jul 2006
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by amitn16
Hi Henk,

you can add below mentioned line in vsftpd.conf.

listen_port=xxxx
where "xxxx" is the port which u wants to listen your ftp server.

Amit
I have added
listen_port=40000 to vsftpd.conf

Have also forwarded port 40000 to my server.

But how do I access my ftp server now?
I have a dyndns pointer 'henkoegema.ftpaccess.cc' to my server.
WhenI try (from a webbrowser IE) "ftp://henkoegma.ftpaccess.cc:40000" (without the " ")
I get error:
An error occured opening the dir. on the FTP-server. Make sure you have access to that dir.
(translated from Dutch)
Details:
200 Switching to ASCII mode
500 Illegal PORT command
500 Unknown command.

Now I can't connect from inside my LAN either. (which I could before)

Rgds
Henk
 
Old 07-16-2006, 07:43 AM   #4
henkoegema
LQ Newbie
 
Registered: Jul 2006
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by henkoegema
I have added
listen_port=40000 to vsftpd.conf
How do I load the new settings in vsftdp.conf?
Now I restart the pc, but there must be a smarter way !
How can I stop and restart the vsftp deamon?

Rgds
Henk
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Higher port forwarding doesn't work fatman Linux - Networking 3 01-01-2006 09:31 AM
Cant use any port higher than 5499 joker20 Slackware 9 07-16-2005 07:09 PM
using port number below 1024 eshwar_ind Linux - Networking 2 07-01-2005 04:58 AM
udp port 1024 frgtn Linux - Security 2 03-27-2005 07:10 AM
services with port < 1024 markus1982 Linux - Security 11 01-27-2003 01:25 AM


All times are GMT -5. The time now is 11:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration