LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-22-2004, 02:56 AM   #1
tmlayton
LQ Newbie
 
Registered: Jun 2004
Posts: 3

Rep: Reputation: 0
Angry SuSE 9.0 can browse LAN, ping router...cannot get on the internet


I have a sony laptop with suse 9.0 installed. I did a ftp network install at work and it went fine and I was able to connect to the internet. When I brought it home I could no longer connect to the internet, but I could still see the local network. When suse is booting and it reaches the DHCP request part, it fails (which is weird, I'll get back to this in a minute). After I had these issues at home I brought it back to work thinking I would be okay there...wrong, the internet still did not work.

I have been reading tons of these posts and most frequently asked for is the ifconfig, so here it is:

eth0 Link encap:Ethernet HWaddr 08:00:46:2A:CE:69
inet addr:192.168.0.103 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::a00:46ff:fe2a:ce69/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:10 errors:0 dropped:0 overruns:0 frame:0
TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:1068 (1.0 Kb) TX bytes:1128 (1.1 Kb)
Interrupt:9 Base address:0x3000 Memory:f4100000-f4100038

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:40 errors:0 dropped:0 overruns:0 frame:0
TX packets:40 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2608 (2.5 Kb) TX bytes:2608 (2.5 Kb)

Before when I said it was weird that the DHCP failed, I say this because the IP of 192.168.0.103 was assigned via DHCP and the router lists the machine in the DHCP clients table. Also without a valid IP, the machine wouldn't be able to browse the local network, which again it can. The sad thing in this whole situation is I just installed linux to do some browser compatibility testing on some web apps, so basically the only thing I need it for is the only thing that isn't working.

My local network is setup as follows: DSL modem > Netgear router (the quality blue metals ones, not the bad silver plastic ones) > Netgear 10/100 5 port hub (okay, this one is the bad plastic silver one) > various other uplinked hubs. Is there any known issue of certain routers dropping the http/ftp request from linux (I am just thinking of anything I can)?

That same machine has WinXP installed as well. If I boot into XP instead of linux, I can get on the net just fine. And again, I did a network install and have browsed the net before so the network card config should be okay, but you never know. That is everything I can think of, and thanks in advanced for the help.
 
Old 06-24-2004, 03:28 AM   #2
karatedog
LQ Newbie
 
Registered: May 2004
Location: Hungary
Distribution: Ubuntu 9.10
Posts: 13

Rep: Reputation: 0
I'm suffering from the same problem. Connection is fine, but no internet. When I manually down-ed the eth0 interface (ifconfig eth0 down) internet immediately came back. The problem is now that I cannot get the network interface working again, not even by restarting Suse. The bootloader fails... :-(((
So if you can manually config network card, you may give this a try (it won't solve the problem thoug, just getting closer...)
 
Old 06-24-2004, 06:43 AM   #3
andrewdodsworth
Member
 
Registered: Oct 2003
Location: United Kingdom
Distribution: SuSE 10.0 - 11.4
Posts: 347

Rep: Reputation: 30
Need a default gateway which = your router IP address for internet to work. Also DNS resolving. This is normally automatically set up by DHCP but doesn't appear to be working for you.

There are a number of ways to find this out - command line first

try route at a command prompt it should look something like this

Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
default 192.168.1.1 0.0.0.0 UG 0 0 0 eth0

If there is no default gateway then:

route add default gw 192.168.x.x(your router IP address)

should do it (but have a look at the man pages)

If you can then use browser with http://IPnumber but not with names you then need to get DNS resolving to work. If you know the DNS server IP addresses for your ISP then you can add them to your /etc/resolv.conf (need to su to root to amend this file) as:

nameserver x.x.x.x
nameserver x.x.x.y

All of this can be done using YaST .. network devices .. network card. Click on change button on bottom box then edit and the hostname and nameserver button gets you to the DNS server boxes and the routing button gets you to the default gateway box.

What could have happened is that your machine has got confused by you installing at work and then moving to home. You could always as a first instance use YaST to remove the card, reboot and then it will rediscover it on boot (just like windows) and set it up again.

Good luck.
 
Old 06-29-2004, 03:44 AM   #4
karatedog
LQ Newbie
 
Registered: May 2004
Location: Hungary
Distribution: Ubuntu 9.10
Posts: 13

Rep: Reputation: 0
How can I automatically set up my network interface on boot? Since I manually down-ed eth0, it is not set up at bootload (and no problems reported).
I tried to configure it via Yast, with no luck. It could be manually up-ed, and it works fine.
 
Old 06-29-2004, 03:05 PM   #5
andrewdodsworth
Member
 
Registered: Oct 2003
Location: United Kingdom
Distribution: SuSE 10.0 - 11.4
Posts: 347

Rep: Reputation: 30
Have a look in /etc/sysconfig/network/ for ifcfg-eth0 which should contain the settings for your network card. Mine looks like this (it's a static IP address so has entries for BROADCAST,NETMASK and NETWORK):

BOOTPROTO='static'
BROADCAST='192.168.1.255'
IPADDR='192.168.1.250'
MTU=''
NETMASK='255.255.255.0'
NETWORK='192.168.1.0'
REMOTE_IPADDR=''
STARTMODE='onboot'
UNIQUE='xxxxxxxxxxxxxxxx'

STARTMODE='onboot' tells it to start on boot - yours may have something different if so change it to 'onboot'

For info my laptop which uses dhcp has:

BOOTPROTO='dhcp'
MTU=''
REMOTE_IPADDR=''
STARTMODE='onboot'
UNIQUE='xxxxxxxxxxxxxxxx'
 
Old 06-30-2004, 03:43 AM   #6
Venom81
LQ Newbie
 
Registered: Jun 2004
Location: germany
Distribution: SuSE 9.0 PRO
Posts: 1

Rep: Reputation: 0
i had the same prob when i took my linux box with me to a lan a few weeks ago.

The problem was easy to solve on 9.0:

use yast2, go to "network services" -> "routing" and enter the ip of your router in the Standard Gateway field, this should get ur internet connection running through the router.

hope it helps, maybe the steps don't match the english version since i use the german version.

Last edited by Venom81; 06-30-2004 at 03:44 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can ping but cannot browse the internet koolgentoo Linux - Wireless Networking 15 05-01-2005 11:53 PM
Cannot browse internet or ping DanielTan Linux - Networking 1 02-01-2005 04:47 AM
Cant browse internet even though I can ping site pazzport Linux - Wireless Networking 8 01-27-2005 12:51 PM
SuSE 9.2 Internet over LAN to Router bmcgregor3 Linux - Networking 2 01-24-2005 07:53 PM
can't browse internet but can ping cj7_laredo Fedora 3 01-21-2004 11:43 PM


All times are GMT -5. The time now is 08:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration