LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 02-22-2005, 07:44 PM   #1
pyschomike15
Member
 
Registered: Jan 2003
Distribution: Slackware 10.1
Posts: 46

Rep: Reputation: 15
Slow network speeds


I have been noticing that all programs that go out to the internet have been running slow on my computer. Ping runs incredibly slow and takes well over a minute to give me any results. Also Firefox doesnt look up websites very fast at all, in fact I think it stopped trying alltogether. I am currently posting this message on windows because the request times out in linux. In windows the speeds are great and nuthing is wrong. I have done the command "route add default gw 192.168.1.1" to make the default route. Ip addresses and configured correctly through dhcp on my router, yet still the speeds are very slow. What could cause this slow access time and how do I fix it?

Mike
 
Old 02-22-2005, 08:01 PM   #2
broch
Member
 
Registered: Feb 2005
Distribution: Arch current, SuSe 10.1 32-bit, FreeBSD current, OpenBSD 4.0
Posts: 453

Rep: Reputation: 30
maybe start with disabling ipv6?
 
Old 02-22-2005, 08:36 PM   #3
pyschomike15
Member
 
Registered: Jan 2003
Distribution: Slackware 10.1
Posts: 46

Original Poster
Rep: Reputation: 15
Does that require a kernel recompile, and if not how do I do that?
By the way I have 2 network cards an ethernet and a wireless (this is a laptop).

Thanks,
Mike
 
Old 02-22-2005, 09:32 PM   #4
broch
Member
 
Registered: Feb 2005
Distribution: Arch current, SuSe 10.1 32-bit, FreeBSD current, OpenBSD 4.0
Posts: 453

Rep: Reputation: 30
Quote:
Does that require a kernel recompile, and if not how do I do that?
No
open terminal su as root and then enter:
echo "alias net-pf-10 off" >> /etc/modprobe.conf
echo "alias ipv6 off" >> /etc/modprobe.conf

netx open Firefox in the address line enter:
about:config
next in the filter line enter ipv6
and doubleclick on
network.dns.disableIPv6 so the value willchange to "true"

restart network (or computer).
I hope that this will help
 
Old 02-23-2005, 02:28 PM   #5
pyschomike15
Member
 
Registered: Jan 2003
Distribution: Slackware 10.1
Posts: 46

Original Poster
Rep: Reputation: 15
Thanks for all your help I think my internet applications are alot quicker now.

Mike
 
Old 02-25-2005, 01:18 PM   #6
pyschomike15
Member
 
Registered: Jan 2003
Distribution: Slackware 10.1
Posts: 46

Original Poster
Rep: Reputation: 15
My network still seams to be going slightly slower than when I am windows. What other things can I do to improve proformance?

Mike
 
Old 02-25-2005, 06:31 PM   #7
fur
Member
 
Registered: Dec 2003
Distribution: Debian, FreeBSD
Posts: 310

Rep: Reputation: 35
are your DNS servers set the same on both computers?

Linux..

cat /etc/resolv.conf



Windows...

ipconfig /all
 
Old 02-25-2005, 07:33 PM   #8
broch
Member
 
Registered: Feb 2005
Distribution: Arch current, SuSe 10.1 32-bit, FreeBSD current, OpenBSD 4.0
Posts: 453

Rep: Reputation: 30
can you define slower?
on average I have on SuSe 353 KB/sec and on windows (different machine) 380 KB/sec transfer rate.
For a standard workstation this difference is negligible.

anyway can you post the results about:
1. your NIC
2. /etc/resolv.conf
3. network (direst connect, home LAN behind router)
3. connection type
3. txqueuelen and MTU value
#ifconfig
4. value of window scaling
#sysctl -a | grep scaling
and look for:
net.ipv4.tcp_window_scaling
5. sack value
#sysctl -a | grep sack
and look for
net.ipv4.tcp_sack
6. path MTU discovery
#sysctl -a | grep disc
and look for
net.ipv4.ip_no_pmtu_disc
 
Old 02-27-2005, 03:19 PM   #9
pyschomike15
Member
 
Registered: Jan 2003
Distribution: Slackware 10.1
Posts: 46

Original Poster
Rep: Reputation: 15
Both Windows and Linux use different DNS servers:

In Windows its only 192.168.1.1 which is my router, and in Linux it says:

nameserver 24.51.159.130
nameserver 24.51.159.133
search chvlva.adelphia.net

I have 2 network cards 1 wireless and the other is gigabit ethernet. ifconfig shows for the wireless:

eth0 Link encap:Ethernet HWaddr 00:06:25:29:D0:AB
inet addr:192.168.1.205 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:14414 errors:0 dropped:0 overruns:0 frame:0
TX packets:13090 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3149720 (3.0 Mb) TX bytes:1592650 (1.5 Mb)
Interrupt:3 Base address:0x100

The I dont use the gigabit much since this is a laptop.

Windows scaling:

error: unknown error 22 reading key 'net.ipv4.route.flush'
net.ipv4.tcp_window_scaling = 1

Sack value:

error: unknown error 22 reading key 'net.ipv4.route.flush'
net.ipv4.tcp_dsack = 1
net.ipv4.tcp_sack = 1

MTU discovery:

error: unknown error 22 reading key 'net.ipv4.route.flush'
net.ipv4.ip_no_pmtu_disc = 0

I have no idea what that error mean however it might be the problem.

Oh and when I say slow it takes about 30-45 seconds to "look up" google.com after it finds the site the pings go normal speed. I believe this is some sort of DNS problem.

Mike
 
Old 02-27-2005, 06:26 PM   #10
broch
Member
 
Registered: Feb 2005
Distribution: Arch current, SuSe 10.1 32-bit, FreeBSD current, OpenBSD 4.0
Posts: 453

Rep: Reputation: 30
don't worry about error
change this to zero
net.ipv4.tcp_window_scaling = 0
edit /etc/sysctl.conf
and add the line above.
save it and run
sysctl -p

configure gateway:
192.168.1.1

That is not the same as nameserver. So you don't need to modify /etc/resolv.conf
(By the way I suggest to change windows settings to:
DNS servers
24.51.159.130
24.51.159.133

gateway
192,168.1.1

Sorry, I don't have any experience with wireless card. I assume that eth0 is an gigabit. So where is a configuration of the wireless card?

It does seem that wireless card is not configured.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Very slow transfer speeds via LAN TBomb Linux - Networking 6 07-26-2005 08:34 AM
SLow Speeds ETH1 > ETH0 > Local network - Help!!! Tekel Linux - Networking 2 09-29-2004 05:12 PM
Some Samba research on slow speeds Ada Linux - Networking 0 08-07-2004 04:14 PM
Excessively slow network transfer speeds from XP to Linux… MooGLEX Linux - Networking 1 07-04-2004 01:13 AM
Slow upload speeds after upgrade Shadoan Linux - Networking 0 08-28-2003 11:36 AM


All times are GMT -5. The time now is 06:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration