LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-26-2005, 11:14 AM   #1
septanla
Member
 
Registered: Sep 2003
Posts: 69

Rep: Reputation: 15
slow DNS resolution in Ubuntu


I encounter slow domain name resolution in mozilla firefox. My system is
UBUNTU 2.6.10-5-686 kernel.. THe network schema is ADSL modem >> TLink -WR541G router >> my computer.

The model of my computer is IBM thinkpad T21, with dual system of Ubuntu and Winxp.

My problem is that it takes me a very long time to resolve a domain name (in the status bar of firefox, the words "looking up ....domain name..." stay for a long time. Quite often, the name was not resolved and timed out.
I tried to ping google or yahoo website, it is slow, sometime, timed out.

I have searched the posts and confirned that modifying the file /etc/resolv.conf did not help (not matter I change it to previous one plus 192.168.1.1 or not). THe IP address is the same as the DNS server displayed using ipconfig /all in Winxp.

Now the thing is that Winxp can resolve simialr webiste quite fast. (note, in order my network (non-wireless one, eth0) card to work, I add apci=off in menu.lst. (not sure whehter this will affect wireless eth1. But another post I googeled, suggest to change acpi=hd noacpi. but this does not help. I also disable IP6 by add "alias net-of-10 off" in /etc/modprobe.d/alias, still does not work.

Here I post the part of the result of ifconfig:

eth1 Link encap:Ethernet HWaddr 00:09:5B:92:B5:80
inet addr:192.168.1.2 Bcast:255.255.255.255 Mask:255.255.255.0
inet6 addr: fe80::209:5bff:fe92:b580/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2495 errors:0 dropped:0 overruns:0 frame:0
TX packets:2882 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1896979 (1.8 MiB) TX bytes:477766 (466.5 KiB)
Interrupt:11

Here is the content of /etc/resolv.conf

search domain
nameserver 202.96.128.68
nameserver 202.96.134.188
nameserver 202.96.134.133
nameserver 192.168.1.1

This problem had bothered my serveral months. I am very appreciated if u can give me some suggestions.

Cheers

Septanla
 
Old 08-26-2005, 01:08 PM   #2
primo
Member
 
Registered: Jun 2005
Posts: 542

Rep: Reputation: 34
Go to Firefox/Mozilla and disable IPv6. Type "about:config" then set
network.dns.disableIPv6 to true
 
Old 08-27-2005, 07:49 PM   #3
septanla
Member
 
Registered: Sep 2003
Posts: 69

Original Poster
Rep: Reputation: 15
Hi, primo, I change the configuration as you recommended. However, things do not change. Resolving is still slow for some website. However, I find in Redhat 9.0, the resolving is fast.

I even tried to flush out the cache in the router using ipconfig /flushdns in windows XP and restart modem and router, it does not help too.

I would be very appreciated if you can remind me any ohter configuration I can resort to to resolve the problem. My ubuntu works very well except the slow domain resolving problem for months. :-(

Cheers
 
Old 08-28-2005, 12:59 PM   #4
primo
Member
 
Registered: Jun 2005
Posts: 542

Rep: Reputation: 34
traceroute each server to see which one is nearest you

What does /etc/host.conf contain?
/etc/nsswitch.conf ?

I currently run a caching-nameserver on my box that talks directly to the root nameservers. It gives me both speed and some privacy. You may try...
 
Old 08-28-2005, 07:17 PM   #5
aznluvsmc
Member
 
Registered: Aug 2004
Location: Newmarket, Ontario
Distribution: OpenSuse 10.2
Posts: 184

Rep: Reputation: 30
First of all, take out the search domain line in /etc/resolv.conf. That is causing a DNS recursion to search for names in the domain zone which doesn't exist. As a side note you can only have a maximum of three name servers listed. Anymore will be useless.
 
Old 08-30-2005, 02:47 AM   #6
septanla
Member
 
Registered: Sep 2003
Posts: 69

Original Poster
Rep: Reputation: 15
Hi, Primo:
this is the result

traceroute each server to see which one is nearest you

What does /etc/host.conf contain?
--------------

order hosts,bind
multi on
-----------------
/etc/nsswitch.conf

# /etc/nsswitch.conf
#
# Example configuration of GNU Name Service Switch functionality.
# If you have the `glibc-doc' and `info' packages installed, try:
# `info libc "Name Service Switch"' for information about this file.

passwd: compat
group: compat
shadow: compat

hosts: files dns
networks: files

protocols: db files
services: db files
ethers: db files
rpc: db files

netgroup: nis

----------------

It does not matters if I change the order of the three DNS servers.

I also want to install a local caching for DNS server. and I followed Unofficial Ubuntu 5.04 Starter Guide

sudo apt-get install dhcp3-server

But, it gave an error message:
----------------
Starting DHCP server: dhcpd3 failed to start - check syslog for diagnostics.
invoke-rc.d: initscript dhcp3-server, action "start" failed.
----------------

any ideas?

Also the domain name resolution problem becomes better when I change the DNS server list to: 62.41.128.51 and 62.41.128.52. I get this from another post in linuxquestions. Is there any better solution?

Cheers

Septanla
 
Old 08-30-2005, 02:49 AM   #7
septanla
Member
 
Registered: Sep 2003
Posts: 69

Original Poster
Rep: Reputation: 15
Hi, aznluvsmc:

I tried ur suggestions, however, it does not work out. even I remove 'search domain' line, it is still very slow and in some cases timed out.

Thanks a lot for your input!

Septanla
 
Old 05-11-2009, 05:40 PM   #8
cicciobello
LQ Newbie
 
Registered: May 2009
Posts: 1

Rep: Reputation: 0
This is how I solved it...

Quote:
Originally Posted by septanla View Post
I encounter slow domain name resolution in mozilla firefox. My system is
UBUNTU 2.6.10-5-686 kernel.. THe network schema is ADSL modem >> TLink -WR541G router >> my computer.

The model of my computer is IBM thinkpad T21, with dual system of Ubuntu and Winxp.

My problem is that it takes me a very long time to resolve a domain name (in the status bar of firefox, the words "looking up ....domain name..." stay for a long time. Quite often, the name was not resolved and timed out.
I tried to ping google or yahoo website, it is slow, sometime, timed out.

I have searched the posts and confirned that modifying the file /etc/resolv.conf did not help (not matter I change it to previous one plus 192.168.1.1 or not). THe IP address is the same as the DNS server displayed using ipconfig /all in Winxp.

Now the thing is that Winxp can resolve simialr webiste quite fast. (note, in order my network (non-wireless one, eth0) card to work, I add apci=off in menu.lst. (not sure whehter this will affect wireless eth1. But another post I googeled, suggest to change acpi=hd noacpi. but this does not help. I also disable IP6 by add "alias net-of-10 off" in /etc/modprobe.d/alias, still does not work.

Here I post the part of the result of ifconfig:

eth1 Link encap:Ethernet HWaddr 00:09:5B:92:B5:80
inet addr:192.168.1.2 Bcast:255.255.255.255 Mask:255.255.255.0
inet6 addr: fe80::209:5bff:fe92:b580/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2495 errors:0 dropped:0 overruns:0 frame:0
TX packets:2882 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1896979 (1.8 MiB) TX bytes:477766 (466.5 KiB)
Interrupt:11

Here is the content of /etc/resolv.conf

search domain
nameserver 202.96.128.68
nameserver 202.96.134.188
nameserver 202.96.134.133
nameserver 192.168.1.1

This problem had bothered my serveral months. I am very appreciated if u can give me some suggestions.

Cheers

Septanla
I had the same problem. I use OpenDNS. Followed these simple instructions from OpenDNS, instead of changing the DNS from the "Network" icon and now it is super fast!

# Right-click on ‘Network Icon’ (located at top-right panel by default) and click on ‘Edit Connections’ to open Network Connections Manager.
# Choose the type of connection you have. For this example, we will use ‘Wired’.
# Under ‘Wired’, highlight ‘Auto etho’ and click on ‘Edit’.
# Inside 'Editing Auto etho' window, click on ‘IPv4 Settings’ tab.
# Under ‘IPv4 Settings’, change the ‘Method’ to Automatic (DHCP) addresses only.
# Put these nameserver addresses as your ‘DNS Servers’: 208.67.222.222, 208.67.220.220
# Click ‘OK’ and reboot your machine.

Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vmware, ubuntu guest, firefox slow URL resolution JordanH Ubuntu 0 09-20-2005 08:27 PM
Extremely Slow DNS Host Resolution longsword84 Linux - Networking 3 04-01-2005 04:19 PM
DNS resolution takes forever on Ubuntu Motown Linux - Networking 3 03-10-2005 08:35 PM
DNS resolution suddenly became slow.. please help Sheado Linux - Networking 3 11-14-2004 02:53 PM
DNS Name Resolution Slow on Internet mooreted Linux - Networking 3 12-25-2003 02:57 PM


All times are GMT -5. The time now is 04:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration