LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-11-2007, 02:56 PM   #1
nirmaltom
Member
 
Registered: Jun 2005
Location: India
Distribution: Redhat,Fedora,DSL,Ubuntu
Posts: 238

Rep: Reputation: 30
Lightbulb setup needed to run web servers using free dns services


hi,
i want to run a webserver from dns service provided by dyndns.com or easydns.org.so i installed apache webserver and the page loads well in my system but not on the internet.The site even says it is possible to run ftp,etc.
Does it require a slave dns bind configuration ?As it is a free service they have some top level domain names, and we have to create under it.
Ex.
<oursitename>.homeunix.com
Anybody experienced in these sites ,plz help me.

regards,
Tom.
 
Old 01-11-2007, 08:53 PM   #2
puntjuh
Member
 
Registered: Apr 2006
Location: holland
Distribution: Gentoo / debian / suse / mint
Posts: 558

Rep: Reputation: 41
i have a website running on my own home server, using dyndns.org service.

All i had to do was make it on dyndns, activate dyndns service in my router! And then just make a VHost in apache config file.

And do have port 80 open so sites can be visited from outside.
 
Old 01-12-2007, 02:40 AM   #3
nirmaltom
Member
 
Registered: Jun 2005
Location: India
Distribution: Redhat,Fedora,DSL,Ubuntu
Posts: 238

Original Poster
Rep: Reputation: 30
Question

Quote:
Originally Posted by puntjuh
activate dyndns service in my router!
hi,
i have done all the things done except this quote.can u please explain me that.
My internet connection is through pppoe.will it uses a router or acts as a router.
thanks and regards,
Nirmal Tom.
 
Old 01-12-2007, 09:07 AM   #4
puntjuh
Member
 
Registered: Apr 2006
Location: holland
Distribution: Gentoo / debian / suse / mint
Posts: 558

Rep: Reputation: 41
Well, in my modem/router that was given to me by my provider, there was a section in it named: DDNS. In here, i had to provide my username/password from DynDNS. If i didn't do this, my dyndns didn't work.
 
Old 01-12-2007, 01:10 PM   #5
maybbach
Member
 
Registered: Feb 2004
Location: Cincinnati, OH
Distribution: SimplyMepis 3.3
Posts: 68

Rep: Reputation: 15
there's different types of free ddns services you can use. i use no-ip (which also is registered as multiple other domain names). when you create a free account and setup ddns, there's a client you can download and run on your pc that will run as a service/daemon. the program will point your ip address to a domain of your choosing. so you can browse to www.mydomain.no-ip.com and view pages on your web server
 
Old 01-13-2007, 07:27 AM   #6
nirmaltom
Member
 
Registered: Jun 2005
Location: India
Distribution: Redhat,Fedora,DSL,Ubuntu
Posts: 238

Original Poster
Rep: Reputation: 30
hi,
let me more descriptive
my private ip:192.168.1.254
subnet mask:255.255.255.0
my ISP gave me an ethernet modem(PPPOE)
its ip is 192.168.1.1
so my,
gateway 192.168.1.1
primary dns 192.168.1.1
and i have to supply username and password to connect to the internet
Every time i connect to internet it gives me a new ip(dynamic)
121.247.254.174(this time)

i registered in dyndns.com with the username nirmaltom and registered the domain
autokanson.homeunix.com.I downloaded ddclient to update my ip in their dns.It runs as a service(like maybbach said).It works fine and checked it manually by getting into their site.
Modify Dynamic DNS autokanson.homeunix.com
IP in Database/DNS: 121.247.254.174
Last Updated: Sat Jan 13 06:00:09 2007

So i think this part works fine.But i am not able to get my desired output (i.e)my web page on internet.I have opened my ports 80 on iptables.

My queries are
1) do i need port forwading?After all have ethernet modem,not possible a router!(quite confusing)

2)my contents in /etc/hosts are only the loopback address and /etc/resolv.conf are
nameserver 202.54.29.5
nameserver 202.54.6.60

do i need to add something to this?

3)I set this machines host name as server.room.com(for my private room network)
Its a virtual host configuration in apache.I need clarification in it.In section2 of its configuration file,i set the directive ServerName
ServerName autokanson.homeunix.com:80
is it correct as its a virtual host?

4)Also in section3 virtual hosts,i set
NameVirtualHost autokanson.homeunix.com:80

OUTPUT of httpd -S:

[root@server ~]# httpd -S
VirtualHost configuration:
121.247.254.174:80 is a NameVirtualHost
default server autokanson.homeunix.com (/etc/httpd/conf/httpd.conf:990)
port 80 namevhost autokanson.homeunix.com (/etc/httpd/conf/httpd.conf:990)
wildcard NameVirtualHosts and _default_ servers:
_default_:443 autokanson.homeunix.com (/etc/httpd/conf.d/ssl.conf:81)
Syntax OK
[root@server ~]#

is it correct?


Thanks a lot for ur valuable time

regards,
Tom.

Last edited by nirmaltom; 01-13-2007 at 07:39 AM.
 
Old 01-13-2007, 08:02 AM   #7
nirmaltom
Member
 
Registered: Jun 2005
Location: India
Distribution: Redhat,Fedora,DSL,Ubuntu
Posts: 238

Original Poster
Rep: Reputation: 30
hi,
a little update it might be a router when i type its address in my browser it asks me an user name and password,and pitty, i dont know what to give?
regards,
Tom.
 
Old 01-13-2007, 12:09 PM   #8
maybbach
Member
 
Registered: Feb 2004
Location: Cincinnati, OH
Distribution: SimplyMepis 3.3
Posts: 68

Rep: Reputation: 15
Virtually every cable/dsl modem sent by ISP's now is a router/firewall also, so I'm thinking port forwarding isn't properly configured. go to www.canyouseeme.org, and it will tell you what your public ip address is. in the box, type in 80 for the port to verify that port 80 is open on your router. if port 80 isnt open then the problem has nothing to do w/ dns. then try to log into your dsl router and see if you can change the settings. if you have your own router as well, you'll need to open up the ports on that router also. if port shows up successfully, then use nslookup on autokanson.homeunix.com and make sure the ip address is correct.

i did a port scan and it doesnt seem you have any ports open, so im guessing its a firewall issue.
 
Old 01-15-2007, 01:30 PM   #9
nirmaltom
Member
 
Registered: Jun 2005
Location: India
Distribution: Redhat,Fedora,DSL,Ubuntu
Posts: 238

Original Poster
Rep: Reputation: 30
hi,
a little bit lucky,my ISp today replaced it with a new one Billion Bipac 5200s.
It has a ddns section and NAt section.I will try it up and tell u the results,
Thanks a lot
regards,
Nirmal Tom.
 
Old 01-15-2007, 03:39 PM   #10
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 48
nirmaltom, the problem is entirely on your LAN.

I just did this command, which asks for the DNS info for your address:
Code:
jim@jimsworktop:~$ dig autokanson.homeunix.com

; <<>> DiG 9.3.3 <<>> autokanson.homeunix.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 25374
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 5, ADDITIONAL: 5

;; QUESTION SECTION:
;autokanson.homeunix.com.       IN      A

;; ANSWER SECTION:
autokanson.homeunix.com. 60     IN      A       121.247.255.45
Ok, so we know your real world IP address. Now, is port 80 open:

Code:
jim@jimsworktop:~$ telnet autokanson.homeunix.com 80
Trying 121.247.255.45...
telnet: Unable to connect to remote host: Connection timed out
So I can't get all the way from my place to your webserver, or I did and your service wasn't running.

Also, with regards to your apache configs, you don't need to make the sitename identical to the DNS name. They don't even need to be remotely close. Your apache config is just for your machine. Just because autokanson.homeunix.com is the name people are using DNS to get to your machine, you don't need to name the site autokanson.homeunix.com. I would for clarity, but naming the virtual host as you did "121.247.254.174:80" doesn't make much sense. What about when your address isn't 121.247.254.174? It will still work because as I said they can be different, but some system or order will help when it's time to troubleshoot problems.

What you need to do going forward - You need to set the router so that the webserver has the same internal address all of the time. I have found it easiest to set the DHCP on the router so the server always gets the same internal address, the aforementioned 192.168.1.254. Then the router needs to be set to port forward anything from the outside real world address at port 80 or 443 to the inside address of 192.168.1.254 at 80 or 443. 2 forwarding rules will do it.

The ddns thing on the router just replaces the ddns client you put on your machine, but you really don't need both. As long as you have the one on the webserver working, there is no need to impliment in on the router too.

Peace,
JimBass
 
Old 01-16-2007, 04:09 AM   #11
nirmaltom
Member
 
Registered: Jun 2005
Location: India
Distribution: Redhat,Fedora,DSL,Ubuntu
Posts: 238

Original Poster
Rep: Reputation: 30
hi,
i set NAT virtual server mapping and stopped firwall on both the system and router
but http://www.canyouseeme.org/ fetches me the following error

Error: I could not see your service on 121.247.214.200 on port (80)
Reason: Connection timed out

thanks
regards,
Tom.
 
Old 01-16-2007, 04:59 AM   #12
nirmaltom
Member
 
Registered: Jun 2005
Location: India
Distribution: Redhat,Fedora,DSL,Ubuntu
Posts: 238

Original Poster
Rep: Reputation: 30
hi,
seems my isp gateway is not running their webservice on port 80
nmap 121.247.214.1

Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2007-01-16 16:02 IST
RTTVAR has grown to over 2.3 seconds, decreasing to 2.0
RTTVAR has grown to over 2.3 seconds, decreasing to 2.0
Interesting ports on 121.247.214.1.chennai-dynamic-bb.vsnl.net.in (121.247.214.1):
Not shown: 1677 closed ports
PORT STATE SERVICE
135/tcp filtered msrpc
139/tcp filtered netbios-ssn
445/tcp filtered microsoft-ds

Nmap finished: 1 IP address (1 host up) scanned in 67.335 seconds


http://www.dnsstuff.com/tools/aboutyou.ch says about me as


Your IP Version: IPv4
Your IP: 121.247.214.200 (port 39257)
Your ASN: 0 [IANA-RSVD-0]. ASN Registrar: ARIN
Your country: India
Your User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061018 BonEcho/2.0
Your Browser: uses Gecko Engine [date=20061018]
Your Operating System:
(from TCP/IP headers) Unix
Your Operating System:
(from browser string) X Window System, Linux

it shows me the port no as 39257
so, how i should make apache to listen on this port too

well,before for browsing i had only ports 80 and 443 opened
I think there is some sort of mapping.Any ideas and suggestions plz.


regards,
Nirmal Tom.

Last edited by nirmaltom; 01-16-2007 at 05:33 AM.
 
Old 01-16-2007, 11:37 AM   #13
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 48
No man, I think you're misunderstanding. The browser port isn't what port your computer will allow connections on, it is what port your client computer connected to their computer (the server) at. Your machine sent a request to them (dnsstuff) at port 80, and in your case, their server said "connection received, move to port 39257 for info". When I just did it, I used port 63075, but I can promise you I am not running a webserver on port 63075!

Your ISP has no need to run a webservice on a gateway. Why would you think they would? Your gateway is probably a router, not a webserver. As an ISP, they have many addresses available to use, they wouldn't try and host websites on the same IP that is a gateway for clients.

There is no mapping sir! All you need open is ports 80 and 443. However, it still doesn't connect. Let's do this piece by piece.

1) From your webserver, open a browser (if you have X windows installed, if not, use lynx), and send it to http://localhost . It should see your website. If not, apache isn't configured right.

2) From another computer on your LAN, go to the webservers local IP, which you said previously was http://192.168.1.254 . Does the other computer see your website?

3) Have any of us look at http://autokanson.homeunix.com , and if we see your site, port forwarding on your router is configured correctly. If not, then you need to tweak your router settings.

Peace,
JimBass
 
Old 01-16-2007, 03:50 PM   #14
nirmaltom
Member
 
Registered: Jun 2005
Location: India
Distribution: Redhat,Fedora,DSL,Ubuntu
Posts: 238

Original Poster
Rep: Reputation: 30
hi,
the first two points are working
Quote:
Originally Posted by JimBass
1) From your webserver, open a browser (if you have X windows installed, if not, use lynx), and send it to http://localhost . It should see your website. If not, apache isn't configured right.
its working fine
Quote:
Originally Posted by JimBass
2) From another computer on your LAN, go to the webservers local IP, which you said previously was http://192.168.1.254 . Does the other computer see your website?
its too working
Quote:
Originally Posted by JimBass
3) Have any of us look at http://autokanson.homeunix.com , and if we see your site, port forwarding on your router is configured correctly. If not, then you need to tweak your router settings.
its not working at all

Thanx and regards,
Tom
 
Old 01-16-2007, 03:59 PM   #15
nirmaltom
Member
 
Registered: Jun 2005
Location: India
Distribution: Redhat,Fedora,DSL,Ubuntu
Posts: 238

Original Poster
Rep: Reputation: 30
hi,
(sorry,as per my new router its local ip is 192.168.1.254 and my system ip is 192.168.1.11)
The status page in my router says,
Device Information

Firmware Version:
2.7.0.23(UE0.C2C)3.5.10.1
MAC Address:
00:04:ed:63:38:10
LAN
IP Address: 192.168.1.254
Subnet Mask: 255.255.255.0
DHCP Server: Enabled
NAT: Enabled

WAN
Virtual Circuit:PVC0
Status: Connected
Connection Type:Bridge
IP Address:N/A
Subnet Mask:N/A
Default Gateway:N/A
DNS Server:N/A

For port forwading,Virtual Server Listing page is set as

Rule Start Port End Port Local IPAddress
1 80 80 192.168.1.11
2 21 21 192.168.1.11
3 22 22 192.168.1.11
4 443 443 192.168.1.11

i have disabled the router firewall.
i dont know where i went wrong.
thanks and regards,
Nirmal tom.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: The Office-free life: Surviving on free Web-based services alone LXer Syndicated Linux News 0 12-22-2005 05:01 AM
Help needed: DNS server setup phonecian Linux - Networking 1 01-28-2005 05:43 PM
Help, what services are needed for a windows to access Linux servers Wolfy Linux - Networking 6 07-12-2004 08:36 PM
free web servers supporting Front page extensions? sachitha General 5 06-09-2004 11:59 AM
Best free web and e-mail servers grogers Linux - Software 1 11-30-2002 09:26 PM


All times are GMT -5. The time now is 07:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration