LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 01-08-2007, 07:10 PM   #1
ldmcclatchey
LQ Newbie
 
Registered: Jan 2007
Posts: 8

Rep: Reputation: 0
Samba Returns NT_STATUS_BAD_NETWORK_NAME


Hello, First of I'd like to say that I am new here, but I have seen similar posts. At least along the lines that Samba on the Linux Server cannot be accessed. On my Windows machines, when I try to browse the workgroup, it comes up with "The Server is not Configured for Transactions".

I am currently attempting to get my "windows network" to work using Samba 3.0.23 running under Suse Linux 10.2. I did not set up a high debug level on my logs yet, but I did check my "tmpdir" permissions. BTW, TmpDir is not set, but my /tmp directory is set to be world readable (1777). Following is my current smb.conf:

# Master Samba Configuration File
# Pieced together by Leon D. McClatchey
# Who is the owner of this system
#
# The Global Section
# Server set up Area
[global]
workgroup = McClatchey
realm = Dad.McClatchey.fam
security = user
password server = *
netbios name = Dad
server string = Dads Standard Samba Server
allow trusted domains = Yes
interfaces = lo, eth0
bind interfaces only = yes
name resolve order = host lmhosts wins bcast
time server = yes
server signing = Auto
max smbd processes = 1000
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_SNDBUF=8192 SO_RCVBUF=8192
log level = 3

# Global Printer Commands
printcap name = cups
printing = cups
cups options = raw

# Try to use the passdb system instead of the standard ansi system
# Plus the standard User Administration Commands
passdb backend = tdsam
map to guest = Bad User
guest account = nobody
passdb backend = smbpasswd:/etc/samba/smbpasswd
passwd program = /usr/bin/passwd %u
passwd chat = *password* %n\n *password* %n\n *changed*
passwd chat debug = yes
username map = /etc/samba/smbusers
unix password sync = yes
message command = csh -c 'xedit %s;rm %s' &
usershare allow guests = Yes
usershare max shares = 0
admin users = doug, root

# The following Scripts are to be used
# until I can get ldap working correctly
add user script = /usr/sbin/useradd -m %u
delete user script = /usr/sbin/userdel -r %u
add group script = /usr/sbin/groupadd %g
delete group script = /usr/sbin/groupdel %g
add user to group script = /usr/sbin/groupmod -A %u %g
delete user from group script = /usr/sbin/groupmod -R %u %g
add machine script = /usr/sbin/useradd -s /bin/false -d /var/lib/nobody %u

# Global Login Commands
# Default Login Script
# Per user logon scripts can be specfied in the user account using pdbedit
logon script = scripts\logon.cmd
logon path = \\%L\profiles\%U
logon drive = H:
logon home = \\%L\%U

# Domain Settings
domain logons = Yes
os level = 35
preferred master = Yes
local master = Yes
domain master = Yes
max protocol = NT
acl compatibility = winnt
wins proxy = yes
wins support = Yes
winbind uid = 10000-20000
winbind gid = 10000-20000
template homedir = /home/%U
template shell = /bin/bash
# winbind separator = +
winbind cache time = 600
winbind enum users = yes
winbind enum groups = yes
winbind use default domain = yes

# File System Global Commands
create mask = 0664
directory mask = 0775
case sensitive = No
hide dot files = No
msdfs proxy = no
restrict anonymous = no
nt acl support = Yes

# Available Shares, the first 5 are System Shares?
[homes]
comment = User Home Directories
valid users = %S
read only = No
browseable = No

[printers]
comment = All Printers
path = /var/spool/samba/
create mask = 0600
guest ok = Yes
printable = Yes
browseable = No

[netlogon]
comment = Network Logon Service
path = /var/lib/samba/netlogon/
guest ok = Yes
browseable = No

[Profiles]
comment = Roaming Profile Share
path = /var/lib/samba/profiles/
read only = No
profile acls = Yes

[Family]
comment = Family Files on Dad
path = /Family/
inherit acls = Yes

BTW, I have eliminated all shares in an attempt to at least get access to the network. I can access the network if I set up my Samba Server as a standalone server, but it does not solve the problem of accessing the server itself. I believe that if the problem accessing the Linux server can be solved, then the problems with accessing the workgroup/network would be solved as well.

I would appreciate any help that is available to solve this problem. BTW, I have searched the internet for solutions, but all I've ever seen is repeats of the same problem

Thanks Loads!
LDMcClatchey
 
Old 01-09-2007, 09:06 AM   #2
ScooterB
Member
 
Registered: Sep 2003
Location: NW Arkansas
Distribution: Linux Redhat 9.0, Fedora Core 2,Debian 3.0, Win 2K, Win95, Win98, WinXp Pro
Posts: 344

Rep: Reputation: 31
My experience with samba is to start very, very simple and build from there. My first suggestion is to make a very simple smb.conf file. Just a few lines of just the needed info. One thing you might want to look at is changing your server string to something shorter. Say "sambaserver". You have a couple of different protocols running here and Windows doesn't like all the names in snmp. The easiest way to get samba up and going is to start very simple, get connected and then expand/broaden from there. Do away with the acl's, etc to get started. Too many variables. Remember to restart samba after each config change and then you will have to wait for a few minutes for the network voting to take place and each machine to declare itself on the network. Now, having said all that. On the linux side, make sure that you have established shares that the windows clients can access. By that I mean that they have linux file permissions to access the files. As a last note, make sure that you have added the samba users as well as the linux users. Two different areas. If the samba users aren't added, they won't be able to browse the server. Take a look at these things and then repost.
 
Old 01-09-2007, 07:55 PM   #3
ldmcclatchey
LQ Newbie
 
Registered: Jan 2007
Posts: 8

Original Poster
Rep: Reputation: 0
Talking NT_STATUS_BAD_NETWORK_NAME Solved!

I'm not sure if it is in the smb.conf that I had posted here, but I had altered the log level (following a sample in the Samba Reference Manual) to:

log level = 3 passdb:5 auth:10 winbind:2

This gave me some clues in the log.smbd! There is a setting which SWAT sets to a default level

msdfs proxy = yes

This entry was in smb.conf but in the log whenever someone tried to login I got

refusing connection to dfs proxy share 'ipc$' (pointing to [whatever was stated in the smb.conf].

So, I commented out that entry, and the next time I tried to access the server, I connected. And the network works just great as well, just like it did before I did the upgrade! So, my recommendation would be to leave that particular entry alone, especially if you use swat to edit your smb.conf file

ldmcclatchey
 
Old 01-09-2007, 08:02 PM   #4
xjlittle
Member
 
Registered: Aug 2003
Location: Indiana
Distribution: fc6 sles9 & 10 kubuntu ubuntu-server
Posts: 240
Blog Entries: 2

Rep: Reputation: 30
FWIW you have to be very careful when using SWAT. Not only will it wipe out your entire smb.conf file (or at least it used to) it will put all sorts of entries in like that one referring to msdfs (which is btw microsoft distributed file system).
 
Old 01-09-2007, 08:33 PM   #5
ScooterB
Member
 
Registered: Sep 2003
Location: NW Arkansas
Distribution: Linux Redhat 9.0, Fedora Core 2,Debian 3.0, Win 2K, Win95, Win98, WinXp Pro
Posts: 344

Rep: Reputation: 31
I concur. I use webmin occasionally but never swat. Heard too many bad things.
 
Old 01-10-2007, 02:49 PM   #6
ldmcclatchey
LQ Newbie
 
Registered: Jan 2007
Posts: 8

Original Poster
Rep: Reputation: 0
Swat still rewrites your config The only reason I do use it occasionally is because of the links to the online help. BTW, that is rapidly becoming irrelevant since the online help does not contain any reference to the newer options. As a result I've been relying more on Kate with the online manual up and ready. But, what is webmin?
 
Old 01-10-2007, 02:54 PM   #7
xjlittle
Member
 
Registered: Aug 2003
Location: Indiana
Distribution: fc6 sles9 & 10 kubuntu ubuntu-server
Posts: 240
Blog Entries: 2

Rep: Reputation: 30
Webmin is a browser based system administration tool. Find it at http://webmin.com/ Let's don't hijack the thread so if you have any more questions start a new one.
 
Old 02-14-2007, 10:39 AM   #8
Unmindfulawe
Member
 
Registered: Aug 2005
Location: WI
Distribution: openSUSE 11.1/ TinyMe
Posts: 51

Rep: Reputation: 16
I was getting the same error that ldmcclatchey was getting and thankfully I found this thread.I used the same method of commenting out the line in the smb.conf file that read "msdfs proxy = no". After doing so this fixed my problem. Thank you for that easy fix ldmcclatchey. You saved me many more hours of frustration.
 
Old 04-17-2007, 08:37 AM   #9
frenchrh
LQ Newbie
 
Registered: Jul 2004
Posts: 18

Rep: Reputation: Disabled
OpenSuse 10.2 samba server and VMWare6 Win Hosts

Thats great! I was having the same problem of "the server is not configured for transactions" and commenting out the "msdfs proxy = no" line in my smb.conf fixed it.

I'm running on a Dell Lattitude D620 Core duo with OpenSuse 10.2 host and using VMware workstation version 6 beta, to host two windows vm's, one of Winxp and on of Win2k. I have them on a small nat'ed network, and use the OpenSuse samba server to share my different data drives.

this all worked well with OpenSuse 10.1 and Vmware workstation 5.5.3, but the newer OpenSuse 10.2 wouldn't.

Its that default setting in smb.conf of "msdfs proxy = no" that caused the problem.
 
Old 09-25-2007, 08:37 AM   #10
vplessky
LQ Newbie
 
Registered: Sep 2007
Location: Moscow, Russia
Distribution: Mandriva 2007.1, Fedora 7
Posts: 3

Rep: Reputation: 0
Similar problem with SAMBA on Mandrake 2007.1

I had similar problem 'with SAMBA on Mandriva Linux 2007.1, after installing it from Discovery 2007 Live CD (DVD).

Code:
[vadim@TC1100 ~]$ smbclient -L notebook10
Password:
Anonymous login successful
Domain=[MDKGROUP] OS=[Unix] Server=[Samba 3.0.24]
tree connect failed: NT_STATUS_BAD_NETWORK_NAME
notebook10 is SAMBA host name for my desktop/server.
Problems indeed started when I launched SAMBA web configuration (SWAT) and used it to update current settings in smb.conf
As it is clear now, SWAT has for some reason default setting in VFS module options
option host msdfs = yes

Adding to [global] section of smb.conf option
Code:
msdfs proxy = no
resolves this problem.

Code:
[vadim@TC1100 ~]$ smbclient -L localhost
Password:
Anonymous login successful
Domain=[MDKGROUP] OS=[Unix] Server=[Samba 3.0.24]

        Sharename       Type      Comment
        ---------       ----      -------
        VADIM_MUSIC     Disk      /home/vadim/Music
        IPC$            IPC       IPC Service (Samba Server on TC1100 3.0.24)
Anonymous login successful
Domain=[MDKGROUP] OS=[Unix] Server=[Samba 3.0.24]

        Server               Comment
        ---------            -------
        MSI-MEGABOOK271      MSI-Megabook
        NOTEBOOK10           Samba Server on TC1100 3.0.24
        VADIM-ASUS           Guest room

        Workgroup            Master
        ---------            -------
        MDKGROUP             NOTEBOOK10
It's interesting that I didn't have such problem with Mandriva Linux 2007 Powerpack+ edition.
During installation of Mandriva 2007 Powerpack (Fall 2006) I selected options to install SAMBA server from the very beginning, and it was working out-of-the box.
Discovery Live CD (DVD) was not prompting for such option, that's why I had to add samba-server package manually later. And do hand-tuning of numerous options.

Best regards,
Vadim Plessky

Last edited by vplessky; 09-25-2007 at 01:03 PM.
 
  


Reply

Tags
networking, samba


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
samba & NT_STATUS_BAD_NETWORK_NAME wlfdgcrkz Linux - Software 10 05-19-2009 09:55 AM
samba: NT_STATUS_BAD_NETWORK_NAME sohmc Linux - Networking 7 12-21-2007 11:49 AM
NT_STATUS_BAD_NETWORK_NAME after Samba 3.0.23 patrokov Slackware 3 07-16-2006 11:56 PM
Samba symbolic share throwing NT_STATUS_BAD_NETWORK_NAME ala_frosty Linux - Software 1 03-31-2006 06:51 PM
Samba+windows printer=NT_STATUS_BAD_NETWORK_NAME rickenbacherus Linux - Networking 0 05-27-2004 05:28 PM


All times are GMT -5. The time now is 10:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration