LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-08-2007, 05:48 PM   #1
cyryl_the_wolf
Member
 
Registered: Aug 2006
Posts: 32

Rep: Reputation: 15
Angry Samba not working/supported in Suse 10.2?


I posted this in another thread, but then figured it wasn't the best thread for it. So I am making a new thread.

The biggest problem I'm having...I DIDN'T have with 10.1.

Or ANY Linux distribution BEFORE that.

I have actually installed 10.2 on three different systems and EACH ONE has had the very same problem.

SAMBA DOESN'T WORK.

Any time I look at settings involving the Samba services, it says that the service 'is not configured' or any number of messages that indicate that the kernel doesn't have Samba (smbfs) support built in.

To be clear...I'm a little pissed off because I can't even remove it and reinstall it without Yast wanting to remove HALF of the goddamn operating system WITH it. (Especially where Gnome packages are concerned.) I tried downloading the newest (stable) source and recompiling...which it did successfully. NO EFFECT. Nothing changed.

If I use a URL such as "smb://Username@IP/share/folder" it actually allows me to browse the shares on my Windows server. However, in order to get MP3's to work in Amarok without having to transfer them to the HDD first, I have to mount the network share locally as an SMBFS mounted folder. (Amarok still sucks at streaming, apparently.) Upon trying to mount the remote share as a local folder using the SMBFS file type, it tells me that the kernel doesn't have built-in SMBFS support. I even downloaded and installed Samb4k to assist me in mounting the shares. It sees them, but it will only browse the share one folder deep before it gives me the usual error message.

I KNOW for a fact that Samba is installed. Since I started using Linux in 2000, I have ALWAYS checked any and all packages related to Samba.

It occurs to me that this isn't just a contained issue since I have installed 10.2 on three of my different machines and got the EXACT SAME RESULTS. I got perfect support for DVD and MP3's installed. I can play MP3's in Amarok. Just not when they're streamed. (It crashes Amarok when I try to play them directly from the share.)

It also occurs to me that Samba is related to MS's network sharing protocol...and MS got all bent out of shape during the development of 10.2...and Novell went and signed a contract with MS about this or that, "PLEASE DON'T SUE OUR USERS." etc.

Anyone else smell BS? I've NEVER had a problem with Samba until NOW. So it strikes me as a bit ODD.

Whatever. I just want to fix the problem.

Anyone have any ideas?
 
Old 01-09-2007, 01:25 AM   #2
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,475

Rep: Reputation: 87
Quote:
Originally Posted by cyryl_the_wolf
I posted this in another thread, but then figured it wasn't the best thread for it. So I am making a new thread.

The biggest problem I'm having...I DIDN'T have with 10.1.

Or ANY Linux distribution BEFORE that.
I've had -exactly- the same problem with Fedora Core 6, versus Fedora Core 3 and Red Hat 9 which I was using previously.

Quote:
I have actually installed 10.2 on three different systems and EACH ONE has had the very same problem.

SAMBA DOESN'T WORK.


Quote:
Any time I look at settings involving the Samba services, it says that the service 'is not configured' or any number of messages that indicate that the kernel doesn't have Samba (smbfs) support built in.
I get exactly the same errors when I try to use Fedora's GUI samba tools.

Quote:
To be clear...I'm a little pissed off because I can't even remove it and reinstall it without Yast wanting to remove HALF of the goddamn operating system WITH it. (Especially where Gnome packages are concerned.) I tried downloading the newest (stable) source and recompiling...which it did successfully. NO EFFECT. Nothing changed.
Ok, here we diverge. I solved the problem by doing exactly this - downloaded the stable source for Samba and compiled it myself. I suspect that you might have skipped actually installing the resulting binaries? What I did was to get the current stable source, then compile it. Then (since I remember from installing Fedora that I asked for SMB support) I realised that those old binaries must still be in my filing system. And, it seemed as if, even if I "make installed" my "own" samba, it left those old binaries around. So I did find / -name smb* and find / -name nmb* and first deleted these old "stock" binaries, then I physically copied the new binaries (which I compiled myself) over the old ones.

Then, I started samba each time I started up my Fedora system by editing /etc/rc.local and adding

smbd -D
nmbd -D

at the end. I also made up my own smb.conf and copied that over each smb.conf that I could find in my filing system. (There seemed to be multiple copies, and I simply replaced each one).

BUT - this only allowed Windows users to see "in" - I could still not "see out" (mount Windows shares to access files on them in Linux) - and it was again due to exactly the same problem you have - no SMBFS support in the kernel.

Quote:
.
.
.
sees them, but it will only browse the share one folder deep before it gives me the usual error message.

I KNOW for a fact that Samba is installed. Since I started using Linux in 2000, I have ALWAYS checked any and all packages related to Samba.
.
.
.
Anyone else smell BS? I've NEVER had a problem with Samba until NOW. So it strikes me as a bit ODD.

Whatever. I just want to fix the problem.

Anyone have any ideas?
I do smell some BS too. I can't see why distro packagers don't put SMBFS support in - apparently now either for FC6 or your distro.

My solution was to recompile my kernel. And, lo and behold, I found that they had not included SMBFS support - the entry in the menuconfig listing was unchecked. I simply checked it and recompiled the kernel and samba started working...

In summary this, you'll probably need to recompile your kernel and include SMBFS support into your "new" kernel...
 
Old 01-10-2007, 01:42 AM   #3
cyryl_the_wolf
Member
 
Registered: Aug 2006
Posts: 32

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by rylan76
I suspect that you might have skipped actually installing the resulting binaries?
No. I did complete the installation as well. To be honest, I even read the installation instructions to insure that I did it correctly. (Only a n00b would refuse to do so.)

I wonder if you could briefly summarize what you did for me? I'm gettin' along in Linux pretty well, but you seem to have used a couple of techniques that I am not quite familiar enough with yet. (Such as compiling the kernel with the SMBFS support. Not entirely familiar with menuconfig, either.)

Gettin' ready to try out Mandriva 2007 here... LOL.

I really wanna get SuSe 10.2 working, though. I don't wish to be 'konquered' by it!

*grins*
 
Old 01-10-2007, 02:45 PM   #4
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,475

Rep: Reputation: 87
Quote:
Originally Posted by cyryl_the_wolf
No. I did complete the installation as well. To be honest, I even read the installation instructions to insure that I did it correctly. (Only a n00b would refuse to do so.)

I wonder if you could briefly summarize what you did for me? I'm gettin' along in Linux pretty well, but you seem to have used a couple of techniques that I am not quite familiar enough with yet. (Such as compiling the kernel with the SMBFS support. Not entirely familiar with menuconfig, either.)
Well, I followed the steps at http://mjmwired.net as regards kernel recompilation, and in xconfig I searched the zillions of options unstil I found the filesystems group - under that you can find SMBFS. I select it to be compiled, then recompiled the FC6 kernel. On starting up my custom compiled kernel 2.6.18.1, Samba was working right and I could mount shares on Windows machines. Problem solved!
 
Old 01-11-2007, 05:26 PM   #5
cyryl_the_wolf
Member
 
Registered: Aug 2006
Posts: 32

Original Poster
Rep: Reputation: 15
Talking

Hmm... I'm having a hard time locating any particular article on that site concerning SMBFS or Samba for Suse 10.2.

Could you link me further, please? (Appreciate your information, BTW.)

I decided to reinstall it again on the laptop last night. I was meticulous in my package selection. now all I see is the laptop itself after configuring Samba using Yast. (All I really did was add a NetBIOS host name... Big deal.) But it still won't browse any other shares on the network. It still says that the "program is not configured" when I look into the services in Yast and I'm almost led to believe that it has to be running in level 6 from what it said after that... (That would be ridiculous.) It also says that it 'might be blocked by a running firewall' or something to that effect.

The ONLY firewall I use is my router. I killed all firewall packages.

For a minute, the powers that be actually let me believe for a moment that I had fixed the issue. How silly of me to believe such a thing, eh? :P

Cyryl

Last edited by cyryl_the_wolf; 01-11-2007 at 05:30 PM.
 
Old 01-17-2007, 11:45 PM   #6
litlmary
Member
 
Registered: May 2005
Location: Texas, somewhere near Houston (I think)
Distribution: See my sig
Posts: 300

Rep: Reputation: 30
I found a solution via a simple edit to fstab and posted it here:

http://www.linuxquestions.org/questi...d.php?t=509292

viel gluck,

J
 
Old 02-04-2007, 12:30 AM   #7
KohlyKohl
Member
 
Registered: Aug 2004
Location: Wausau, WI
Distribution: SuSE Linux Enterprise Desktop 10
Posts: 193

Rep: Reputation: 30
I have OpenSUSE 10.2 installed on a server, acting as a domain controller. I have it installed on the client side alongside windows. You can log into the domain fine, and access all shares from either Linux or Windows with read/write access if desired. If you could explain your problem a little more in detail perhaps I can help you out.

James
 
Old 03-08-2007, 11:21 AM   #8
apostate
LQ Newbie
 
Registered: Jun 2005
Posts: 12

Rep: Reputation: 0
Hi. Having run into this with a buddy of mine who wanted to add remote shares to his Amarok collection, I may be able to help. You see, your Samba network protocol is working fine right? However, mounting samba shares on your computer is not networking anymore per se, it is now creating a *local* filesystem on your box, a Samba filesystem. Hence, sambafs. This part of Samba DOES need to be comiled into the kernel, as it involves local filesystems. So, without sambafs enabled you can see samba shares on other systems, but not mount them on yours using smb4k.

Sambafs support may or may not be included with the default 10.2 kernel, I keep forgetting to check BUT it may very well be included and disabled. Go to Yast, look at your system services, and see if there is a daemon for sambafs that is not running, and if so, start it. If not, you may need to build a new kernel, which would be discouraging since I run 102 myself, and *I* want to add remote folders to my Ararok collection too!



Quote:
Originally Posted by rylan76
I've had -exactly- the same problem with Fedora Core 6, versus Fedora Core 3 and Red Hat 9 which I was using previously.







I get exactly the same errors when I try to use Fedora's GUI samba tools.



Ok, here we diverge. I solved the problem by doing exactly this - downloaded the stable source for Samba and compiled it myself. I suspect that you might have skipped actually installing the resulting binaries? What I did was to get the current stable source, then compile it. Then (since I remember from installing Fedora that I asked for SMB support) I realised that those old binaries must still be in my filing system. And, it seemed as if, even if I "make installed" my "own" samba, it left those old binaries around. So I did find / -name smb* and find / -name nmb* and first deleted these old "stock" binaries, then I physically copied the new binaries (which I compiled myself) over the old ones.

Then, I started samba each time I started up my Fedora system by editing /etc/rc.local and adding

smbd -D
nmbd -D

at the end. I also made up my own smb.conf and copied that over each smb.conf that I could find in my filing system. (There seemed to be multiple copies, and I simply replaced each one).

BUT - this only allowed Windows users to see "in" - I could still not "see out" (mount Windows shares to access files on them in Linux) - and it was again due to exactly the same problem you have - no SMBFS support in the kernel.



I do smell some BS too. I can't see why distro packagers don't put SMBFS support in - apparently now either for FC6 or your distro.

My solution was to recompile my kernel. And, lo and behold, I found that they had not included SMBFS support - the entry in the menuconfig listing was unchecked. I simply checked it and recompiled the kernel and samba started working...

In summary this, you'll probably need to recompile your kernel and include SMBFS support into your "new" kernel...
 
Old 03-09-2007, 05:45 AM   #9
alcachi
LQ Newbie
 
Registered: Mar 2007
Posts: 3

Rep: Reputation: 0
The easiest is just to use "cifs" instead of "smbfs" when mounting the samba filesystem.

"CIFS VFS is a new implementation of SMBFS which aims to solve many of the problems which SMBFS has. It uses a different mount program but works in a simalar way. Many kernels come with CIFS included, but at this stage they all seem to be hopelessly broken."

From: http://uranus.it.swin.edu.au/~jn/linux/smbfs/
 
Old 04-03-2007, 03:02 PM   #10
Floppie
LQ Newbie
 
Registered: Apr 2007
Posts: 1

Rep: Reputation: 0
Unfortunately however, CIFS isn't perfect. I'm running a Fedora Core 4 server in our office, and when I try to mount the Samba shares on that box, it appears to mount correctly, and the files/folders all appear to be there (you can browse till the cows come home, smooth as silk). However, the files all have some weird permissions problem, and I can't actually read them. Except sometimes it doesn't return a permissions error, and allows me to read the first byte of the file.

Compiling SMBFS support in and CIFS support out of my kernel now.
 
Old 02-05-2010, 02:32 PM   #11
virtualx
LQ Newbie
 
Registered: Oct 2005
Posts: 22

Rep: Reputation: 15
openSUSE has a probem with windows shares

Cifs doesn't allow me to write to a windows share. SMB doesn't allow me to execute terminal commands but works via Konqueror's smb kio-slave (smb://host/Public/).

From the sounds of it, it's an RPM disto-related problem as I haven't had any problem with kubuntu or Sidux. Unfortunately, for now my only choice is to use Kubuntu. Kind of sad, because I do like the full KDE experience you get with openSUSE as opposed to Kubuntu.

Hope a fix comes around soon.
 
  


Reply

Tags
mount, samba, share, smb, smbfs, support, suse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba, Krusader: Protocol not supported LordSurvivoR Linux - Networking 6 02-28-2008 01:06 PM
SAMBA client stopped windows browsing from working - SuSE 9.1 mikemrh9 Linux - Networking 7 08-18-2004 01:38 PM
samba printing format not supported spooge Linux - Networking 4 07-19-2004 10:17 PM
samba working, then installed openSSL and not samba not working hamish Linux - Networking 3 05-17-2004 01:50 PM
SuSE 9.1 supported hardware? Nyee Linux - Distributions 5 04-04-2004 04:24 PM


All times are GMT -5. The time now is 11:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration