LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-19-2003, 10:29 PM   #1
m0llbuz_
LQ Newbie
 
Registered: Jan 2003
Posts: 13

Rep: Reputation: 0
No DHCPOFFERS received


Hi!

OS: Red Hat Linux 8.0
Motherboard: ECS K7S5A
Network device: on-board SiS900

I have recently compiled the latest kernel (2.4.20) for my RH8 system. I load the SiS900 driver as a module, and it seems to work:

Jan 20 05:43:08 hulk kernel: eth0: Realtek RTL8201 PHY transceiver found at address 1.
Jan 20 05:43:08 hulk kernel: eth0: Using transceiver found at address 1 as default
Jan 20 05:43:08 hulk kernel: eth0: SiS 900 PCI Fast Ethernet at 0xdc00, IRQ 11, 00:07:95:a8:9c:a2.
Jan 20 05:43:08 hulk kernel: eth0: Media Link On 10mbps half-duplex

Then the trouble starts:

Jan 20 05:43:08 hulk ifup: PING 213.112.117.1 (213.112.117.1) from 213.112.117.4 : 56(84) bytes of data.
Jan 20 05:43:08 hulk ifup:
Jan 20 05:43:08 hulk ifup: --- 213.112.117.1 ping statistics ---
Jan 20 05:43:08 hulk ifup: 3 packets transmitted, 0 received, +3 errors, 100% loss, time 2013ms
Jan 20 05:43:08 hulk ifup: , pipe 3
Jan 20 05:43:08 hulk ifup: failed.
Jan 20 05:43:08 hulk network: Bringing up interface eth0: failed

If I restart the network dhclient requests an IP address from the DHCP server, but it doesn't receive an offer:

Jan 20 05:44:46 hulk dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 5
Jan 20 05:44:51 hulk dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
Jan 20 05:44:59 hulk dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 21
Jan 20 05:45:20 hulk dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 15
Jan 20 05:45:35 hulk dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 12
Jan 20 05:45:47 hulk dhclient: No DHCPOFFERS received.
Jan 20 05:45:47 hulk dhclient: No working leases in persistent database - sleeping.
Jan 20 05:46:25 hulk dhclient: receive_packet failed on eth0: Network is down

If I boot the old kernel (2.4.18-14) the network starts but I lose the connection after a while. See my previous thread:
http://www.linuxquestions.org/questi...threadid=41713

Regards
 
Old 01-19-2003, 10:51 PM   #2
rohang
Member
 
Registered: Aug 2002
Location: Sydney, Australia
Distribution: Redhat, Open BSD, SuSe, Debian, CentOS
Posts: 177

Rep: Reputation: 30
What are you connecting to? A hub, switch?

Is your NIC able to do 100Mbps full duplex?

What's the results of ifconfig -a?

Try using mii-tool to force your NIC to 100Mbps full-duplex.

[root@dcssl-smg-webids02 rohang]# mii-tool --help
usage: mii-tool [-VvRrwl] [-A media,... | -F media] [interface ...]
-V, --version display version information
-v, --verbose more verbose output
-R, --reset reset MII to poweron state
-r, --restart restart autonegotiation
-w, --watch monitor for link status changes
-l, --log with -w, write events to syslog
-A, --advertise=media,... advertise only specified media
-F, --force=media force specified media technology
media: 100baseT4, 100baseTx-FD, 100baseTx-HD, 10baseT-FD, 10baseT-HD,
(to advertise both HD and FD) 100baseTx, 10baseT
 
Old 01-20-2003, 12:40 PM   #3
m0llbuz_
LQ Newbie
 
Registered: Jan 2003
Posts: 13

Original Poster
Rep: Reputation: 0
I'm connecting to my ISP (10 Mbit/s) at home.
The NIC is on-board SiS900 10/100 Ethernet card.

Maybe I have done something wrong when I compiled the kernel? It didn't work at all at first, but I fixed it by enabling Socket Filtering. Now it's connecting to the DHCP erver at least...
 
Old 01-20-2003, 03:29 PM   #4
m0llbuz_
LQ Newbie
 
Registered: Jan 2003
Posts: 13

Original Poster
Rep: Reputation: 0
Solved.

I used the old kernel config (2.4.18) and did some tweaking. I must have disabled something vital...
 
Old 01-20-2003, 07:52 PM   #5
rohang
Member
 
Registered: Aug 2002
Location: Sydney, Australia
Distribution: Redhat, Open BSD, SuSe, Debian, CentOS
Posts: 177

Rep: Reputation: 30
Can you post what tweaking you did? It's always good to hear how someone solved a problem.
 
Old 01-20-2003, 08:19 PM   #6
m0llbuz_
LQ Newbie
 
Registered: Jan 2003
Posts: 13

Original Poster
Rep: Reputation: 0
1. make xconfig
2. Load the kernel config for the "default" kernel that comes with RH8: /usr/src/linux-2.4.18-14/configs/kernel-2.4.18-<arch>.config
3. Disable stuff you *know* is safe to remove, leave the rest. Reading the help texts helps a lot... I think it's weird RH8 comes with Telephony and Amatuer Radio support, but NTFS read support is disabled...
4. Compile the kernel.

If that kernel works you can try to remove more stuff from it so you get the smallest possible kernel.
 
Old 07-29-2010, 02:08 PM   #7
neilm99
LQ Newbie
 
Registered: Jul 2010
Posts: 1

Rep: Reputation: 0
kill wpa_supplicant

I see this post all over the place - my home net has wpa on, when I tried to connect the wireless on an open net it connected the first time but when lease ran out I could not get a new IP address.

I disable wpa_supplicant and the dhp discover succeeded and I got a new ip.

neil
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC4 ipw2100 - No DHCPOFFERS received tingcm Linux - Wireless Networking 4 08-22-2005 03:43 AM
Debian no DHCPOFFERS recieved firefly2442 Linux - Networking 3 01-12-2005 03:12 AM
[Debian] Ndiswrapper can't get connected (No DHCPOFFERS received) freek sanders Linux - Wireless Networking 0 12-20-2004 02:46 PM
<no DHCPOFFERS received> for ADSL connection Tanguy Linux - Networking 3 02-12-2004 04:59 PM
NMI received hemanth_13 Linux - General 3 07-11-2003 09:12 AM


All times are GMT -5. The time now is 08:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration