LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 09-08-2006, 06:37 AM   #1
Linux For Ever
Member
 
Registered: Jun 2006
Location: KSA
Distribution: Slackware 12.2
Posts: 49

Rep: Reputation: 15
NFS transfer is slowly


Hi every body.
I have tow computers.
Computer number 1 with RHEL4-AS and another with Fedora Core 5.
The ethernet card on RHEL-AS is 10/100 and other is 10/100/1000. The cable type is cat 5 and i use Switch to linked computers.
I use NFS to shared files.
Once i copying files between computers the transfer speed is 10 MPS in the best.
I trying linked computer with crossover cable and the speed is same.
Can you help me.
 
Old 09-08-2006, 09:25 AM   #2
MensaWater
Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 5,770
Blog Entries: 4

Rep: Reputation: 697Reputation: 697Reputation: 697Reputation: 697Reputation: 697Reputation: 697
Check your settings on the NICs on each card. Since both can do 100 MB that's what you want to do. Also set it for full duplex rather than half.

Often slow speeds like this are due to autonegotiate being turned on. You should turn it off on both and hard set both to speed 100 with full duplex.

You can usually do this with ethtool or mii-tool if ethtool doesn't work for your NIC.

ifconfig will show you which NICs you have (typically eth0 is the first ethernet card - lo0 is the loopback which you can ignore).

My notes on use of these utilties:

ethtool command will set NIC parameters:
ethtool -s eth0 autoneg off speed 100 duplex full
NOTE: To force the options at all boots add the following to ifcfg-eth0:
ETHTOOL_OPTS="autoneg off speed 100 duplex full"

mii-tool command will set NIC parameters - older tool than ethtool
mii-tool -F 100baseTx-FD eth1
mii-tool -v eth1 # Shows info about the interface

Whoo-hoo - this is post #1000 so I'm officially a Senior Member.
 
Old 09-08-2006, 11:50 AM   #3
Linux For Ever
Member
 
Registered: Jun 2006
Location: KSA
Distribution: Slackware 12.2
Posts: 49

Original Poster
Rep: Reputation: 15
Thanks very much for your help and congratulation. Your are Senior Member.
I following your steps but the transfer speed is not change.

look at this.

---------------------------------
On client(Fedora Core 5)
---------------------------------
[root@client ~]# ethtool eth0
Settings for eth0:
Supported ports: [ MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: Not reported
Advertised auto-negotiation: No
Speed: 100Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 1
Transceiver: internal
Auto-negotiation: off
Supports Wake-on: g
Wake-on: d
Current message level: 0x000000ff (255)
Link detected: yes

[root@client ~]# mii-tool -v eth0
eth0: 100 Mbit, full duplex, link ok
product info: vendor 00:08:18, model 24 rev 0
basic mode: 100 Mbit, full duplex
basic status: link ok
capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
advertising: 100baseTx-FD flow-control
-----------------------------
On Server(RHEL-4-AS)
-----------------------------
[root@server ~]# ethtool eth0
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised auto-negotiation: No
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 32
Transceiver: internal
Auto-negotiation: off
Supports Wake-on: pumbg
Wake-on: d
Current message level: 0x00000007 (7)
Link detected: yes

[root@server ~]# mii-tool -v eth0
eth0: 100 Mbit, full duplex, link ok
product info: vendor 00:00:00, model 0 rev 0
basic mode: 100 Mbit, full duplex
basic status: link ok
capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
advertising: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD

===================

Thanks again.
 
Old 09-08-2006, 11:55 AM   #4
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 171Reputation: 171
For Ever

If the above post does not help try :/sbin/hdparm -tT /dev/hda (assuming hda). It is a long shot, but if your drives have something funky going on it may (if the drives are really slow) limit your transfer rate. You will probably need to be root. Here is my old pata drive as an example:

[root@127 ~]# /sbin/hdparm -tT /dev/hda

/dev/hda:
Timing cached reads: 2468 MB in 2.00 seconds = 1234.38 MB/sec
Timing buffered disk reads: 172 MB in 3.00 seconds = 57.33 MB/sec

Good Luck

Lazlow
 
Old 09-08-2006, 12:55 PM   #5
MensaWater
Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 5,770
Blog Entries: 4

Rep: Reputation: 697Reputation: 697Reputation: 697Reputation: 697Reputation: 697Reputation: 697
You are set at 100 Full with no autonegotiate based on what you posted. Did you change something or was it already like that?

Also you mention having tried a cross-over cable which makes it sound like you're going through a hub or a switch normally. If a switch you have to make sure the switch ports are also not set to autonegotiate.

By the way you don't have to do both ethtool and mii-tool. I mentioned both only because I've run into some older NICs on which ethtool doesn't work but mii-tool does. If ethtool works you don't have to run mii-tool.
 
Old 09-10-2006, 06:33 AM   #6
Linux For Ever
Member
 
Registered: Jun 2006
Location: KSA
Distribution: Slackware 12.2
Posts: 49

Original Poster
Rep: Reputation: 15
Hi.
I don't change any thing. I execute that commands only.
I use crossover cable without switch and Straight-Through cable with switch.

my switch is EDIMAX. how i can change switch ports to set autonegotiate is off.

thank you for your helping and sorry my bad English.
 
Old 09-10-2006, 06:43 AM   #7
Linux For Ever
Member
 
Registered: Jun 2006
Location: KSA
Distribution: Slackware 12.2
Posts: 49

Original Poster
Rep: Reputation: 15
This is my switch ES-3108P (8 port)

http://www.edimax.com.tw/html/englis...s/ES-31xxP.htm

it's support Auto-Negotiation.
 
Old 09-10-2006, 11:58 AM   #8
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 171Reputation: 171
For Ever

With a GigE controller on one end you should be able to use a straight through cable to hook directly from machine to machine (in case you router/switch has a problem and your crossover cable has a problem).

Lazlow
 
Old 09-10-2006, 12:48 PM   #9
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
Try using the following options when mounting your NFS: "rsize=8192,wsize=8192".
 
Old 03-10-2007, 07:22 AM   #10
Slim Backwater
Member
 
Registered: Nov 2005
Distribution: Slackware 10.2 2.6.20
Posts: 68

Rep: Reputation: 15
Quote:
Originally Posted by Linux For Ever
Hi every body.
The ethernet card on RHEL-AS is 10/100 and other is 10/100/1000.
...
Once i copying files between computers the transfer speed is 10 MPS in the best.
Not sure if you resolved this, but if your problem is that you are getting 10 MegaBytes per second (MBPS), then that's the best that your hardware supports.

Server RHEL-AS 10/100 = 100 Megabits per second max
Client FC5 10/100/1000 = 1,000 Megabits per second max

The whole transfer is limited by the slowest point, which is the server at 100 Megabits per second.

The best you can get is 100 Megabits per second which, (with 10 bits/byte; 8 + 2 for start and stop bits) is 10 Megabytes per second.

If you want to get a faster transfer, you need to get everything upto Gigabit Ethernet, which means a GigE NIC for the server, and a GigE switch. You may run into other problems if your machines are plain PCI (32-Bit 33Mhz) and only see a transfer rate of about 300 Megabits per second. (Still three times what you are getting now). With 64-Bit PCI @ 133 MHZ (server class hardware) you can easily get 900+ Megabits per second.

Hope that helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Allowing NFS in IPTABLES: Fix port for NFS Lock Manager Swakoo Linux - General 10 08-25-2006 05:24 AM
NFS client = Linux, NFS server = Mac OS X Tiger --> Hell of a problem make Linux - Networking 9 03-10-2006 05:16 AM
NFS and transfer speeds ! crispyleif Linux - Networking 1 10-31-2005 08:59 AM
NFS file transfer problem via wireless akshunj Linux - Wireless Networking 15 12-19-2004 12:47 PM
SuSE NFS Transfer, Crash rm6990 Linux - Networking 2 09-07-2004 02:52 PM


All times are GMT -5. The time now is 09:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration