LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 10-21-2005, 06:56 PM   #1
zephyr.zhao
LQ Newbie
 
Registered: Oct 2005
Posts: 9

Rep: Reputation: 0
MadWifi Problem


Hi,

I setup the madwifi on my Debian. It seems works because iwconfig & iwlist both works fine. The problem is I can't ping my router.

I'm using static ip addrress and I can ping my own ip address. My KWiFiManager shows green signal bars when iwconfig is set. I turned of my Netgear router's wep, still doesn't work( also iwconfig ath0 enc off).

the route table looks fine. Is any body has some clues?

I think the module is ok, but I suspect the connection between my PCMCIA card and the router is not setup.... Is there any way to diagnoise the problem more precisely?
 
Old 10-21-2005, 08:05 PM   #2
Sinaz
LQ Newbie
 
Registered: Sep 2005
Location: Siberia-Gasteiz
Distribution: Debian Sarge
Posts: 13

Rep: Reputation: 0
Hey! Zephyr.zhao!
Can you post the result of iwconfig and ifconfig?
This way is easyer to see what is not working (or maybe not for me, because I'm a
!!) but may be helpfull for others in order to help you.
 
Old 10-21-2005, 10:43 PM   #3
zephyr.zhao
LQ Newbie
 
Registered: Oct 2005
Posts: 9

Original Poster
Rep: Reputation: 0
Hay! Sinaz!
Thanks for your reply.
My PCMCIA card is netgear WG511T

This is the iwconfig command that I execute:

iwconfig ath0 essid "MyWiFi" mode Managed channel 6 key FC65702A5D nick netgear rate 54M

After this command, the KWiFiManage shows the green singal bar.

This is the result of iwconfig:
ath0 IEEE 802.11g ESSID:"MyWiFi" Nickname:"netgear"
Mode:Managed Frequency:2.437 GHz Access Point: 00:09:5B:C9:1F:A0
Bit Rate=54 Mb/s Tx-Power:18 dBm Sensitivity=0/3
Retryff RTS thrff Fragment thrff
Encryption key:FC65-702A-5D Security mode:restricted
Power Managementff
Link Quality=20/94 Signal level=-75 dBm Noise level=-95 dBm
Rx invalid nwid:443 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:15 Invalid misc:15 Missed beacon:0

This is my interfaces file:
# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 10.99.13.66
netmask 255.255.255.0
network 10.99.13.0
broadcast 10.99.13.255
gateway 10.99.13.1
name Ethernet LAN card

auto ath0
iface ath0 inet static
address 10.99.13.77
netmask 255.255.255.0
network 10.99.13.0
broadcast 10.99.13.255
gateway 10.99.13.1
name NetGear card

Eth0 is my another network card, it works fine. I'm using static IP addr, 10.99.13.1 is my router's ip

This is my ifconfig result:

ath0 Link encap:Ethernet HWaddr 00:09:5B:C1:EE:62
inet addr:10.99.13.77 Bcast:10.99.13.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1 errors:2434 dropped:0 overruns:0 frame:2434
TX packets:0 errors:15 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:200
RX bytes:243 (243.0 b) TX bytes:0 (0.0 b)
Interrupt:11 Memory:e0a80000-e0a90000

eth0 Link encap:Ethernet HWaddr 00:09:6B0:4B:31
inet addr:10.99.13.66 Bcast:10.99.13.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:504 (504.0 b)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:12 errors:0 dropped:0 overruns:0 frame:0
TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:924 (924.0 b) TX bytes:924 (924.0 b)

This is my route table:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.99.13.0 * 255.255.255.0 U 0 0 0 eth0
10.99.13.0 * 255.255.255.0 U 0 0 0 ath0
default 10.99.13.1 0.0.0.0 UG 0 0 0 ath0
default 10.99.13.1 0.0.0.0 UG 0 0 0 eth0

even after I ifdown the eth0, as :
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.99.13.0 * 255.255.255.0 U 0 0 0 ath0
default 10.99.13.1 0.0.0.0 UG 0 0 0 ath0

I still can't ping the 10.99.13.1 (MY gateway).
another sympton is that every time I execute "route" table, it takes long time to display the result!

Can you find any clues? Thanks
 
Old 10-22-2005, 06:33 AM   #4
Sinaz
LQ Newbie
 
Registered: Sep 2005
Location: Siberia-Gasteiz
Distribution: Debian Sarge
Posts: 13

Rep: Reputation: 0
Ok, for some reason your card receives the wireless signal but can't establish a connection with the router,
Try:
dhclient ath0
this will get you an IP.
You have set chanel 6, and the result Rx invalid nwid:443 means that there's an ESSID or interference problem, so you can also try another chanel or leave it blank so it will set automatically(I think).
I will also try not to use encryption, cause maybe there could be a problem with it, for example:
iwconfig ath0 essid "MyWIFI" mode Managed
and then:
dhclient ath0
Hope this works!
 
Old 10-22-2005, 11:56 AM   #5
zephyr.zhao
LQ Newbie
 
Registered: Oct 2005
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks for you suggestion.

Interestingly, my debian has no dhclient command. that's why I have to use static ip...

And how do you figure out the meaning of the error code nwid:443?
Is there any reference sheet?

Thanks
 
Old 10-23-2005, 12:33 PM   #6
zephyr.zhao
LQ Newbie
 
Registered: Oct 2005
Posts: 9

Original Poster
Rep: Reputation: 0
Today, I happened to get it work.
1) set rate to auto, instead of 54M. But I don't know why

2) route add 10.99.13.1 dev ath0

therefore, my route table is
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.99.13.1 * 255.255.255.255 UH 0 0 0 ath0
10.99.13.0 * 255.255.255.0 U 0 0 0 eth0
10.99.13.0 * 255.255.255.0 U 0 0 0 ath0
default 10.99.13.1 0.0.0.0 UG 0 0 0 ath0
default 10.99.13.1 0.0.0.0 UG 0 0 0 eth0

again, I don't know why...
but these two steps get my wireless work.

Can anybody give me some explainations?
Thanks
 
Old 10-23-2005, 02:29 PM   #7
Sinaz
LQ Newbie
 
Registered: Sep 2005
Location: Siberia-Gasteiz
Distribution: Debian Sarge
Posts: 13

Rep: Reputation: 0
Sorry for the delay!
But you have managed to make it work, that's great!
For the iwconfig options and info:
man iwconfig
There's from I got that info.
I don't know why now is working (maybe your router doesn't support that speed?), but anyway what I think is that's better not to add many parameters, and let it set automatically.
About the route command, I don't know because I don't use static ip, and when I type route:
Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 wlan0
default         192.168.1.1     0.0.0.0         UG    0      0        0 wlan0
This looks like yours before the route add, and mine works so I have no idea why you need to do that.
Does it works after rebooting or you have to repeat it every time?
Anyway enjoy your wireless!
 
Old 10-23-2005, 02:40 PM   #8
zephyr.zhao
LQ Newbie
 
Registered: Oct 2005
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks for your reply.
It works every reboot. And these two steps are necessary for me...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
madwifi problem urban_hermit Linux - Wireless Networking 1 11-26-2005 05:04 PM
MadWifi Problem craigs1987 Linux - Networking 8 07-27-2005 01:51 PM
Wireless Newbie Problem:Madwifi newinlinux Slackware 2 02-16-2005 07:20 PM
Problem building madwifi on mdk 10.1 Elomis Linux - Software 2 01-15-2005 02:10 AM
Madwifi make problem... EduFer Linux - Hardware 7 04-22-2004 08:24 PM


All times are GMT -5. The time now is 11:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration