LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-27-2004, 04:01 AM   #1
LinuxRam
Member
 
Registered: Jul 2004
Distribution: Red Hat 9, Mandrake 9.2
Posts: 211

Rep: Reputation: 30
LTSP server TFTP file not found error


I am trying to configure LTSP client on Red Hat 8.0,

Server is configured and when try to boot client
it say

.............
..Me192.168.1.9 Server 192.168.1.55
Loading 192.168.1.55:/tftpboot/lts/vmlinuz.ltsp TFTP error 1 (File not found)
Unable to load file

<sleep>
<abort>
Probing for pci nic ...
Probing for isa nic....

but vmlinuz file is present over there.
I tried changing the path /lts/vmlinuz-2.4.26-ltsp-2 in the dhcpd.conf but then also it doesn't works.


Any idea ??
 
Old 08-27-2004, 10:59 AM   #2
jasboy
LQ Newbie
 
Registered: May 2004
Posts: 24

Rep: Reputation: 15
I had the same problem. this path filename "/lts/vmlinuz-2.4.26-ltsp-2"; is the correct path in my config (RH9). After changing the path did you restart dhcp? I know it sounds stupid, but I did that exact thing heheheh. After a "service dhcpd restart" everything worked!
 
Old 08-27-2004, 12:21 PM   #3
LinuxRam
Member
 
Registered: Jul 2004
Distribution: Red Hat 9, Mandrake 9.2
Posts: 211

Original Poster
Rep: Reputation: 30
Yes, I had started the dhcp service after configuring dhcpd.conf file.

??
 
Old 08-27-2004, 03:19 PM   #4
jasboy
LQ Newbie
 
Registered: May 2004
Posts: 24

Rep: Reputation: 15
Will you post the contents of your dhcpd.conf file?
 
Old 08-28-2004, 10:01 PM   #5
LinuxRam
Member
 
Registered: Jul 2004
Distribution: Red Hat 9, Mandrake 9.2
Posts: 211

Original Poster
Rep: Reputation: 30
#cat /etc/dhcpd.conf

ddns-update-style none;
default-lease-time 21600;
max-lease-time 21600;

option subnet-mask 255.255.255.0;
option broadcast-address 192.168.1.255;
#option domain-name-servers 192.168.1.4;
option domain-name "mandrake";
option root-path "192.168.1.55:/opt/ltsp/i386";


shared-network WORKSTATIONS
{
subnet 192.168.1.0 netmask 255.255.255.0
{}
}

group
{
use-host-decl-names on;

host ws001
{
hardware ethernet 00:C0:26:62:C5:96;
fixed-address 192.168.1.9;
filename "/tftpboot/lts/vmlinuz.ltsp";
}
}
 
Old 08-28-2004, 10:47 PM   #6
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
Quote:
host ws001
{
hardware ethernet 00:C0:26:62:C5:96;
fixed-address 192.168.1.9;
filename "/tftpboot/lts/vmlinuz.ltsp";
the last line should look like this....
filename "/lts/vmlinuz.ltsp";

Since you are not using the default ip address range of 192.168.0.1 ~ 254, you need to be sure to go through all of the files and make sure they use your ip address range.
/etc/exports
/etc/hosts.allow
/etc/rc.d/init.d/nat
/etc/hosts
/etc/dhcpd.conf
/opt/ltsp/i386/etc/lts.conf
/opt/ltsp/templates/k12linux/hosts-update.sh
/opt/ltsp/templates/k12linux/setup-update.sh
/opt/ltsp/templates/k12linux/ ( check for proper domain name and ip address )

Here is what my dhcp.conf looks like...

Code:
# Sample configuration file for ISCD dhcpd
#
# Don't forget to set run_dhcpd=1 in /etc/init.d/dhcpd
# once you adjusted this file and copied it to /etc/dhcpd.conf.
#

default-lease-time            21600;
max-lease-time                21600;
ddns-update-style none;
allow booting;
allow bootp;

option subnet-mask            255.255.255.0;
option broadcast-address      192.168.0.255;
option routers                192.168.0.1;
option domain-name-servers    192.168.0.1;
option domain-name            "mydomain.com";
option root-path              "192.168.0.1:/opt/ltsp/i386";
option option-128 code 128 = string;
option option-129 code 129 = text;

host sony {
	hardware ethernet 00:a0:c9:5c:d7:5a;
	fixed-address 192.168.0.5;
	}

shared-network WORKSTATIONS {
  subnet 192.168.0.0 netmask 255.255.255.0 {
     range dynamic-bootp 192.168.0.2 192.168.0.50;
     use-host-decl-names       on;
     option log-servers        192.168.0.1;

     # trick from Peter Rundle <peter.rundle@au.interpath.net>
     if substring (option vendor-class-identifier, 0, 9) = "PXEClient"
     {
        filename      "/lts/pxe/pxelinux.0";
          # NOTE: kernels are specified in /tftpboot/lts/pxe/pxelinux.cfg/
     }
     else
     {
        filename    "/lts/vmlinuz.ltsp";
     }
  }
}

# example configurations for specifying specific kernels to specific clients
#group	{
#    use-host-decl-names       on;
#    option log-servers        192.168.0.254;
#
#    host ws001 {
#        hardware ethernet     00:E0:06:E8:00:84;
#        fixed-address         192.168.0.1;
#        filename              "/lts/vmlinuz.ltsp";
#        option option-128 e4:45:74:68:00:00;
#        option option-129 "NIC=3c509";
#    }
#    host ws002 {
#        hardware ethernet     00:D0:09:30:6A:1C;
#        fixed-address         192.168.0.2;
#        filename              "/lts/vmlinuz.ltsp";
#        option option-128 e4:45:74:68:00:00;
#        option option-129 "NIC=ne";
#    }
#    host ws003 {
#        hardware ethernet     00:D0:09:30:28:B2;
#        fixed-address         192.168.0.3;
#        # kernels are specified in /tftpboot/lts/boot/pxe/pxelinux.cfg/
#        filename              "/lts/boot/pxe/pxelinux.0";
#    }
#}
 
Old 08-31-2004, 03:05 PM   #7
jasboy
LQ Newbie
 
Registered: May 2004
Posts: 24

Rep: Reputation: 15
Quote:
I tried changing the path /lts/vmlinuz-2.4.26-ltsp-2 in the dhcpd.conf but then also it doesn't works.
Your posted dhcpd.conf file shows the path "filename "/tftpboot/lts/vmlinuz.ltsp";" and I believe it needs to be "filename "/lts/vmlinuz-2.4.26-ltsp-2"; " without the outside quotes. Then reboot dhcp and it should work.
 
Old 09-01-2004, 01:06 AM   #8
LinuxRam
Member
 
Registered: Jul 2004
Distribution: Red Hat 9, Mandrake 9.2
Posts: 211

Original Poster
Rep: Reputation: 30
#/etc/exports
/opt/ltsp 192.168.1.0/255.255.255.0(ro,no_root_squash,sync)
/var/opt/ltsp/swapfiles 192.168.1.0/255.255.255.0(rw,no_root_squash,async)


#/etc/hosts.allow
bootpd: 0.0.0.0
in.tftpd: 192.168.1.
portmap: 192.168.1.

#/etc/rc.d/init.d/nat
doesn't present in my system

#/etc/hosts
192.168.1.1 ws009.ltsp ws009
192.168.1.2 ws002.ltsp ws002
192.168.1.3 ws003.ltsp ws003
192.168.1.4 ws004.ltsp ws004
192.168.1.5 ws005.ltsp ws005
192.168.1.6 ws006.ltsp ws006
192.168.1.7 ws007.ltsp ws007
192.168.1.8 ws008.ltsp ws008
192.168.1.9 ws001.ltsp ws001
192.168.1.10 ws010.ltsp ws010
| | | | | | | | |
| | | | | | | | |
| | | | | | | | |
| | | | | | | | |
192.168.1.254 ws254.ltsp ws254

#/etc/dhcpd.conf
ddns-update-style none;
default-lease-time 21600;
max-lease-time 21600;

option subnet-mask 255.255.255.0;
option broadcast-address 192.168.1.255;
#option domain-name-servers 192.168.1.4;
option domain-name "mandrake";
option root-path "192.168.1.55:/opt/ltsp/i386";


shared-network WORKSTATIONS
{
subnet 192.168.1.0 netmask 255.255.255.0 {
}
}

group
{
use-host-decl-names on;

host ws001
{
hardware ethernet 00:E0:4C:E1:A8:16;
fixed-address 192.168.1.9;
filename "/lts/vmlinuz.ltsp";
}
}

#/opt/ltsp/i386/etc/lts.conf
[Default]
SERVER =192.168.1.55
XSERVER =auto
X_MOUSE_PROTOCOL ="PS/2"
x_MOUSE_DEVICE ="/dev/psaux/"
X_MOUSE_RESOLUTION =400
X_MOUSE_BUTTONS =3
USE_XFS =N
LOCAL_APPS =N
RUNLEVEL =5

[ws001]
XSERVER =auto
LOCAL_APPS =N
USE_NFS_SWAP =N
SWAPFILE_SIZE =48m
RUNLEVEL =5

#/opt/ltsp/templates/k12linux/hosts-update.sh
doesn't present in my system

#/opt/ltsp/templates/k12linux/setup-update.sh
doesn't present in my system

#/opt/ltsp/templates/k12linux/ ( check for proper domain name and ip address )
doesn't present in my system


still same error Unable to Load file ...

Last edited by LinuxRam; 09-01-2004 at 01:40 AM.
 
Old 09-01-2004, 08:10 AM   #9
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
Here is a difference in my /etc/exports

/opt/ltsp/i386 192.168.0.0/255.255.255.0(ro,no_root_squash,sync)
/var/opt/ltsp/swapfiles 192.168.0.0/255.255.255.0(rw,no_root_squash,async)


Can you put this into the dhcpd.conf > Change the addresses to match your setup.
Don't forget to restart the dhcpd service after making these changes.


shared-network WORKSTATIONS {
subnet 192.168.0.0 netmask 255.255.255.0 {
range dynamic-bootp 192.168.0.2 192.168.0.50;
use-host-decl-names on;
option log-servers 192.168.0.1;

# trick from Peter Rundle <peter.rundle@au.interpath.net>
if substring (option vendor-class-identifier, 0, 9) = "PXEClient"
{
filename "/lts/pxe/pxelinux.0";
# NOTE: kernels are specified in /tftpboot/lts/pxe/pxelinux.cfg/
}
else
{
filename "/lts/vmlinuz.ltsp";
}
}
}

Last edited by homey; 09-01-2004 at 09:20 AM.
 
Old 09-01-2004, 08:26 PM   #10
LinuxRam
Member
 
Registered: Jul 2004
Distribution: Red Hat 9, Mandrake 9.2
Posts: 211

Original Poster
Rep: Reputation: 30
Quote:
Can you put this into the dhcpd.conf > Change the addresses to match your setup
What i have to put in dhcpd.conf file.


Now what changes i have to make
1) /etc/exports.
2) .....????
 
Old 09-01-2004, 10:05 PM   #11
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
The dhcpd.conf has a line filename "/lts/vmlinuz.ltsp";
but you have it in with one hardware address.

{
hardware ethernet 00:E0:4C:E1:A8:16;
fixed-address 192.168.1.9;
filename "/lts/vmlinuz.ltsp";
}

It needs to be in brackets by itself...

{
filename "/lts/vmlinuz.ltsp";
}
 
Old 09-02-2004, 12:13 AM   #12
LinuxRam
Member
 
Registered: Jul 2004
Distribution: Red Hat 9, Mandrake 9.2
Posts: 211

Original Poster
Rep: Reputation: 30
When i placed brackets and restarted dhcpd services then it is giving me error.

and i made changes in /etc/exports file but then also
it is giving me error "Unable to load file...."
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel compilation error: Error 15: File not found Niceman2005 Linux - General 9 10-04-2007 03:45 AM
Trying to install LTSP, config problem (tftp, xdmcp) yokim Linux - Networking 2 10-10-2005 11:11 PM
Error 15 file not found PenguinMolester Suse/Novell 5 08-29-2005 07:07 AM
LTSP file not found error LinuxRam Linux - Networking 1 09-03-2004 01:31 PM
snmpd installed, see file, but get error file not found PCHelper Slackware 0 11-06-2003 12:44 PM


All times are GMT -5. The time now is 05:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration