LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 02-22-2002, 03:33 PM   #1
morbo
Member
 
Registered: Dec 2001
Posts: 53

Rep: Reputation: 15
installing bind on redhat 7.1


Ok, this is the last phase of my server-and of course it doesn't work as it should....

Basically, I compiled bind using the following syntax:

./configure make --with-openssl=/usr/local/openssl

It compiled fine, and then I went to install using:

make install

It goes through most of the install then exits after this:

/usr/bin/ar: unix/app.o: No such file or directory
make[2]: *** [libisc.a] Error 1
make[2]: Leaving directory `/usr/local/bind/lib/isc'
make[1]: *** [install] Error 1
make[1]: Leaving directory `/usr/local/bind/lib'
make: *** [install] Error 1

Any ideas?
 
Old 02-22-2002, 06:47 PM   #2
Malicious
Member
 
Registered: Jan 2002
Location: Galveston Island
Distribution: suse, redhat
Posts: 208

Rep: Reputation: 30
Are you sure that it compiled ok? Install is looking for lib/isc/unix/app.o and it isn't there. In my bind source tree there is a lib/isc/unix/app.c. Best bet is that there is was an error in that compile. cd to lib/isc/unix and do a make and see if you get a compile error on app.c. If it compiles, try the make install again.
 
Old 02-22-2002, 07:17 PM   #3
morbo
Member
 
Registered: Dec 2001
Posts: 53

Original Poster
Rep: Reputation: 15
Ok, I checked and there is no app.o in the dir structure...

Is compiling using the syntax I used right? I'm sure I unzipped the tarball fine, but I'm not sure I'm compiling itproperly, becaus e when I run ./configure make I get :
loading cache ./config.cache
checking host system type... Invalid configuration `make': machine `make' not recognized

So i tried doing just:
./configure --with-openssl=/usr/local/sslserver/openssl/

and still get the same thing, just no make error, it still fails at the same time with app.o

no errors on the compile either....

Last edited by morbo; 02-22-2002 at 07:19 PM.
 
Old 02-22-2002, 07:50 PM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,132
Blog Entries: 54

Rep: Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791
The configure command should go before the make command, just do "./configure <options here>", then "make".
 
Old 02-22-2002, 08:23 PM   #5
morbo
Member
 
Registered: Dec 2001
Posts: 53

Original Poster
Rep: Reputation: 15
I did a ./configure --with-openssl=/usr/local/bin/sslserver/openssl make

and still got the:

loading cache ./config.cache
checking host system type... Invalid configuration `make': machine `make' not recognized

Urgh, what's the deal? Why is the app.o not going to the dir? I am compiling acording to the README, but still no success. I've also tried compiling without SSL, and still no luck!
 
Old 02-22-2002, 08:42 PM   #6
morbo
Member
 
Registered: Dec 2001
Posts: 53

Original Poster
Rep: Reputation: 15
Ok, I got it to work!

All I did was take of the 'install' after make, and it appears to work just fine....

Now the problem becomes how to invoke it?

Thanks for all of the help, it's much appreciated.
 
Old 02-23-2002, 12:39 AM   #7
Malicious
Member
 
Registered: Jan 2002
Location: Galveston Island
Distribution: suse, redhat
Posts: 208

Rep: Reputation: 30
The problem you had is due to the order you did things. The "typical" order is:

./configure
make depend
make all (or just make)
make install

The reason I say "typical" is that this sequence will always do things in the righr order. Ideally, the make install would force the make depend, make all, and then install. Some Makefile structures do, others do not. Out of curiosity, I pulled down the latest bind source tarball and did a ./configure and make install. I got exactly the same error you did; no app.o. I looked in the tree and the .o files for the unix directory and nsl directory were in the isc dirctory. In this particular case, the dependencies in the Makefiles for the install tag for libisc.a are wrong. I ran the typical sequence above and it all worked.

By the way, the error you had running configure was the command "./configure make --whatever" is wrong. ./configure and make are two separate commands; ./configure mistook the word make for the system host type (./configure --help). Read that error line with Solaris or Windows in place of make and it makes a little more sense.

later

Last edited by Malicious; 02-23-2002 at 12:43 AM.
 
Old 02-23-2002, 03:59 AM   #8
morbo
Member
 
Registered: Dec 2001
Posts: 53

Original Poster
Rep: Reputation: 15
Ok, now it makes much more sense.....I especially thank you for clearing that up, and for all of the help you've provided. I've learned a lot, but still have a ton more to go. The more and more I work at it, the more I appreciate penguins =)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bind Error Redhat 9.0 acdc Linux - Networking 1 10-22-2003 05:49 AM
BIND Problems on Redhat 9 Djelibeybi Linux - Networking 3 09-01-2003 11:29 PM
Redhat 7.3, Apache, and Bind arikel Linux - Networking 6 04-01-2003 04:13 AM
Redhat 7.2 + Bind 9 ? help ! Gism0 Linux - General 1 04-18-2002 12:28 AM
RedHat 7.1 and BIND 9.1 Woes Frostgod Linux - Networking 1 12-28-2001 05:00 PM


All times are GMT -5. The time now is 08:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration