LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 01-14-2010, 05:05 PM   #1
Hewson
Member
 
Registered: Feb 2007
Location: /home
Distribution: Kubuntu and CentOS
Posts: 214

Rep: Reputation: 32
how to LDAP user authentication working for Ubuntu clients


I'm trying to utilize my company's IT orginazation's LDAP service (running on some sort of windows) for authenticating users on an Ubuntu box.

Another group has done something similar for CENTOS; I've used their ldap.conf as a reference as well as https://help.ubuntu.com/9.04/serverg...ap-server.html (LDAP Authentication section)

I can't get it to work. When I try to connect as my corporate user I see this in auth.log:
Code:
Jan 14 14:32:24 Algalon sshd[7062]: nss_ldap: could not connect to any LDAP server as cn=ldapquery2,cn=Users,dc=<companyname>,dc=com - Can't contact LDAP server
Jan 14 14:32:24 Algalon sshd[7062]: nss_ldap: failed to bind to LDAP server ldaps:///10.1.1.200: Can't contact LDAP server
Jan 14 14:32:24 Algalon sshd[7062]: nss_ldap: reconnecting to LDAP server...
Jan 14 14:32:24 Algalon sshd[7062]: nss_ldap: could not connect to any LDAP server as cn=ldapquery2,cn=Users,dc=<companyname>,dc=com - Can't contact LDAP server
Jan 14 14:32:24 Algalon sshd[7062]: nss_ldap: failed to bind to LDAP server ldaps:///10.1.1.200: Can't contact LDAP server
Jan 14 14:32:24 Algalon sshd[7062]: nss_ldap: reconnecting to LDAP server (sleeping 1 seconds)...
Jan 14 14:32:25 Algalon sshd[7062]: nss_ldap: could not connect to any LDAP server as cn=ldapquery2,cn=Users,dc=<companyname>,dc=com - Can't contact LDAP server
Jan 14 14:32:25 Algalon sshd[7062]: nss_ldap: failed to bind to LDAP server ldaps:///10.1.1.200: Can't contact LDAP server
Jan 14 14:32:25 Algalon sshd[7062]: nss_ldap: could not search LDAP server - Server is unavailable
Any hints? I'm not sure what to do.
 
Old 01-15-2010, 05:19 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,345

Rep: Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945
That error just says that it can't reach port 636 on that server. check your routing and ldap server details. do you want SSL? Does it work without encryption e.g. ldap:// ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Centralized Authentication for Windows Clients using LDAP,SAMBA & LAM metallica1973 Linux - Networking 2 01-09-2009 05:20 PM
LDAP Authentication not working t0bias Linux - Server 1 09-25-2008 09:02 AM
User authentication with LDAP stanthecaddy22 Linux - Networking 5 04-07-2006 08:30 AM
LDAP-CVS-User Authentication ralagar_raja Linux - Enterprise 0 01-04-2005 05:42 AM
Quick Q on LDAP and user authentication tarballed Linux - General 3 03-29-2003 03:08 AM


All times are GMT -5. The time now is 12:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration