LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 11-14-2009, 05:37 PM   #16
appyface
LQ Newbie
 
Registered: Dec 2008
Posts: 3

Rep: Reputation: 0

Hello fralacos,

I tried your instructions but I could not make them work for me. Assuming I followed your instructions correctly (and perhaps that is not a valid assumption!), I believe the reason it did not work is because I also need the data ports forwarded down the tunnel, and not just the control port.

The method I outlined above allows for the data ports to be known in advance and therefore forwarded down the tunnel.

Please let me know if I did not follow your method correctly and the data ports should have been forwarded down the tunnel as well?

Thanks and regards,
--appyface
 
Old 10-16-2011, 07:34 AM   #17
Eeek Th£ Bear
LQ Newbie
 
Registered: Jul 2009
Location: Norwich
Distribution: Debian_AMD64
Posts: 8

Rep: Reputation: 0
Talking Thank you!!

Quote:
Originally Posted by fralacos View Post
Hello,

I got this working using putty 0.60 for setting up a dynamic tunnel, with this kind of tunnel PuTTY provides a local SOCKS 4/4A/5 proxy on a local port. Your FTP client must be set to use this local SOCKS proxy and passive mode.

Not so detailed Instructions:

on PUTTY:
  1. Open putty configuration.
  2. Set up an SSH connection to your SSH server as usual (host, port, etc.)
  3. Go to Connection > SSH > Tunnels.
  4. Fill in source port, this is the port where SOCKS proxy will listen, so you FTP client should be set to use 127.0.0.1:<source port> as socks proxy.
  5. Destination: empty, not used for dynamic tunnels.
  6. Select Dynamic radio button.
  7. (optional) Go back to session and save you settings.
  8. Connect to your SSH server!

on FTP client:
  1. Configure your FTP client to use a SOCKS proxy at 127.0.0.1:<source port>.
  2. Configure your FTP client to use PASSIVE mode.
  3. FTP connection must be opened to actual FTP server address and port, for example 192.168.0.1:21. Note that your SSH server must be able to reach your FTP server at that IP address and port.

FrAlAcos

PS: I'm a frequently visitor of this forums and got lot of help from here, just now i have this chance to help back so ... hope it helps!

Legend! Long story short I'm in IT, tunnelling etc is a frequent requirement in my role, I knew I wanted to use a dynamic tunnel in PUTTY to get around FTP's damn dual port set-up but hadn't considered adding a proxy to my FTP client!! You are a star, works like a charm!
 
  


Reply

Tags
encrypted, ftp, passive, pasv, secure, ssh, tunnel


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP Tunnel 70mas Linux - Software 1 11-28-2006 07:24 AM
Getting FTP, TELNET , or SSH to work jst1 Suse/Novell 1 03-08-2005 08:54 PM
SSH Tunnel and FTP Issues ayrton Linux - Networking 2 02-16-2004 05:03 AM
SSH and FTP quozt Linux - Networking 4 08-22-2003 07:10 AM
ssh and ftp artman62 Linux - Networking 4 08-25-2002 04:55 PM


All times are GMT -5. The time now is 03:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration