LinuxQuestions.org
Visit Jeremy's Blog.
Home Forums Tutorials Articles Register
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 01-18-2006, 09:53 AM   #16
baldy3105
Member
 
Registered: Jan 2003
Location: Cambridgeshire, UK
Distribution: Mint (Desktop), Debian (Server)
Posts: 891

Rep: Reputation: 184Reputation: 184

ok so it will look something like this -

int f0/0
ip address 10.0.0.1 255.255.255.0
desc **** connection to firewall dirty side ****

int s0/0
ip address 192.168.0.1 255.255.255.252
desc **** wan connection to ISP ****

router ospf 1
network 10.0.0.0 0.0.0.255 area 0
redistribute static metric 50

ip route 0.0.0.0 0.0.0.0 192.168.0.2

So only the lan side will run ospf but the ospf process will bring the static route in as long as its a valid route. If the interface goes down then the route becomes invalid and the route will be withdrawn.

Don't forget that this approach only works for outgoing traffic that is load balanced on a per session basis by the internal router, which is the fella that will be making the routing decisions. You should have your public facing servers on a DMZ off the firewalls so incoming sessions will be unaffected by the load balancing.
 
Old 01-18-2006, 10:03 AM   #17
ghight
Member
 
Registered: Jan 2003
Location: Indiana
Distribution: Centos, RedHat Enterprise, Slackware
Posts: 524

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by baldy3105
ok so it will look something like this -

int f0/0
ip address 10.0.0.1 255.255.255.0
desc **** connection to firewall dirty side ****

int s0/0
ip address 192.168.0.1 255.255.255.252
desc **** wan connection to ISP ****

router ospf 1
network 10.0.0.0 0.0.0.255 area 0
redistribute static metric 50

ip route 0.0.0.0 0.0.0.0 192.168.0.2

So only the lan side will run ospf but the ospf process will bring the static route in as long as its a valid route. If the interface goes down then the route becomes invalid and the route will be withdrawn.

Don't forget that this approach only works for outgoing traffic that is load balanced on a per session basis by the internal router, which is the fella that will be making the routing decisions. You should have your public facing servers on a DMZ off the firewalls so incoming sessions will be unaffected by the load balancing.
Looks embarrassingly simple. Thanks. I've seen this done many times in several of m y very own books, but I guess I never understood it correctly.

I think that should solve the problem nicely. If I could give you points, I'd give you the max available. Half for helping me out, and the other half for not letting me argue an incorrect point to my engineer.
 
Old 01-18-2006, 10:17 AM   #18
baldy3105
Member
 
Registered: Jan 2003
Location: Cambridgeshire, UK
Distribution: Mint (Desktop), Debian (Server)
Posts: 891

Rep: Reputation: 184Reputation: 184
No worries. its only simple when you've done it few times
 
  


Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
yast segmentation fault, system freezing - nvidia driver at fault? BaltikaTroika SUSE / openSUSE 2 12-02-2005 09:34 AM
how to do iptables fault tolerance ? adrianmak Linux - Networking 1 11-01-2004 07:44 AM
NT4-like disk fault tolerance availability mikep53 Linux - General 1 06-13-2004 03:44 PM
Adapter Teaming for Fault Tolerance jayesh_777 Linux - Networking 1 09-26-2003 01:12 AM
PPP Fault tolerance Sathe Linux - Networking 2 10-18-2001 11:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration