LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-19-2004, 08:26 PM   #1
benrose111488
Member
 
Registered: Jun 2004
Location: Wantage, NJ
Distribution: Fedora 7
Posts: 177

Rep: Reputation: 30
Angry eth0 Activates but no internet!


I recently installed Fedora Core 2 for my friend...

He has ONE ethernet controller connected to a router connected to his DSL modem...

Via DHCP, eth0 successfully determines an IP and activtaes ok

but he still has no connection to the internet... Mozilla says that he's not connected, and Gaim says the same thing...

And a when I installed Fedora Core 2 on my PC, i had a problem with my modem, which i fixed with (as root)
setserial /dev/modem autoconfig
setserial /dev/modem skip_test

So any suggestions?

Stumped!

thanks everyone!
-Benji
brose@nac.net
 
Old 06-19-2004, 08:51 PM   #2
jcookeman
Member
 
Registered: Jul 2003
Location: London, UK
Distribution: FreeBSD, OpenSuse, Ubuntu, RHEL
Posts: 417

Rep: Reputation: 33
Can you post the output of 'ifconfig', 'route' and 'cat /etc/resolv.conf'?
 
Old 06-19-2004, 09:33 PM   #3
benrose111488
Member
 
Registered: Jun 2004
Location: Wantage, NJ
Distribution: Fedora 7
Posts: 177

Original Poster
Rep: Reputation: 30
lol my friend spent an hour going from one computer to another transferring this data so go a little easy on him next time if possible ;-)

but thanks!

ifconfig...
Eth0 Link encap:Ethernet Hwaddr 00:0C:6E:5F5:CF
Inet addr: 192.168.0.7 Bcast:192.168.0.255 Mask:255.255.255.0
Inet6 addr: fe80::20c:6eff:fe5f:d5cf/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:23 errors:0 dropped:0 overruns:0 frame:0
TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:1000
RX bytes:4969 (4.8 Kb) TX bytes:2472 (2.4 Kb)
Interrupt:3 Base Address: Ox4000

Lo Link encap:Local Loopback
Inet addr:127.0.0.1 Mask:255.0.0.0
Inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:4090 errors:0 dropped:0 overruns:0 frame:0
TX packets:4090 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:0
RX bytes:2509265 (2.3 Mb) TX bytes:2509265 (2.3 Mb)

and then for route:
Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 * 255.255.255.0 U 0 0 0 Eth0
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
^^srry if it doesnt show up right, just try to match up the columns as best u can^^

and for the cat /etc/resolv.conf:
search localdomain

aight so that should do it... thanks for all ur help!

-Benji
 
Old 06-19-2004, 09:35 PM   #4
benrose111488
Member
 
Registered: Jun 2004
Location: Wantage, NJ
Distribution: Fedora 7
Posts: 177

Original Poster
Rep: Reputation: 30
I just noticed in the ifconfig there's a laughing face, ignore that because its supposed ot be a colon and a capital D

sorry for the inconvinence, and thanks again for the help

-Benji
 
Old 06-19-2004, 09:54 PM   #5
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
Quote:
Inet6 addr: fe80::20c:6eff:fe5f:d5cf/64 Scope:Link
It may be related to that Inet6 line. I don't have FC2 up right now but I seem to recall a check box to tell the system to use ipv4. That would be in the GUI tool which comes up with the command: redhat-config-network
 
Old 06-19-2004, 09:57 PM   #6
jcookeman
Member
 
Registered: Jul 2003
Location: London, UK
Distribution: FreeBSD, OpenSuse, Ubuntu, RHEL
Posts: 417

Rep: Reputation: 33
Ok, you don't have a default gateway set.. Your route ahould have an entry "default" like this:
Code:
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.2.0     *               255.255.255.0   U     0      0        0 ath0
loopback        justinlap.secni 255.0.0.0       UG    0      0        0 lo
default         192.168.2.1     0.0.0.0         UG    0      0        0 ath0
Second, you don't have an entry in /etc/resolv.conf for your nameserver. Like this:
Code:
nameserver 68.63.80.5
nameserver 68.63.80.6
This usually comes from invoking dhclient (I assume since you're using RedHat) or dhcpcd with the wrong flags.

Check your 'ps -aux' to see what flags it is being invoked with:
Code:
root      7548  0.0  0.0  1360  440 ?        S<s  20:01   0:00 /sbin/dhcpcd -t 10 ath0
With dhcpcd -R prevents dhcpcd from replacing existing /etc/resolv.conf file. -G prevents dhcpcd from installing default routes provided by DHCP server.

The easy way to set this manually is to:
Code:
route add default gw 192.168.1.1 eth0
Whatever the real IP is of the router, and edit /etc/resolv.conf to contain nameserver entries for your ISPs nameserver. Or, whatever nameservers you are using.

Justin
 
Old 06-20-2004, 12:53 AM   #7
benrose111488
Member
 
Registered: Jun 2004
Location: Wantage, NJ
Distribution: Fedora 7
Posts: 177

Original Poster
Rep: Reputation: 30
homey, In FC2 there's IPv6 and not IPv4 so idk if theres a difference involved, but as for now im gonna put ur idea on hold and try Justin's idea. If that doesn't work, then i'll try yours, but or some reason Justin's sounds more promising. and THANK YOU

Justin - THANK YOU!!!

Since I wont get to try this out untril probably Monday when I go over his house (Betcha didnt know ur talking to a 15 year old all this time) any replies wont be submitted until then about this working... but to both of you, check back on Monday night IF YOU CAN, and THANK YOU guys SOOOO MUCH for all of your help. Just let me know if there's anything i can help either of you with, I've been using Linux since I was 8 lol

so, one last time, THANK YOU! and plz check back around Monday night.
 
Old 06-21-2004, 05:18 PM   #8
benrose111488
Member
 
Registered: Jun 2004
Location: Wantage, NJ
Distribution: Fedora 7
Posts: 177

Original Poster
Rep: Reputation: 30
Talking

IT WORKED!!!

I did exactly what Justin said and it still didnt work so i undid it and enabled IPv6 and it didnt work lol So then I did what BOTH of you said and it worked! lol thank you guys muchly!!!

:-)
 
Old 06-21-2004, 05:42 PM   #9
sfamonkey
LQ Newbie
 
Registered: Jun 2004
Posts: 7

Rep: Reputation: 0
I hope you figure it out!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0 and internet contiang Linux - General 16 04-22-2005 04:19 AM
Slackware: What is the script that activates/desactivates services? jayhel Slackware 3 12-23-2004 02:22 PM
Dell 510M Letterbox / Small screen in X and Console before fb activates dezza Linux - Laptop and Netbook 3 11-09-2004 04:20 PM
eth0 no longer activates during startup zombiedeth Linux - Networking 2 03-03-2004 02:19 AM
ppp0 uses eth0... but eth0 never activates joshuapurcell Linux - Networking 3 12-17-2003 01:52 AM


All times are GMT -5. The time now is 06:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration