LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-24-2003, 01:53 AM   #1
exper
Member
 
Registered: Jul 2003
Location: China
Distribution: Redhat
Posts: 48

Rep: Reputation: 15
Question could not connect my vsftpd server


I use vsftpd as my server application for 1 year.But last week, I couldn't connect it .when I use ftp command to connect my server. and I received the message as follow list

ftp: connect: connection refused

I try restart the server use following command

#service vsftpd restart

receive the following message

Shutting down vsftpd: [FAILED]
Starting vsftpd for vsftpd: [ OK ]

See that I use 'netstat -a |grep ftp' and 'ps -ef |grep ftp' to check the service status but nothing I received.

I notice when I reboot or shutdown my server,all of the vsftpd failed shutdown.


How can I resolve this problem
anyone help me?

Last edited by exper; 07-24-2003 at 02:00 AM.
 
Old 07-25-2003, 04:14 AM   #2
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 47
check /var/log/messages and vsftpd.log for clues; looks like vsftpd does not like something in your conf file
 
Old 07-26-2003, 03:54 AM   #3
jackyopensrc
LQ Newbie
 
Registered: Jul 2003
Location: Kuala Lumpur,Malaysia.
Distribution: Red Hat 7.3
Posts: 16

Rep: Reputation: 0
I have exprienced this problem before I logging off my PC .

In addition,My procedures that are slightly different from yours.

First , I will do it as the following,
1) Enable vs-ftp the paramater file from xinetd.d and add vsftpd: ALL
in hosts.allow and hosts.deny

2) Type "service sshd start" and "service xinetd start"

3) To add a ftp user such as "adduser ftp" and provide the password "passwd ftp".

4) add "ftp" to /etc/ftpusers.

That 's the my procudure.

Enjoy !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd server: can connect locally, not remotely propz Linux - Networking 2 10-24-2005 01:59 AM
VSFTPD Setup - Connect problem nadsab Linux - Software 4 08-29-2004 10:03 PM
vsftpd - Can't connect externally??? Xgkkp Linux - Networking 5 08-30-2003 01:50 PM
Can't connect to vsFTPd through ssh tunnel Sizam Linux - Networking 0 06-27-2003 01:30 PM
VSFTPD Running But Cannot Connect from another machine SForsgren Linux - General 10 05-02-2003 12:55 AM


All times are GMT -5. The time now is 02:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration