LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 12-24-2009, 06:55 PM   #31
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40

well your route output shows the correct info but for eth4 whereas ifconfig is set to eth2, I am reading the route man page as I type and will post my suggestions on how to edit your routing table - it is a problem I haven't encountered before, but it does explain why your laptop won't connect with encryption on or off.

I suggest you take a look at man route in the meantime
 
Old 12-24-2009, 07:12 PM   #32
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
His route is useless.
First his IP - 192.168.1.3 Mask:255.255.255.0

That means GW should be 192.168.1.1
To have ability to go out from wireless INTERFACE should be eth2

So
1. route del -net 192.168.0.0
1.1 route add -net 192.168.1.0 netmask 255.255.255.0 gw 0.0.0.0 eth2

2. route del -net 0.0.0.0
2.2 route add -net 0.0.0.0 netmask 0.0.0.0 gw 192.168.1.1 eth2

But this will work ONLY if his GW= 192.168.1.1.

To find it out OP, please connect to your router (no important how) and type from root console
dhcpcd -T eth0 (if you connect through ethernet)
dhcpcd -T eth2 (if you connect through wireless)

Post outputs please.
 
Old 12-24-2009, 07:19 PM   #33
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
I am thinking:

route add -net 192.168.1.0 netmask 255.255.255.0 dev eth2

route add default gw 192.168.1.1 dev eth2

should, I think, change the output of route -n to what we want

run route -n and see what comes out, I am not going to experiment on my machine since it is my only way of connecting to LQ.


If the effect of these changes is correct you can try to reach http://192.168.1.1 AGAIN.
 
Old 12-24-2009, 07:21 PM   #34
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
nimnull22 is correct, unfortunately he was offline when I posted may last message which you can now safely ignore
 
Old 12-24-2009, 07:25 PM   #35
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
Sorry but I have to get some sleep its 01:22 here in the UK and I have to be up early for tomorrow's activities. happy Christmas to you all.
 
Old 12-24-2009, 07:32 PM   #36
Maxximiliann
Member
 
Registered: Dec 2009
Posts: 72

Original Poster
Rep: Reputation: 16
SUCCESS!!! - http://pastebin.com/d703b053e

It appears that the problem was because dhcpcd was missing form my system. Once installed everything started working properly. Thanks guys for all your help!!
 
Old 12-24-2009, 07:36 PM   #37
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
I'm happy.
 
Old 12-24-2009, 08:16 PM   #38
Maxximiliann
Member
 
Registered: Dec 2009
Posts: 72

Original Poster
Rep: Reputation: 16
Ok, new problem. Re-enabled my encryption protocols and I lost my connection to the net even though Network Manager tells me I'm connected. What happened?
 
Old 12-24-2009, 08:25 PM   #39
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
Quote:
Originally Posted by Maxximiliann View Post
Ok, new problem. Re-enabled my encryption protocols and I lost my connection to the net even though Network Manager tells me I'm connected. What happened?
Can you tell us in details, please, how did you "Re-enabled encryption protocols"?

Thanks.
 
Old 12-24-2009, 08:28 PM   #40
Maxximiliann
Member
 
Registered: Dec 2009
Posts: 72

Original Poster
Rep: Reputation: 16
Went back into my router's encryption settings and restored them. Here's what they're set to now:

WPA: WPA-PSK (no server)
WPA MODE: WPA2
Encryption Technique: TKIP
 
Old 12-24-2009, 08:31 PM   #41
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
Quote:
Originally Posted by Maxximiliann View Post
Went back into my router's encryption settings and restored them. Here's what they're set to now:

WPA: WPA-PSK (no server)
WPA MODE: WPA2
Encryption Technique: TKIP
Yes, and had to set password, I assume. Right.
So in Network Manager you have to choose the same encryption method and set the same password.

Can you check all of this.
 
Old 12-24-2009, 08:43 PM   #42
Maxximiliann
Member
 
Registered: Dec 2009
Posts: 72

Original Poster
Rep: Reputation: 16
Same encryption method and key. Still can't connect to the net.

Incidentally, Synaptic tells me that I have wpasupplicant version 0.6.9-3ubuntu1 already installed.
 
Old 12-24-2009, 08:56 PM   #43
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
Can you check the file: /etc/wpa_supplicant.conf
If you have one, please post its content.

Thanks.
 
Old 12-24-2009, 09:08 PM   #44
Maxximiliann
Member
 
Registered: Dec 2009
Posts: 72

Original Poster
Rep: Reputation: 16
Doesn't look like I have a wpa_supplicant.conf. What now?
 
Old 12-24-2009, 09:11 PM   #45
elsheepo
Member
 
Registered: Feb 2008
Distribution: Slackware -current
Posts: 77

Rep: Reputation: 18
install wicd
http://wicd.sourceforge.net/download.php
It will fix your wpa_supplicant issues garenteed
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broadcom Corporation BCM4328 802.11a/b/g/n (rev 03) Adler Linux - Laptop and Netbook 4 11-15-2008 02:34 PM
Broadcom card configured for 802.11g, but not 802.11b? MrPeabody Linux - Wireless Networking 2 10-07-2007 04:27 PM
Broadcom 802.11b/g WLAN Does Not turn on in Ubuntu beachbum2005 Linux - Hardware 3 02-20-2007 03:40 PM
Problem ON Broadcom Corporation BCM94306 802.11g (rev 02) ON Fedora honest Linux - Wireless Networking 4 07-17-2004 12:56 PM
Broadcom Corporation BCM94306 802.11g on Fedora core 2. honest Linux - Newbie 1 06-27-2004 08:57 AM


All times are GMT -5. The time now is 06:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration