LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 11-16-2004, 08:45 AM   #1
kraid
LQ Newbie
 
Registered: Nov 2004
Posts: 1

Rep: Reputation: 0
Can't mount pc share on Red Hat 6.1 box


Greetings,
I've tried to find as much info about this problem before posting to no avail.

I'm trying:
mount -t smbfs -o workgroup=ansi,username=myname,password=mypassword //server/share /nt

I get:
wrong fs type, bad option, bad superblock on //server/share

I also tried Sharity Lite and get:

# shlight //server/share /nt -U myname -W ansi -D 0xff password:
psitable_insert(): inserting inode 449722290: -><-
Kernel: smb_proc_connect: Passed SESSION REQUEST.
Kernel: len: 85, wct: 17, bcc: 16
Kernel: smb_proc_connect: Request SMBnegprot..Kernel: Verified!
Kernel: smb_proc_connect: Server wants NT LANMAN 1.0 protocol.
Kernel: smb_proc_connect: password = ********
Kernel: smb_proc_connect: usernam = myname
Kernel: smb_proc_connect: blkmode = 0
Kernel: smb_proc_connect: workgroup = ANSI
Kernel: len: 66, wct: 3, bcc: 25
Kernel: len: 39, wct: 2, bcc: 0
Kernel: OK! Managed to set up SMBtcon!
Kernel: max_xmit = 8304, tid = 1
Kernel: smb_proc_connect: Normal exit
Using port 1024 for NFS.
- going into select
Going to mount...
nfs mount /nt: [19] Operation not supported by device
Killed

It looks like everthing works great until the final mount operation.

Thanks for any direction here.

Kraid
 
Old 11-16-2004, 08:55 AM   #2
gani
Member
 
Registered: Jun 2004
Location: Metro Manila, Philippines
Distribution: OpenBSD, Slackware, XP
Posts: 347

Rep: Reputation: 31
What do you mean by PC share? Is it remote Windows shares? It looks to me that you're mounting smb shares.

If it is smb/windows share can you try this:

# smbmount //windows_host/share_name /mnt
 
Old 11-16-2004, 09:15 AM   #3
wmakowski
Member
 
Registered: Oct 2003
Location: Ohio
Distribution: Fedora 18, 19, RHL 5.2
Posts: 546

Rep: Reputation: 43
Your first example shows using the mount command. It looks like your kernel may not have smbfs support configured. I believe this causes a problem when using the mount command versus using smbmount.

Another option and a good first step would be to try using smbclient to see if you can access the share. I see you are using RedHat 6.1. On one of my older linux systems I had to upgrade samba and enable encryption to access a Windows NT share. This situation doesn't look like a permission problem, but I thought I would throw that in for completeness.

Bill
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
windows share automatically mount on linux box emailssent Linux - Networking 11 11-01-2004 03:02 AM
Red Hat internet share problem ethernet4 Linux - Networking 0 08-28-2004 10:12 AM
(Windows) Only one Linux box can mount a smb share Artimus General 1 07-21-2004 12:12 PM
Connect Red Hat box to Win XP box? VBAHole22 Linux - Newbie 6 05-09-2004 11:13 AM
Can't figure out how to share internet connection in Red Hat 7.3 N52 Linux - Newbie 7 06-06-2003 02:29 PM


All times are GMT -5. The time now is 01:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration