LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-13-2004, 04:20 PM   #1
SniperDevil
LQ Newbie
 
Registered: Jan 2004
Distribution: Debian "sarge" -- testing
Posts: 11

Rep: Reputation: 0
BIND problem... named will not even start.


Hello, I am trying to configure my own nameservers, ns1.unfclan.com and ns2.unfclan.com.

Originally I was using a free DNS (zoneedit.ccom's free service), but I have decided to make my own, just to make things easier in the long run; i.e. not having to go to ZoneEdit's control panel and add a Zone every time, since I have to do it at my server, too.

Anyways, below is some of my systemlog, and the errors I am receiving:

Code:
Jan 13 15:56:59 creativity named[30450]: starting BIND 9.2.1
Jan 13 15:56:59 creativity named[30450]: using 1 CPU
Jan 13 15:56:59 creativity named[30452]: loading configuration from '/etc/named.conf'
Jan 13 15:56:59 creativity named[30452]: no IPv6 interfaces found
Jan 13 15:56:59 creativity named[30452]: listening on IPv4 interface lo, 127.0.0.1#53
Jan 13 15:56:59 creativity named[30452]: binding TCP socket: address in use
Jan 13 15:56:59 creativity named[30452]: listening on IPv4 interface eth0, 66.79.190.90#53
Jan 13 15:56:59 creativity named[30452]: binding TCP socket: address in use
Jan 13 15:56:59 creativity named[30452]: listening on IPv4 interface eth0:1, 66.79.190.91#53
Jan 13 15:56:59 creativity named[30452]: binding TCP socket: address in use
Jan 13 15:56:59 creativity named[30452]: listening on IPv4 interface eth0:2, 66.79.190.92#53
Jan 13 15:56:59 creativity named[30452]: binding TCP socket: address in use
Jan 13 15:56:59 creativity named[30452]: listening on IPv4 interface eth0:3, 66.79.190.94#53
Jan 13 15:56:59 creativity named[30452]: binding TCP socket: address in use
Jan 13 15:56:59 creativity named[30452]: /etc/named.conf:8: couldn't find key 'rndc.key' for use with command channel 127.0.0.1#960
Jan 13 15:56:59 creativity named[30452]: command channel listening on 127.0.0.1#960
Jan 13 15:56:59 creativity named[30452]: couldn't open pid file '/var/run/named/named.pid': Permission denied
Jan 13 15:56:59 creativity named[30452]: exiting (due to early fatal error)
So it's saying address in use... ?? I don't get this; sure obviously apache is running on this machine, but this is on port 260 (I changed the ports to 260 to debug the problem, but it says the exact same thing with 953).



Below is my /etc/named.conf:


Code:
options {
        directory "/var/named";
        allow-query { any; };
        recursion no;
};

controls {
      inet 127.0.0.1 port 960
               allow { localhost; } keys { rndc.key; };
};

key "rndc-key" {
        algorithm hmac-md5;
        secret "eBjwsmGyeHUmARgABSqC/f2dsokWTr/2NOsrb2x51xM=";
};


// Provide a reverse mapping for the loopback address 127.0.0.1
zone "0.0.127.in-addr.arpa" {
     type master;
     file "/var/named/localhost.rev";
     notify no;
};

zone "." {
        type hint;
        file "/var/named/named.ca";
};

zone "image." {
        type master;
        file "/var/named/image..db";
};

zone "ns1.unfclan.com" {
        type master;
        file "/var/named/ns1.unfclan.com.db";
};

zone "ns2.unfclan.com" {
        type master;
        file "/var/named/ns2.unfclan.com.db";
};

zone "unfclan.com" {
        type master;
        file "/var/named/unfclan.com.db";
};

zone "www.unfclan.com" {
        type master;
        file "/var/named/www.unfclan.com.db";
};
And my rndc key is in rndc.key. Can anybody 'debug' this problem? As you may see, I'm a newbie to BIND, but hence the site's name haha.

Thank you very much in advance for your kind help.
 
Old 01-13-2004, 04:49 PM   #2
WeNdeL
Member
 
Registered: Oct 2002
Location: At my desk...
Distribution: RedHat, Fedora, Ubuntu
Posts: 344

Rep: Reputation: 30
couldn't open pid file '/var/run/named/named.pid': Permission denied

Permissions error man... start there first...

edit: uNF uNF uNF!!!

And note that gamers with the word "sniper" in their name are by default n00bs...
 
Old 01-13-2004, 05:02 PM   #3
SniperDevil
LQ Newbie
 
Registered: Jan 2004
Distribution: Debian "sarge" -- testing
Posts: 11

Original Poster
Rep: Reputation: 0
1) I'm running as root...

2) what are you talking about uNF uNF uNF???? it's my clan, yes...

3) How are gamers with the word sniper in their names n00bs? it's just the alias i use...
 
Old 01-13-2004, 05:27 PM   #4
g-rod
Member
 
Registered: Dec 2003
Location: Long Island, NY USA
Distribution: RedHat, SUSE
Posts: 336

Rep: Reputation: 30
Sounds like bind might be running already. Run
netstat -pan;
to find what process are listening on which ports.
 
Old 01-13-2004, 05:43 PM   #5
SniperDevil
LQ Newbie
 
Registered: Jan 2004
Distribution: Debian "sarge" -- testing
Posts: 11

Original Poster
Rep: Reputation: 0
Heh, I think I just fixed it; I have NOOOOOOOOOO idea what i did LOL
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird BIND + Webmin Problem (named.conf) cruzifixion Linux - Networking 1 01-12-2006 05:33 PM
dhcpd and/or BIND (named) problem sneumyer Linux - Networking 2 09-06-2004 05:33 PM
bind and named Red Squirrel Linux - Software 3 04-25-2004 10:49 PM
BIND / named r3ekon Linux - Newbie 6 10-16-2003 06:33 PM
How to Start Named - DNS Bind on boot-up. 360 Linux - Networking 0 05-26-2002 09:52 PM


All times are GMT -5. The time now is 06:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration