LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-19-2009, 05:45 AM   #1
crocodanser
LQ Newbie
 
Registered: May 2009
Posts: 9

Rep: Reputation: 0
Unhappy Bind problem for one domain name


Hi, i have a problem with my Bind 9.

I can't resolve one domain name : runonce.msn.com. When i use a dig, i have a timeout response and when i use +trace option, i have a result....

# dig runonce.msn.com

; <<>> DiG 9.2.4 <<>> runonce.msn.com
;; global options: printcmd
;; connection timed out; no servers could be reached
# dig runonce.msn.com +trace

; <<>> DiG 9.2.4 <<>> runonce.msn.com +trace
;; global options: printcmd
. 189277 IN NS H.ROOT-SERVERS.NET.
. 189277 IN NS I.ROOT-SERVERS.NET.
. 189277 IN NS J.ROOT-SERVERS.NET.
. 189277 IN NS K.ROOT-SERVERS.NET.
. 189277 IN NS L.ROOT-SERVERS.NET.
. 189277 IN NS M.ROOT-SERVERS.NET.
. 189277 IN NS A.ROOT-SERVERS.NET.
. 189277 IN NS B.ROOT-SERVERS.NET.
. 189277 IN NS C.ROOT-SERVERS.NET.
. 189277 IN NS D.ROOT-SERVERS.NET.
. 189277 IN NS E.ROOT-SERVERS.NET.
. 189277 IN NS F.ROOT-SERVERS.NET.
. 189277 IN NS G.ROOT-SERVERS.NET.
;; Received 360 bytes from 127.0.0.1#53(127.0.0.1) in 0 ms

com. 172800 IN NS a.gtld-servers.net.
com. 172800 IN NS b.gtld-servers.net.
com. 172800 IN NS c.gtld-servers.net.
com. 172800 IN NS d.gtld-servers.net.
com. 172800 IN NS e.gtld-servers.net.
com. 172800 IN NS f.gtld-servers.net.
com. 172800 IN NS g.gtld-servers.net.
com. 172800 IN NS h.gtld-servers.net.
com. 172800 IN NS i.gtld-servers.net.
com. 172800 IN NS j.gtld-servers.net.
com. 172800 IN NS k.gtld-servers.net.
com. 172800 IN NS l.gtld-servers.net.
com. 172800 IN NS m.gtld-servers.net.
;; Received 493 bytes from 128.63.2.53#53(H.ROOT-SERVERS.NET) in 108 ms

msn.com. 172800 IN NS ns1.msft.net.
msn.com. 172800 IN NS ns2.msft.net.
msn.com. 172800 IN NS ns3.msft.net.
msn.com. 172800 IN NS ns4.msft.net.
msn.com. 172800 IN NS ns5.msft.net.
;; Received 211 bytes from 192.5.6.30#53(a.gtld-servers.net) in 185 ms

runonce.msn.com. 900 IN CNAME runonce.glbdns.microsoft.com.
;; Received 72 bytes from 207.68.160.190#53(ns1.msft.net) in 172 ms

My nameserver is in Public DMZ. I've desactivate all inspect on my firewall for dns.

Any Idea?

Thx a lot ,
Olivier
 
Old 05-20-2009, 05:16 PM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,894

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Can you resolve other domains, like msn.com?
What happen if you use for example opendns as a dns?
Code:
dig runonce.msn.com @208.67.222.222

Last edited by bathory; 05-20-2009 at 11:59 PM.
 
Old 05-20-2009, 10:06 PM   #3
fur
Member
 
Registered: Dec 2003
Distribution: Debian, FreeBSD
Posts: 310

Rep: Reputation: 35
Do these queries work?

dig @glb1.glbdns.microsoft.com. runonce.glbdns.microsoft.com.

dig @glb2.glbdns.microsoft.com. runonce.glbdns.microsoft.com.

Last edited by fur; 05-20-2009 at 10:07 PM.
 
Old 05-25-2009, 07:35 AM   #4
crocodanser
LQ Newbie
 
Registered: May 2009
Posts: 9

Original Poster
Rep: Reputation: 0
Hi, thx for your help.

All of these queries works. An other idea?

Thx
Olivier
 
Old 05-25-2009, 07:53 AM   #5
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,894

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Can you resolve msn.com from your server, or using opendns servers?
Code:
dig msn.com
dig runonce.msn.com @208.67.222.222
Try also the 2nd query using your dns and tcp protocol:
Code:
dig runonce.msn.com +vc
 
Old 05-26-2009, 12:41 AM   #6
crocodanser
LQ Newbie
 
Registered: May 2009
Posts: 9

Original Poster
Rep: Reputation: 0
[root@dns1 ~]# dig msn.com

; <<>> DiG 9.2.4 <<>> msn.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 4266
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 5, ADDITIONAL: 5

;; QUESTION SECTION:
;msn.com. IN A

;; ANSWER SECTION:
msn.com. 900 IN A 207.68.172.246

;; AUTHORITY SECTION:
msn.com. 113277 IN NS ns1.msft.net.
msn.com. 113277 IN NS ns2.msft.net.
msn.com. 113277 IN NS ns3.msft.net.
msn.com. 113277 IN NS ns4.msft.net.
msn.com. 113277 IN NS ns5.msft.net.

;; ADDITIONAL SECTION:
ns1.msft.net. 120729 IN A 65.55.37.62
ns2.msft.net. 2908 IN A 64.4.59.173
ns3.msft.net. 120729 IN A 213.199.161.77
ns4.msft.net. 120729 IN A 207.46.66.126
ns5.msft.net. 2908 IN A 65.55.226.140

;; Query time: 25 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Tue May 26 07:39:55 2009
;; MSG SIZE rcvd: 219

[root@dns1 ~]# dig runonce.msn.com @208.67.222.222

; <<>> DiG 9.2.4 <<>> runonce.msn.com @208.67.222.222
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 371
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;runonce.msn.com. IN A

;; ANSWER SECTION:
runonce.msn.com. 81 IN CNAME runonce.glbdns.microsoft.com.
runonce.glbdns.microsoft.com. 90 IN A 64.4.18.20

;; Query time: 21 msec
;; SERVER: 208.67.222.222#53(208.67.222.222)
;; WHEN: Tue May 26 07:37:41 2009
;; MSG SIZE rcvd: 88

[root@dns1 ~]# dig runonce.msn.com

; <<>> DiG 9.2.4 <<>> runonce.msn.com
;; global options: printcmd
;; connection timed out; no servers could be reached

[root@dns1 ~]# dig runonce.msn.com +vc

; <<>> DiG 9.2.4 <<>> runonce.msn.com +vc
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 61948
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;runonce.msn.com. IN A

;; Query time: 4250 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Tue May 26 07:38:21 2009
;; MSG SIZE rcvd: 33

Thx for your help
 
Old 05-26-2009, 02:54 AM   #7
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,894

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
This is strange: you get "connection timed out; no servers could be reached" using plain dig and "servfail" when you use tcp to query your dns that's running on localhost!!!
What is the output of:
Code:
netstat -tunapl|grep 53
Now about the actual problem add
Code:
edns-udp-size 512
in the global options of named.conf and see if it helps.
Another thing you can do, is to use tcpdump and try to debug the problem.
 
Old 05-26-2009, 07:54 AM   #8
crocodanser
LQ Newbie
 
Registered: May 2009
Posts: 9

Original Poster
Rep: Reputation: 0
[root@dns2 ~]# netstat -tunapl|grep 53

tcp 0 0 127.0.0.1:10026 0.0.0.0:* LISTEN 29653/master
tcp 0 0 172.17.2.2:53 0.0.0.0:* LISTEN 28573/named
tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 28573/named
tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 29653/master
tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN 28573/named
tcp 0 0 127.0.0.1:10026 127.0.0.1:38653 TIME_WAIT -

udp 0 0 0.0.0.0:53 0.0.0.0:* 28573/named
udp 0 0 172.17.2.2:53 0.0.0.0:* 28573/named
udp 0 0 127.0.0.1:53 0.0.0.0:* 28573/named

What is this command : edns-udp-size 512 ?

Why this command could resolv my problem?

Thx for your help.
 
Old 05-26-2009, 08:20 AM   #9
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,894

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
I still cannot understand why you don't get a response using the default udp protocol to query your dns for that particular domain and you get a servfail using tcp.
Anyway:
Quote:
edns-udp-size defines the size_in_bytes that the server will advertize for an EDNS UDP buffer. Valid values are 512 to 4096, values outside this range will be silently adjusted. The default value is 4096. This statement may be used in a view or global options clause.
Practically it's used to limit the number of packets you receive. Dunno if it helps, but I cannot think of anything else other than you're receining incomplete packets, or the dns sends incomplete packets. There is also the "max-udp-size" that controls the packets you send, but I don't think it works with bind 9.2.4
 
Old 05-26-2009, 09:31 AM   #10
crocodanser
LQ Newbie
 
Registered: May 2009
Posts: 9

Original Poster
Rep: Reputation: 0
I add edns-udp-size 512 in my configuration file and restart service. The problem is always here...

I have this problem just for runonce.msn.com. Can i force to resolv this subdomain as the file /etc/hosts but with bind?

Thx for your help
 
Old 05-26-2009, 02:25 PM   #11
crocodanser
LQ Newbie
 
Registered: May 2009
Posts: 9

Original Poster
Rep: Reputation: 0
Sorry i try commands of fur and it's doesn't work :

[root@dns2 ~]# dig @glb1.glbdns.microsoft.com. runonce.glbdns.microsoft.com.
dig: couldn't get address for 'glb1.glbdns.microsoft.com.': failure

With my capture, i can see that my server knows runonce.msn.com. it's a CNAME of runonce.glbdns.microsoft.com but i can't resolve it.

With the screenshot, you can see dns query. Remote server is not responding....

What are these checksum error????
Attached Images
File Type: jpg capture_26_05_2009-1528.jpg (117.5 KB, 5 views)

Last edited by crocodanser; 05-26-2009 at 02:28 PM.
 
Old 05-26-2009, 03:08 PM   #12
crocodanser
LQ Newbie
 
Registered: May 2009
Posts: 9

Original Poster
Rep: Reputation: 0
glb1.glbdns.microsoft.com --> 204.74.68.5

[root@dns2 ~]# dig @204.74.68.5 runonce.glbdns.microsoft.com

; <<>> DiG 9.2.4 <<>> @204.74.68.5 runonce.glbdns.microsoft.com
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 41633
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;runonce.glbdns.microsoft.com. IN A

;; Query time: 161 msec
;; SERVER: 204.74.68.5#53(204.74.68.5)
;; WHEN: Tue May 26 22:24:15 2009
;; MSG SIZE rcvd: 46


I tried to change my ip address and the problem persist. So normally, i'm not banned by glb1.glbdns.microsoft.com...

Some idea?

Last edited by crocodanser; 05-26-2009 at 03:27 PM.
 
Old 05-26-2009, 03:24 PM   #13
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,894

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
What you can do is to create a forward zone for the domain msn.com, so any queries for *.msn.com are forwarded to the msn.com authoritative name servers.
About the crc error, I don't know why is happening, but it could be because of the packet you send is truncated somehow. That's why I told you to test edns-udp-size.
Is this destination cisco that appears in the screenshot, a PIX? Maybe this is the culprit.
 
Old 05-26-2009, 03:40 PM   #14
crocodanser
LQ Newbie
 
Registered: May 2009
Posts: 9

Original Poster
Rep: Reputation: 0
hummm Yes it's an ASA... I already watch on ASA. There is nothing in log...
 
Old 05-26-2009, 03:55 PM   #15
crocodanser
LQ Newbie
 
Registered: May 2009
Posts: 9

Original Poster
Rep: Reputation: 0
Thx a lot!! I do that :

zone "microsoft.com" {
type forward;
forward only;
forwarders {
194.2.0.20; # DNS FAI
};
};


it works fine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
bind domain name? ninja master Slackware 3 10-20-2008 07:53 AM
DHCPD is updating BIND with <host>.<domain>.<domain>. diabelek Linux - Networking 15 10-11-2007 05:58 AM
BIND - can't get answer for domain but can for other domain Splenden Linux - Server 2 01-12-2007 11:19 PM
Setup BIND for Local Domain and hosting domain ALInux Linux - Networking 4 12-19-2006 02:26 AM
Cant get entry in bind to work with domain.com instead of www.domain.com pxes351 Linux - Networking 12 05-09-2005 06:20 AM


All times are GMT -5. The time now is 09:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration