LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 09-09-2004, 09:16 AM   #1
davidk
LQ Newbie
 
Registered: Sep 2004
Location: Adelaide Australia
Posts: 14

Rep: Reputation: 0
apache start problem


Hello,
I have just finished installing Apache on Mandrake 9. I have used Apache 2.0 I followed the instructions on the apache website and everything seemed to go ok until I started the server. If I type:

apachectl start I get messages saying that my config files don't exist. I then noticed it was looking for them in the wrong place. I copied the default conf files from /usr/local/apache2/conf to /etc/httpd/conf/ which is where it seems to want to look for these files but it keeps telling me my httpd.conf file contains errors. The errors go like this:


$ apachectl start
Starting httpd-perl: fopen: No such file or directory
httpd-perl: could not open document config file /etc/httpd/conf/httpd-perl.conf
[FAILED]
Starting httpd: [Thu Sep 9 11:42:51 2004] [warn] Apache does not support line-e nd comments. Consider using quotes around argument: "#-1"
Syntax error on line 358 of /etc/httpd/conf/httpd.conf:
Invalid command 'Order', perhaps mis-spelled or defined by a module not included in the server configuration
[FAILED]
fopen: No such file or directory
httpd-perl: could not open document config file /etc/httpd/conf/httpd-perl.conf
[FAILED]
[Thu Sep 9 11:43:01 2004] [warn] Apache does not support line-end comments. Con sider using quotes around argument: "#-1"
Syntax error on line 358 of /etc/httpd/conf/httpd.conf:
Invalid command 'Order', perhaps mis-spelled or defined by a module not included in the server configuration
[FAILED]
fopen: No such file or directory
httpd-perl: could not open document config file /etc/httpd/conf/httpd-perl.conf
[FAILED]
[Thu Sep 9 11:43:12 2004] [warn] Apache does not support line-end comments. Consider using quotes around argument: "#-1"
Syntax error on line 358 of /etc/httpd/conf/httpd.conf:
Invalid command 'Order', perhaps mis-spelled or defined by a module not included in the server configuration
[FAILED]





I did go through an dcomment out some of the errors but they don't seem like they are syntax errors as it says. Can someone tell me whats wrong, or at least point me in the right direction?

Thanks
David K
 
Old 09-09-2004, 09:45 AM   #2
maxut
Senior Member
 
Registered: May 2003
Location: istanbul
Distribution: debian - redhat - others
Posts: 1,188

Rep: Reputation: 50
try
#apachectl stop
#/usr/local/apache2/bin/apachectl start

good luck.
 
Old 09-09-2004, 09:51 AM   #3
davidk
LQ Newbie
 
Registered: Sep 2004
Location: Adelaide Australia
Posts: 14

Original Poster
Rep: Reputation: 0
OK
did that and now it seems to have worked. I get this now though

(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

I am thinking this is something to do with my conf file now. Also I have squid running and IP Masq. this wouldn't
be affecting it would it?

why did this work? was I already running apache? I did have it installed automatically with the initial install of
Mandrake

Thanks
David K
 
Old 09-09-2004, 10:06 AM   #4
maxut
Senior Member
 
Registered: May 2003
Location: istanbul
Distribution: debian - redhat - others
Posts: 1,188

Rep: Reputation: 50
u have double apache as i understand. u probably have 2 apachectl too. first of them is located in one PATH directory. other is the one that u have just installed (/usr/local/apache2)
i know that because same thing happened here for a while ago, too
do:
ps aux
to see what process are running. also u can try to search rpm of apache if installed:
rpm -qa|grep httpd
i use redhat, it is called httpd in redhat. i think it is same for mdk
if it is installed u will see it. u can remove it by
rpm -e httpd

u can try the following to see where other apachectl is located.
whereis apachectl

remove old apache. and edit /usr/local/apache2/conf/httpd.conf

good luck.
 
Old 09-10-2004, 06:56 AM   #5
davidk
LQ Newbie
 
Registered: Sep 2004
Location: Adelaide Australia
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks for your help. I have found where I need to look in the httpd.conf file but I don't understand what is required to fix it. I changed the listenning port to 10.0.0.1 which is the IP of my external eth0 card. Can you tell me where I can look for info on this? I am sort of lost.
After I changed the IP I got a similar message but it just said:\

(99)cannot assign requested address: make_sock: could not bind to address 10.0.0.1:80
no listening sockets available, shutting down
unable to open logs

???

If its any use to you:
my external (ISP) IP ADSL address is say a.b.c.d
internal eth0 IP is 10.0.0.1
internal eth1 IP is 192.168.0.1

I have squid running with all default settings
I have IP Masq set up passing ports 80, 110, 25

thanks

Last edited by davidk; 09-10-2004 at 07:10 AM.
 
Old 09-13-2004, 08:49 AM   #6
davidk
LQ Newbie
 
Registered: Sep 2004
Location: Adelaide Australia
Posts: 14

Original Poster
Rep: Reputation: 0
still need help

Hi,
I still need help here if anyone is able to assist. I have since stoped using squid and just use firewall, ip masq and dhcp. Also I have installed apache on a windows system with out any problems. If only I could do the same on Linux.

thanks
David K
 
Old 09-13-2004, 11:59 AM   #7
Pete M
Member
 
Registered: Aug 2003
Location: UK
Distribution: Redhat 9 FC 3 SUSE 9.2 SUSE 9.3 Gentoo 2005.0 Debian Sid
Posts: 657

Rep: Reputation: 30
davidk

Try changing
Listen 10.0.0.1:80 to

Listen 80 notice no ' : ' needed

This will allow Apache to listen on all interfaces, port 80

Just try it this way to see if Apache will start

Also on Redhat you can run /usr/sbin/apachectl -t which will check your conf file for errors, might be the same on Mandrake

Pete
 
Old 09-13-2004, 10:17 PM   #8
davidk
LQ Newbie
 
Registered: Sep 2004
Location: Adelaide Australia
Posts: 14

Original Poster
Rep: Reputation: 0
problem fixed

Yup that was it. somewhere I had put in the listen port as 3128 and the wrong IP number, that of my router.

Thanks very very much both MaxUT and Pete M

Now to do email...

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apache start problem fnoyan Linux - General 2 10-21-2005 06:09 AM
Failed to start apache : Apache does not appear to be running : number11 Slackware 9 02-11-2005 09:51 AM
Apache Start problem SimonT Linux - Software 10 10-22-2004 02:34 AM
Apache won't start, problem with libcppu and mod_auth_mysql.so Null537 Linux - Software 3 05-29-2004 09:32 AM
Apache problem - httpd won't start. Iced_Falcon Linux - Networking 3 12-22-2001 04:31 PM


All times are GMT -5. The time now is 12:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration