LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices

Reply
 
Search this Thread
Old 04-29-2014, 02:24 AM   #1
1sweetwater!
Member
 
Registered: Nov 2011
Location: South Central Montana USA
Distribution: Debian derivitives switched to Mint from Ubuntu but play with them all time and brain permitting...
Posts: 191

Rep: Reputation: Disabled
unable to get recovery menu Mint16Mate


I hold down shift key after BIOS beep in Mint16Mate yet no recovery menu.
BiostarTA75M A4-3400 8gb ram. Using either ps2 HP or Logitech k360 wireless keyboard.
sister machine with Gigabyte A55M DS2 A4-3300 8gb ram running Mint14Mate
is able to run recovery using same method. Using either ps2 HP or Logitech K360 wireless keyboard.
Seems like Biostar doesn't recognize Logitec without an OS. PS2 use to work to get recovery menu. Or is it Logitec's fault? Any ideas how to recover Mint16Mate machine?
 
Old 04-29-2014, 01:23 PM   #2
ondoho
Senior Member
 
Registered: Dec 2013
Distribution: arch linux / crunchbang
Posts: 1,014

Rep: Reputation: 144Reputation: 144
where does it boot to without holding shift?
maybe you can get into recovery mode (basically a root terminal) from there?
 
Old 04-29-2014, 02:16 PM   #3
1sweetwater!
Member
 
Registered: Nov 2011
Location: South Central Montana USA
Distribution: Debian derivitives switched to Mint from Ubuntu but play with them all time and brain permitting...
Posts: 191

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ondoho View Post
where does it boot to without holding shift?
maybe you can get into recovery mode (basically a root terminal) from there?
It boots to the default Mate desktop, just bypassing the recovery menu. You don't suppose just holding the shift key on Mint 16 automatically runs recovery files during boot without showing it on the monitor cuz my system seems to have straightened out. Although I had reselected Mate as the default desktop and couldn't be certain if recovery or reselecting Mate as default was what brought both machines back to a better state.
I briefly searched the net for ways to run recovery on mint16mate and nothing was found. thanx
 
Old 04-29-2014, 02:49 PM   #4
ondoho
Senior Member
 
Registered: Dec 2013
Distribution: arch linux / crunchbang
Posts: 1,014

Rep: Reputation: 144Reputation: 144
recovery menu... i guess it's GRUB you're talking about?
you can adjust GRUB so that the menu comes up at every boot for, say, 5 seconds, then it boots normally if you don't press any buttons.
that would be the first step to find out whether it's really your mouse/keyboard that's not recognized during early boot. i had that myself some time ago, but there's not many things that you can't fix later on after booting up.

fyi, "recovery mode" is usually one of the options you get in the GRUB menu.
 
Old 04-29-2014, 05:51 PM   #5
1sweetwater!
Member
 
Registered: Nov 2011
Location: South Central Montana USA
Distribution: Debian derivitives switched to Mint from Ubuntu but play with them all time and brain permitting...
Posts: 191

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ondoho View Post
recovery menu... i guess it's GRUB you're talking about?
you can adjust GRUB so that the menu comes up at every boot for, say, 5 seconds, then it boots normally if you don't press any buttons.
that would be the first step to find out whether it's really your mouse/keyboard that's not recognized during early boot. i had that myself some time ago, but there's not many things that you can't fix later on after booting up.

fyi, "recovery mode" is usually one of the options you get in the GRUB menu.
Can that grub adjusment be done by checking a box in synaptic or something else in menus? Otherwise I'm clueless here. Learning and doing is part of my dementia. Could take me years to figure out but by that time the version has gone obsolete. I read the links in your reply and wasn't able to gleen how to get her done. Those links seemed to talk about and around it as if I alread knew how to do it. I do remember some Ubuntu versions log ago came with that enabled. Dirty shame we can't quickly select what we liked in all versions and incorporate them in one without having to become a computer scientist. Thanx again
 
Old 04-29-2014, 06:02 PM   #6
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,348

Rep: Reputation: 184Reputation: 184
open a terminal then
Code:
sudo gedit /etc/default/grub
have these lines to be this:
Code:
#GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
then
Code:
sudo update-grub

Last edited by colorpurple21859; 04-29-2014 at 06:03 PM.
 
Old 04-29-2014, 10:17 PM   #7
1sweetwater!
Member
 
Registered: Nov 2011
Location: South Central Montana USA
Distribution: Debian derivitives switched to Mint from Ubuntu but play with them all time and brain permitting...
Posts: 191

Original Poster
Rep: Reputation: Disabled
Would having both grub-commom 2.00-19 and grub2 common 2.00-19 files installed at same time be causing any of this grub issue of not being able to see grub menu on boot after holding down shift key??
I tried to get a screenshot of this in Synaptic but couldn't find where it put it!
 
Old 04-30-2014, 09:47 AM   #8
ondoho
Senior Member
 
Registered: Dec 2013
Distribution: arch linux / crunchbang
Posts: 1,014

Rep: Reputation: 144Reputation: 144
Quote:
Originally Posted by 1sweetwater! View Post
both grub-commom 2.00-19 and grub2 common 2.00-19
?????

anyhow, do what colorpurple said.

apart from that, synaptic is only for installing software (not making screenshots and other day-to-day activities).
you most probably won't need synaptic to solve this.
 
Old 04-30-2014, 11:19 PM   #9
1sweetwater!
Member
 
Registered: Nov 2011
Location: South Central Montana USA
Distribution: Debian derivitives switched to Mint from Ubuntu but play with them all time and brain permitting...
Posts: 191

Original Poster
Rep: Reputation: Disabled
I thought I mentioned this before/earlier but I cannot find it in the thread history. Several boots past, I reselected the Mate desktop as my defaulf desktop to boot to and the boot issue resolved after that. It has booted to Mate ever since maybe 10 boots no hiccoughs. what could have caused it to not boot to Mate when Mate was selected to be the desktop of choice during installation? Since it is booting ok now is it still wise to do what color purple said to do?
 
Old 05-01-2014, 07:11 AM   #10
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,348

Rep: Reputation: 184Reputation: 184
Quote:
Since it is booting ok now is it still wise to do what color purple said to do?
If it is booting the way you want it, then leave it as is.
 
Old 05-10-2014, 06:41 AM   #11
1sweetwater!
Member
 
Registered: Nov 2011
Location: South Central Montana USA
Distribution: Debian derivitives switched to Mint from Ubuntu but play with them all time and brain permitting...
Posts: 191

Original Poster
Rep: Reputation: Disabled
Lightbulb

Quote:
Originally Posted by colorpurple21859 View Post
If it is booting the way you want it, then leave it as is.
I tried something different during boot time before last and got the grub menu. suprise suprise suprise
In previous versions to Mint16Mate I always held down the shift key after BIOS post/beep and was able to do recovery from the menu.
Mint 16 Mate wasn't letting me do it that way. I tried holding down shift key before the BIOS Post/beep and was able to use the grub menu. Anyone know if it is suppose to be this way?
 
Old 05-10-2014, 08:56 PM   #12
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,348

Rep: Reputation: 184Reputation: 184
I've been doing a little bit of investigation and found out that if you want to see the grub menu instead of being hidden will also have to edit /etc/grub.d/30_osprober to change the last line from this
Code:
adjust_timeout
to this
Code:
#adjust_timeout
then rerun
Code:
sudo update-grub
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to create windows recovery disc ravisingh1 General 3 05-08-2013 03:41 PM
I'm using Ubuntu and I changed my password in the recovery mode root menu ... nmc05006 Linux - Newbie 8 04-24-2013 09:55 AM
Lubuntu recovery menu udevd error zeelog Ubuntu 1 02-02-2013 04:19 AM
Viewing Terminal from Linux Recovery Menu SG86- Linux - Newbie 3 03-21-2011 04:38 PM
Finding recovery menu in ubuntu Jbernoski Ubuntu 2 10-28-2008 03:10 PM


All times are GMT -5. The time now is 12:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration