LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices

Reply
 
Search this Thread
Old 02-27-2012, 12:01 PM   #1
Doc CPU
Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 999

Rep: Reputation: 294Reputation: 294Reputation: 294
Disable screensaver in Mint 12 - how?


Hi there,

having switched from Ubuntu 10.10 to Mint 12 some weeks ago, I feel quite comfortable with Mint, using the MATE desktop because I don't like Gnome 3 (that was my main reason to turn my back un Ubuntu).

However, there is one thing that pisses me off: How can I disable the damn pseudo-screensaver?
Whenever the system is idle for about 5min, the screens go blank, with backlight still on (this doesn't make sense, since it won't save power). That's driving me nuts! Isn't there any knob I can turn? Most peculiar, there isn't a GUI anywhere to tune screensaver or any other power management settings. Can it be done from the command line, or by editing a configuration file? If so, which one?

Somewhere I found the advice to specify Option "DPMS" "false" for the monitors in /etc/X11/xorg.conf, which I tried - but to no avail, the screens go blank anyway. Which is quite logical, because there is no DPMS involved here. Mint just blanks the video signal, but maintains HSYNC and VSYNC, and so the monitor keeps operating normally, displaying black all over.

Any advice, ideas, hints?

[X] Doc CPU

PS: It would also be nice if Mint responded to the Power button on a multi-function keyboard ...

Last edited by Doc CPU; 02-27-2012 at 12:15 PM.
 
Old 03-01-2012, 04:25 PM   #2
Doc CPU
Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 999

Original Poster
Rep: Reputation: 294Reputation: 294Reputation: 294
Okay guys,

it's now been three days that this post has been online, and more than 250 users have read it.
Since there's been not a single reply, I take it that none of you have a clue. It gives me some comfort that I'm not the only one who's that stupid.

Thanks a lot anyway.

[X] Doc CPU
 
1 members found this post helpful.
Old 03-01-2012, 05:03 PM   #3
doubtintom
LQ Newbie
 
Registered: Sep 2004
Posts: 2

Rep: Reputation: 0
Hey Doc

My history on this is similar to yours. Hacked around, got to the point of the psuedo-screensaver. Let's keep this alive, somebody's going to know. Or maybe the better place to post is the Mint boards.

Tom
 
Old 03-03-2012, 03:31 PM   #4
Dave251
LQ Newbie
 
Registered: Mar 2012
Posts: 7

Rep: Reputation: Disabled
That's funny I'm in almost the same boat, with the opposite problem
Have you tried dconf-tools ?I think this is were the control will be but am unsure if they work. In the MATE yet

How to upgrade Linux Mint 12's power settings
Here's how you can add advanced power settings to Linux Mint 12's GNOME 3 desktop


dcomf- tools

1. Open a terminal window and type in the following command, then hit enter.

sudo apt-get install dconf-tools

2 go to menu/system tools/dconf editor/ org/gnome/settings-daemon/plugins/power/sleep-display-ac


0 = on
60 = 1 minute


Please let me know if this works for you

Last edited by Dave251; 03-03-2012 at 03:33 PM.
 
Old 03-03-2012, 04:31 PM   #5
Doc CPU
Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 999

Original Poster
Rep: Reputation: 294Reputation: 294Reputation: 294
Hi there,

thank you for caring ...

Quote:
Originally Posted by Dave251 View Post
That's funny I'm in almost the same boat, with the opposite problem
Means what exactly ...?

Quote:
Originally Posted by Dave251 View Post
Have you tried dconf-tools ?
Not before, but now I have. And it didn't change a thing.

Quote:
Originally Posted by Dave251 View Post
go to menu/system tools/dconf editor/ org/gnome/settings-daemon/plugins/power/sleep-display-ac

0 = on
60 = 1 minute

Please let me know if this works for you
It didn't change anything, and the settings displayed in dconf-tools don't even match the reality. For instance, there's a timeout of 1800 seconds for sleep-display-ac, but actually the display goes blank after 5mins (300sec). And there's "suspend" as the action for the power button event, but when I press the power button, the system actually shuts down (which is what I want).
So I think dconf-tools controls some settings that aren't used anywhere.

[X] Doc CPU
 
Old 03-03-2012, 07:02 PM   #6
Dave251
LQ Newbie
 
Registered: Mar 2012
Posts: 7

Rep: Reputation: Disabled
That's funny I'm in almost the same boat, with the opposite problem
means I switched from kubuntu 8.04 to mint 12 and am having monitor issues

try login in to the GNOME as admin to set the parameters this is my original post
http://forums.linuxmint.com/viewtopic.php?f=47&t=95899
 
Old 03-04-2012, 05:40 AM   #7
Doc CPU
Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 999

Original Poster
Rep: Reputation: 294Reputation: 294Reputation: 294
Hi there,

it's getting weirder.

Quote:
Originally Posted by Dave251 View Post
That's funny I'm in almost the same boat, with the opposite problem
means I switched from kubuntu 8.04 to mint 12 and am having monitor issues

try login in to the GNOME as admin to set the parameters this is my original post
http://forums.linuxmint.com/viewtopic.php?f=47&t=95899
alright, let's go step by step.

I don't know what you mean by "Admin", because neither GNOME nor MATE will allow you to log in as root. However, you can start dconf-tool either as a normal user or as root. But that doesn't make a difference, because even when I start it as a normal user, I can modify the settings, and they get stored somewhere, which I can see when I close dconf-tool and open it anew.

I tried to log in to GNOME now, and hey - under GNOME I get to the screensaver and power management settings. And they have the expected effect. For instance, the monitor stays on the way I want it to. But since I don't want to use GNOME and rather prefer MATE, that isn't a solution for me, because once I log in to MATE again, the settings made in dconf-tools or the GNOME GUI have no effect any more. Very obviously, GNOME and MATE use different configuration records.

By the way, on my Intel Atom based notebook, my mouse pointer always freezes when I access power or screensaver settings in GNMOE. When it happens again, I'll try to connect an external mouse to see if that behaves different. Is there a command-line way to restart the mouse driver only without killing and restarting the entire X server?

[X] Doc CPU
 
Old 03-04-2012, 09:04 AM   #8
rokytnji
Senior Member
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 13 , Various Puppys (MacPup,Slack0),MX-14
Posts: 2,558
Blog Entries: 16

Rep: Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818
I don't use Mint but

Quote:
Is there a command-line way to restart the mouse driver only without killing and restarting the entire X server?
http://antix.freeforums.org/post15330.html#p15330

I just installed Mate in my AntiX 11 base install in my Motorcycle Desktop which runs Fluxbox as the default Window Manager via slim login and my ~/.xinitrc setup. I have my screen set to go black (but this is a desktop so no power saving needed).

Quote:
Somewhere I found the advice to specify Option "DPMS" "false" for the monitors in /etc/X11/xorg.conf, which I tried - but to no avail, the screens go blank anyway
Wondering if you read the advice you mentioned here
 
Old 03-04-2012, 09:11 AM   #9
Dave251
LQ Newbie
 
Registered: Mar 2012
Posts: 7

Rep: Reputation: Disabled
Ok when i installed mint 12 one of the first questions it asked me was what type of account I wanted to make administrator or user. So I made an admin account to further isolate the root because in reality you can have root ,admin, and user. Iinstalled the software I wanted as admin and created a user account from admin control panal with no privileges. this is how my mint is set up. I had the same problem you have after initial instillation so I went to dconf-tools in GNOME admin mode, and set the parameter I showed you from 600 to 0 now my monitor stays on all the time in mate, which I run in user mode. Now from what I have read mate is a work in progress, So i'm not sure if dconf-tools is complete, or if the front end is there and they are still setting up the back end, so it might not all be there yet. Maybe it's just me because apart from dconf-tools I find I have literaly no controles for the monitors I can change the background and thats about all


I've used dcon-tools elsewhere and it seems to work fine
 
Old 03-04-2012, 09:54 AM   #10
Doc CPU
Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 999

Original Poster
Rep: Reputation: 294Reputation: 294Reputation: 294
Hi there,

Quote:
Originally Posted by Dave251 View Post
Ok when i installed mint 12 one of the first questions it asked me was what type of account I wanted to make administrator or user.
I can't remember being asked such a question - AFAIK the Mint setup just created one user, whose login name, password and real name I had to specify, and automatically made that user sudo-able (i.e. allowed to obtain root privileges temporarily). I didn't create a second user.

Quote:
Originally Posted by Dave251 View Post
I had the same problem you have after initial instillation so I went to dconf-tools in GNOME admin mode, and set the parameter I showed you from 600 to 0 now my monitor stays on all the time in mate, which I run in user mode.
Very strange, because I found that the settings in GNOME seem to have no effect on the behavior in MATE.

Quote:
Originally Posted by Dave251 View Post
Now from what I have read mate is a work in progress
That's indeed what it is, and so I hope that one or the other problem I'm faced with now will be fixed within a few weeks or months.

Quote:
Originally Posted by Dave251 View Post
Maybe it's just me because apart from dconf-tools I find I have literaly no controles for the monitors I can change the background and thats about all
That's exactly my perception as well.

[X] Doc CPU
 
Old 03-04-2012, 11:43 AM   #11
Dave251
LQ Newbie
 
Registered: Mar 2012
Posts: 7

Rep: Reputation: Disabled
OK I think were on the same page dconf-tools is probable the place to change these configs, but it does not work in the mate yet would you agree?
 
Old 03-04-2012, 12:19 PM   #12
Doc CPU
Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 999

Original Poster
Rep: Reputation: 294Reputation: 294Reputation: 294
Hi there,

Quote:
Originally Posted by Dave251 View Post
OK I think were on the same page dconf-tools is probable the place to change these configs, but it does not work in the mate yet would you agree?
honestly, I don't really understand that sentence. I think you want to say:

1. dconf-tools is the right place to change these settings like screen saver and power management.
2. Obviously MATE ignores the parameters set by dconf-tools.

And yes, I agree. And I'm not sure if we should consider it a bug of MATE, because what you showed me is clearly meant for the GNOME settings daemon. MATE is not GNOME, even though it tries to follow the trails of GNOME 2. I think it should either honor the settings of GNOME or provide its own tool to set the parameters.
However, I would call it a bug that it does neither.

[X] Doc CPU
 
Old 03-04-2012, 01:38 PM   #13
Dave251
LQ Newbie
 
Registered: Mar 2012
Posts: 7

Rep: Reputation: Disabled
I can't really say. all I can say is I wont go back to 8.04

Where do you go to set your monitors in mate? I go to controlcenter/monitors it shows the monitors(2) as one big unknown with the right res, but wrong refresh rate, the only thing that works is the show monitors in panel switch. I cant adjust the brightness except in the nvidiaX server, I can't adjust the sleep settings, or colors I don't even have a screen button in the control center like gnome even though it does not give me control of these options.
 
Old 03-04-2012, 02:16 PM   #14
Doc CPU
Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 999

Original Poster
Rep: Reputation: 294Reputation: 294Reputation: 294
Hi there,

Quote:
Originally Posted by Dave251 View Post
Where do you go to set your monitors in mate? I go to controlcenter/monitors
so do I.

Quote:
Originally Posted by Dave251 View Post
it shows the monitors(2) as one big unknown with the right res, but wrong refresh rate, the only thing that works is the show monitors in panel switch.
On my two systems, that works fine. My desktop PC with an onboard Radeon graphics adapter (using the proprietary fglrx driver) displays the two monitors correctly, even with their names. I can select resolution, refresh rate, placement and rotation of each monitor separately. My notebook with an Intel 945 integrated graphics solution and 1024x600 (using the generic open-source driver) display also works correctly; however, it's displayed with just a generic name. I haven't yet tested to connect an extra monitor to my notebook.

Quote:
Originally Posted by Dave251 View Post
I cant adjust the brightness except in the nvidiaX server
Hmm? I adjust brightness, contrast and color temperature at the monitor itself, not anywhere in the graphics driver.

Quote:
Originally Posted by Dave251 View Post
I can't adjust the sleep settings, or colors I don't even have a screen button in the control center like gnome even though it does not give me control of these options.
Interesting. Well, I can't adjust the sleep settings either (that was why I started this thread), but there's the monitor applet in System Preferences that allows me to set all the monitor's physical parameters. If I want so, I can have the monitor icon in the notification panel - but I didn't select that, because it would unnecessarily use precious space.

[X] Doc CPU
 
Old 03-04-2012, 03:02 PM   #15
Dave251
LQ Newbie
 
Registered: Mar 2012
Posts: 7

Rep: Reputation: Disabled
Well Doc looks like I got bigger issues than I thought, thanks for the input. Best luck solving your problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable screensaver in Fluxbox Mr. Alex Linux - Newbie 3 04-25-2012 11:17 PM
xfce4 disable screensaver tuxrules Slackware 1 10-28-2011 08:13 PM
Disable screensaver in LXDE Ipolit Linux - Desktop 5 08-06-2009 09:33 AM
Cannot disable the screensaver lock davidguygc Linux - Desktop 2 08-01-2007 05:30 PM
How to disable screensaver for some applications ... legroschat Linux - Software 5 08-28-2003 01:49 AM


All times are GMT -5. The time now is 08:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration