LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 12-16-2003, 08:12 AM   #1
Crashedfiesta
LQ Newbie
 
Registered: Dec 2003
Posts: 3

Rep: Reputation: 0
Unhappy Passing kernel parameters at boot with LILO


My first question on this forum (and definitely not the last....)

I have an AST Ascentia M series laptop running Red Hat 7.0 (enigma) with XFree86 4.2 (I think). Xconfigurator never seemed to work correctly with the graphics chipset (Cirrus GLD 7555 2Mb video ram) until I discovered from another site that by passing the parameter "vga=791" to activate the framebuffer thingy at the LILO prompt the chipset works great. I also get the funky penguin whilst booting .

My problem is this. I want to pass this parameter to the kernel automatically so I don't have to do ctrl-x and manually enter "vga=791" every time I start up the laptop. I have added the following line in various places of lilo.conf :

append="vga=791"

and it doesn't work anywhere. I tried at the start as a global parameter and also just after the 'linux' line too but to no avail.

(Before anyone says, yes I did run the 'lilo' command afterwards )

Any ideas?

Incidentally I did the same on my Red Hat 9 box with no problems. Just added it at the end of the linux line in /boot/grub/grub.conf with no problems.
 
Old 12-16-2003, 09:27 AM   #2
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
I don't know if this causing the problem, but try it as a bare
vga = 791
instead of an append. Plus, the fine manual says it won't work if you've already got an append line, such as scsi-emulation and you add a second append - you have to put all appends on one line.

(This is assuming it works in the first place which, based on your post, it does. My i810e on the Celeron doesn't like any of those options.)
 
Old 12-16-2003, 09:51 AM   #3
Crashedfiesta
LQ Newbie
 
Registered: Dec 2003
Posts: 3

Original Poster
Rep: Reputation: 0
Hmmmm. Seems I was too quick to assume 'vga' was a kernel parmeter. Reading the man pages it does seem as if vga=791 should be on it's own as it seems to actually be a lilo parameter. I'll try that when I get home tonight.....

Serves me right for missing out one of the best sources of info in Linux, the man pages......doh.

Oh, and my box at work (with an i810) doesn't work any of those settings either .......

EDIT

Yup. By adding just :

vga=791

to lilo.conf it now works.

Next time i'll RTFM......

Last edited by Crashedfiesta; 12-16-2003 at 01:48 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
passing parameters to network modules muru Linux - Networking 4 10-21-2005 11:44 AM
Passing parameters to a shell script neocookie Linux - General 5 10-20-2005 12:44 PM
Passing parameters to bash script Kamikazee Programming 4 10-01-2005 07:41 AM
Passing Parameters to Bash Script mooreted Linux - Software 3 04-05-2004 10:08 PM
PHP - passing multiple parameters jacksmash Programming 1 11-25-2003 11:56 AM


All times are GMT -5. The time now is 10:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration