LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 11-02-2006, 09:27 AM   #1
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
Howto: Get your Gateway (Or Finepoint Pen) Working


Finally found some useful info on the Finepoint Innovations Tablet PC Digitizers. Most notably of late the Gateway cx series and M series tablet PC's seem to use almost exclusively these pens...

Step 1. Editing Xorg.conf

Add the following, you may need to play with the min and max numbers, but hopefully not.

Section "InputDevice"
Identifier "Tablet"
Driver "fpit"
Option "Device" "/dev/ttyS0"
Option "AlwaysCore" "on"
Option "InvertY"
Option "MaximumXPosition" "12550"
Option "MaximumYPosition" "7650"
Option "MinimumXPosition" "400"
Option "MinimumYPosition" "400"
Option "SendCoreEvents"
EndSection

You also need to add InputDevice "Tablet" to the server layout section of your xorg.conf

Step 2.

You'll need the folllowing in your serial.conf or setserial.conf or whatever file your distro has to set up it's serial ports...

/dev/ttyS0 port 0x03F8 irq 4 baud_base 38400

Step 3. You'll need the source of latest fpit source code, and edit xf86Fpit.c and comment out the line which reads if (!prox) buttons=0;

Step 4. Put the following in your .xinitrc file, or make a .xinitrc file in your home directory and add this...

xsetpointer TOUCHSCREEN
xmodmap -e "pointer = 1 3 2"


My cx2618 tracks the pen but clicking is still broken. I hear an M280 and a cx2610 work fine, perhaps other models will be lucky with this method.
 
Old 11-02-2006, 01:56 PM   #2
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Original Poster
Rep: Reputation: 45
Ok, clicking works as well. For some reason even though the version I compile won't work just copying the driver from another user's distro works fine.
 
Old 12-07-2006, 04:45 AM   #3
cmkidd75
LQ Newbie
 
Registered: Dec 2006
Location: Hagerstown, Maryland
Distribution: Suse 10.1
Posts: 1

Rep: Reputation: 0
newbie in need

I am new to linux and need a little more direction. I am currently on a Gateway CX200X Tablet with dual boot XP and Suse 10.1. I found the Xorg.conf files and need to know which to edit and how to edit them. Possibly a more step by step instruction. Any help would be appreciated. The sooner the pen works the sooner windows leaves.
 
Old 12-09-2006, 06:27 PM   #4
thejonmoore
LQ Newbie
 
Registered: Jul 2005
Location: Kentucky
Distribution: Debain, Slack, Fedora
Posts: 18

Rep: Reputation: 0
This was a problem I fought with for a while, but I have finally got it working.

Everything Caeda said is basically all that needs to be done. I kept having errors when trying to recomple the fpit drivers, though. There is a post on the Ubuntu forums about this, and a person there is offering the compiled module for download. Grab that, and things work.

One addition I might add, changing the driver from "i810" to "intel" seems to let you run at 1280x768 and suppors rotation. Still don't have the pen (or mouse) rotating as well, but thats another story.
 
Old 12-11-2006, 10:05 AM   #5
bb002
Member
 
Registered: Aug 2005
Posts: 80

Rep: Reputation: 15
...Step 3 isn't very clear. Where might I find the latest fpit source code? Google isn't being very helpful for a change.
 
Old 12-11-2006, 04:31 PM   #6
thejonmoore
LQ Newbie
 
Registered: Jul 2005
Location: Kentucky
Distribution: Debain, Slack, Fedora
Posts: 18

Rep: Reputation: 0
Quote:
Originally Posted by bb002
...Step 3 isn't very clear. Where might I find the latest fpit source code? Google isn't being very helpful for a change.
There is a post over at the Ubuntu forums with some links to this. I had some troubles recompiling though. That post, on the Ubuntu forums, as a link where you can downloaded the updated drivers.

Update:
Rather pointless without a link the other forums, huh.
fpit driver download

Last edited by thejonmoore; 12-11-2006 at 04:32 PM.
 
Old 12-14-2006, 04:45 PM   #7
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Original Poster
Rep: Reputation: 45
The link to ubuntu forums is not for the source that most people would be using. The files posted there included a compiled driver for use on gentoo/ubuntu or systems that exactly match the way the computers on that forum are setup.

It was assumed (by me) that anyone attempting to follow these instructions was perfectly capable of going to the xorg website and downloading fpit which they DO provide for download.

http://xorg.freedesktop.org/releases/ is what you'd get if you just used google.
 
Old 12-14-2006, 04:53 PM   #8
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Original Poster
Rep: Reputation: 45
Oh, and also. The i810 driver supports rotation just fine. As well as direct rendering, as long as your using one of the newer versions of Xorg (you should be at 7.0 or above by now, no reason not to be.) to which these instructions apply. Do not change anything to "intel."
 
Old 12-14-2006, 05:11 PM   #9
thejonmoore
LQ Newbie
 
Registered: Jul 2005
Location: Kentucky
Distribution: Debain, Slack, Fedora
Posts: 18

Rep: Reputation: 0
Quote:
Originally Posted by Caeda
Oh, and also. The i810 driver supports rotation just fine. As well as direct rendering, as long as your using one of the newer versions of Xorg (you should be at 7.0 or above by now, no reason not to be.) to which these instructions apply. Do not change anything to "intel."
Using the intel driver in Fedora Core 6 opened up the native 1280x768 resolution. Going from 1024x768 to 1280 made for a much better expirence. Though, I'm sure there are ways of getting the higher res with the i810 driver, it was just easier for me this way

Did you get the pen to rotate with the tablet? My problem when using the i810 and rotation (same with the intel driver) is that when I rotate the screen, the pen doesn't "turn" with it. Up becomes Down, Down becomes Up, etc...
 
Old 12-17-2006, 05:36 AM   #10
kingofearth
LQ Newbie
 
Registered: Dec 2006
Posts: 11

Rep: Reputation: 0
I just got a new Gateway tablet a couple days ago and have read this thread and the Ubuntu forum a few times but I can't seem to get a couple things to work. I think the tablet isn't working because when I try to cat /dev/ttyS0 it says "Input/Output error". I know I have serial support in my kernel, and I have the serial commands in /etc/serial.conf and my serial init script is running at boot, so I don't know what the problem would be. Also dmesg | grep tty doesn't display anything.

Also, KDE doesn't want to give me widescreen support with my intel card. I'm running Gentoo Linux with the very latest xf86-video-i810 driver. So any information or links or anything would be appreciated.
 
Old 12-17-2006, 07:41 PM   #11
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Original Poster
Rep: Reputation: 45
Which tablet? Are you sure it's a finepoint model?
 
Old 12-17-2006, 10:58 PM   #12
kingofearth
LQ Newbie
 
Registered: Dec 2006
Posts: 11

Rep: Reputation: 0
It's a CX210X so based on what I've read it should be a Finepoint. And the driver may work, I'm not sure cause it doesn't get that far since catting /dev/ttyS0 gives me an input output error.
 
Old 12-18-2006, 08:24 AM   #13
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Original Poster
Rep: Reputation: 45
Hrm, you shouldnt get an input output error as long as you have that line in your serial.conf or as long as you've got it set to run at startup...

What happens if you run

/bin/setserial /dev/ttyS0 autoconfig
/bin/setserial /dev/ttyS0 port 0x03F8 irq 4 baud_base 38400

instead?

And are you sure you have acpi compiled loaded an enabled? You need it for the irq's to be set up properly.
 
Old 12-18-2006, 09:52 AM   #14
kingofearth
LQ Newbie
 
Registered: Dec 2006
Posts: 11

Rep: Reputation: 0
That doesn't work either.
Code:
localhost linux # /bin/setserial /dev/ttyS0 autoconfig
Cannot autoconfigure port: Device or resource busy
localhost linux # /bin/setserial /dev/ttyS0 port 0x03F8 irq 4 baud_base 38400
localhost linux # cat /dev/ttyS0
cat: /dev/ttyS0: Input/output error
localhost linux # /bin/setserial /dev/ttyS1 autoconfig
localhost linux # /bin/setserial /dev/ttyS1 port 0x03F8 irq 4 baud_base 38400
localhost linux # cat /dev/ttyS1
cat: /dev/ttyS1: Input/output error
And .I have ACPI compiled and most of the ACPI stuff turned on, but I don't see why the stuff thats off should effect it.
Code:
#
# ACPI (Advanced Configuration and Power Interface) Support
#
CONFIG_ACPI=y
CONFIG_ACPI_AC=y
CONFIG_ACPI_BATTERY=y
CONFIG_ACPI_BUTTON=y
# CONFIG_ACPI_VIDEO is not set
# CONFIG_ACPI_HOTKEY is not set
CONFIG_ACPI_FAN=y
# CONFIG_ACPI_DOCK is not set
CONFIG_ACPI_PROCESSOR=y
CONFIG_ACPI_THERMAL=y
# CONFIG_ACPI_ASUS is not set
# CONFIG_ACPI_IBM is not set
# CONFIG_ACPI_TOSHIBA is not set
CONFIG_ACPI_BLACKLIST_YEAR=2001
CONFIG_ACPI_DEBUG=y
CONFIG_ACPI_EC=y
CONFIG_ACPI_POWER=y
CONFIG_ACPI_SYSTEM=y
CONFIG_X86_PM_TIMER=y
# CONFIG_ACPI_CONTAINER is not set
# CONFIG_ACPI_SBS is not set

Last edited by kingofearth; 12-18-2006 at 10:40 AM.
 
Old 12-18-2006, 12:19 PM   #15
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Original Poster
Rep: Reputation: 45
Your getting the message I get when it's already configured. The "device busy" message. They may have changed the pen in your model. Or assigned a different IRQ.
 
  


Reply

Tags
driver, gateway, gentoo, pc, pen, tablet, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pen not working on wp5540u tablet? db391 Linux - Hardware 2 12-15-2006 06:50 PM
Finepoint Innovations Pen PC Caeda Linux - Laptop and Netbook 2 07-10-2006 10:27 PM
automatic USB pen drive working fakie_flip Ubuntu 2 09-29-2005 09:29 AM
Usb Flash Pen Not Working wisdom Linux - Hardware 13 01-07-2005 07:47 PM
howto mount usb pen drive? name_in_use450 Linux - Hardware 2 08-24-2004 08:23 AM


All times are GMT -5. The time now is 12:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration