LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 03-12-2009, 12:05 AM   #1
JimmyTaylor
LQ Newbie
 
Registered: Mar 2009
Posts: 7

Rep: Reputation: 0
Question Boot loader change - Vista & Fedora 9?


Hey guys,

So this Linux newbie decided to install Fedora 9 (on a separate partition) on a laptop that's been running Vista. I decided to configure it for dual-booting. At the boot loader configuration during the installation, I decided to install the boot loader on /dev/sda.

I've got Vista running on what the boot loader shows to be on /dev/sda1, and Fedora 9 on /dev/sda2. I chose the latter to be the default OS.

Everything went smooth, the installation was successful. But, every time I power on my laptop, I get to the GRUB boot loader screen with two options:
- Fedora (2.6.25 - 19.fc9.i686)
- Other (Choosing this takes me to Vista)

I was hoping to see the good ol' Windows Boot Loader instead of GRUB, allowing me to choose between Vista and Fedora. I mean, GRUB does that, but I want Vista to be my default, and currently it's not. Yes, I know I chose Fedora to be the default, but I assumed I would get the Windows Boot Loader upon powering on my laptop.

Is there a way to get Windows Boot Loader to show up instead and change the default OS to Vista? Any help is appreciated, and if more information is needed, feel free to ask

Jim

Last edited by JimmyTaylor; 03-12-2009 at 12:09 AM. Reason: Added a little bit more info.
 
Old 03-12-2009, 12:22 AM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,658
Blog Entries: 3

Rep: Reputation: 222Reputation: 222Reputation: 222
Default system means the first choice on grub. Not default windows operating system. Or default linux OS. good luck. You need grub to dual boot your system.
 
Old 03-12-2009, 12:29 AM   #3
yancek
Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 5,063

Rep: Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802
If you want vista to be your default, all you have to do is boot into Fedora, login as root user, navigate to a file called menu.lst in the /boot/grub/ directory and edit it. Near the top will be the word "default", probably with a zero (0) after it. There will be at least 2 entries, Fedora and 'other' (vista). You count the title lines and put the number for vista after 'default'. Grub counts from zero, so if vista is the third title entry put 2 after default. You can also change 'other' to 'vista' or whatever you want to call it by editing the title line currently labelled 'other'. Additionally, there is an entry at the top that says 'timeout' and you can put a number there for the number of seconds before it automatically boots.

If you want to acatually boot from the vista bootloader for vista and Fedora, you can do that also but it won't be as easy. I would suggest if you want to try that, you download EasyBCD from neosmart technologies (just google that).

The default installation for Ubuntu is to put Grub in the master boot record. I haven't installed Ubuntu lately but you should have had an Advanced tab to click on to change that during your installation. Almost all distributions give you that choice, unlike windows.
 
Old 03-12-2009, 02:55 PM   #4
Zen alsory
Member
 
Registered: Aug 2008
Location: At home
Distribution: Fedora 13
Posts: 49

Rep: Reputation: 16
Hello..Jimmy
if you want dual boot and dual OS you have to use GRUB , if you use windows boot leader you won't be able to access to fedora
because windows can't see other OS but Linux can..!!!!
 
Old 03-13-2009, 09:45 AM   #5
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,658
Blog Entries: 3

Rep: Reputation: 222Reputation: 222Reputation: 222
if you want to reinstall windows boot loader to the mbr then make a boot cdrom then use super grub then do that. that way you can boot to windoze and when you want to use a real operating system like linux. then put your boot cdrom disk in and boot it.
 
Old 03-13-2009, 02:42 PM   #6
Ciprian
LQ Newbie
 
Registered: Mar 2009
Location: Romania
Distribution: Fedora 10
Posts: 5

Rep: Reputation: 0
Hi,
I have kind of same problem, but I want what Jimmy doesn't: to boot on grub. I installed Fedora 10 x86_64 and my laptop boots directly in veesta. I want to be asked which OS I want to choose. Any advise? Thanks.
 
Old 03-13-2009, 04:38 PM   #7
yancek
Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 5,063

Rep: Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802
When you installed Fedora you probably did not choose the option to install to the master boot record. If you had, you would be seeing the Grub menu. Post the output of the "fdisk -l" command run as root user to show your partition information and someone should be able to tell you the correct commands.
 
Old 03-14-2009, 01:33 AM   #8
JimmyTaylor
LQ Newbie
 
Registered: Mar 2009
Posts: 7

Original Poster
Rep: Reputation: 0
Well, I did what yancek said in his first post, and you know, it's not bad Looks pretty with the laser blue background, and that beats the boring black Windows boot loader background any day. Not that I care about the color, I don't XD

But I did get Vista to be the default OS. Thanks, yancek!!

Jim
 
Old 03-15-2009, 03:28 PM   #9
Zen alsory
Member
 
Registered: Aug 2008
Location: At home
Distribution: Fedora 13
Posts: 49

Rep: Reputation: 16
Hello..Ciprian
if you haven't install GRUB when you installed fedora try this:
make upgrade from fedora dvd and chose create new boot loader ..
it works ..i have tried it ...
 
Old 06-12-2009, 01:14 AM   #10
Thrasher11
LQ Newbie
 
Registered: Jun 2009
Posts: 3

Rep: Reputation: 0
Same Issue as Jimmy

I currently have Fedora Core 5 as my default OS and would like to change it to Vista.

I am trying to access the menu.lst file to make the adjustments but for some reason it says I do not have the permission. It would not display what is inside the file. There is a red circle with a line across it on the file icon. I am logged in as a root user.

Any ideas?

Thanks!
 
Old 06-12-2009, 01:35 AM   #11
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,433

Rep: Reputation: 1066Reputation: 1066Reputation: 1066Reputation: 1066Reputation: 1066Reputation: 1066Reputation: 1066Reputation: 1066
Try grub.conf - it should be linked to menu.lst.
Just a bad concept that Redhat used to follow. Not sure about FC5, but easy enough to check.
 
Old 06-13-2009, 04:33 AM   #12
Cr4s5
LQ Newbie
 
Registered: Jun 2009
Location: North Philthy
Distribution: Archlinux, Debian testing
Posts: 1

Rep: Reputation: 1
Thrasher11

when you say you are logged in as root, I am understanding that as you logged into a session as root, and then browsed to the menu.lst file throught the file browser. Thats how i understand what you meant, from reading your post. If you want to edit the the menu.lst file, log into a session as a normal user, open a terminal, and type

"su" without the quotes, then hit enter.

then type your root password.This makes you root, and gives you permission to change the menu.lst file.
then you are going to use a text editor to change the menu.lst file. Im not familiar with fedora and what text editor it uses, and also im not 100% sure if the menu.lst file is located in the same place as it is in other distros. For an example of what to type next, here is what i would type to edit my menu.lst file.

nano /boot/grub/menu.lst

(i would type this into a terminal as root, and hit enter). nano is a text editor, and another one would be gedit.this command will open my menu.lst file for me to edit it. If you use nano, after you make changes, hit control+o, enter, control+x . what that does is save the changes i made with nano, to the menu.lst file. If you use gedit, it is simple to save changes made, by clicking on the save button toward the top left of the editor's window. Hope you understand this and it helps.
 
Old 06-14-2009, 02:12 AM   #13
Thrasher11
LQ Newbie
 
Registered: Jun 2009
Posts: 3

Rep: Reputation: 0
syg00 and Cr4s5,

Thanks for your reply! Cr4s5, you wer correct, I was trying to access menu.lst file via a file broswer. grub.conf had the same issue, no access permission using file browser.

I followed your tips on using Terminal and found it to be successful, thanks!! However, bear with me, as you can tell, I am new to Linux...I am not sure what to change in this file to make my Vista the default OS. Here is the content of menu.lst:

#grub.conf generated by anaconda
#
#Note that you do not have to rrun grub after making changes to this file
#NOTICE: You do not have a /boot partition. This means that
# all kernel and initrd paths are relative to /, eg
# root(hd1,2)
# kernel /boot/vmlinuz-version ro root=/dev/sdb3
# initrd /boot/initrd-version.img
#boot=/dev/sda
default=0
timeout=10
splashimage=(hd1,2)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.15-1.2054_FC5smp)
root (hd1,2)
kernel /boot/vmlinuz-2.6.15-1.2054_FC5smp ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.15-1.2054_FC5smp.img
title Other
rootnoverify (hd0,0)
chainloader +1

Thanks for your help thus far!
 
Old 06-14-2009, 02:59 AM   #14
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,433

Rep: Reputation: 1066Reputation: 1066Reputation: 1066Reputation: 1066Reputation: 1066Reputation: 1066Reputation: 1066Reputation: 1066
Count the number of the "title" line of interest - then subtract 1 because grub uses zero-based counting.
So, in your case 2-1; change the default line to 1.
Edit the title text to something meaningful while you're there.

If you want to see the menu so you can make a selection yourself, comment the "hiddenmenu" line by putting a # in column one.
 
Old 06-14-2009, 06:26 AM   #15
GTrax
Member
 
Registered: Oct 2005
Location: UK
Distribution: Mint
Posts: 206

Rep: Reputation: 32
I multi-boot 4 distros and a Windows, by editing menu.lst. There are some tricks you might like to know.

It is way easier to let Linux GRUB start off Windows as the default choice than the other way around. You can either edit "default(0)" to read something else, or move the little group of commands up to be the first encountered.

Notice that the group of commands that booted Windows uses "chainloader +1". This just means that when the PC first looks on the hard drive MBR (master boot record), and gets to start GRUB, then GRUB simply points it onward to the Windows bootloader as if GRUB was not there. If ever you do a clean Windows install, it will ALWAYS overwrite the master boot record, and your Fedora will (temporarily) seem to be unavailable until you install GRUB again.

I have seen a little refinement to what can be the default. Each little group of lines to boot each OS starts with a "title" line, then a pointer to the partition where a kernel can be found, then a boot line to the kernel filename (or maybe a link to it), with some boot options, and often a last line to a thing called "iniramfs".
If the line "savedefault" or "savedefault=true" is added, then whichever was the choice last time around, will be the default choice again until you select something different when booting up.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to change from grub boot loader to lilo boot loader linuxjamil Linux - Software 1 05-27-2008 02:47 PM
fedora/vista dual boot - partimage: restored vista - vista won't let me log on redmoon zero Linux - General 1 12-31-2007 08:21 PM
Dual Boot Vista & Fedora biksuni Linux - General 15 04-10-2007 04:27 AM


All times are GMT -5. The time now is 09:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration