LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices

Reply
 
Search this Thread
Old 03-05-2012, 11:48 PM   #1
viveck
LQ Newbie
 
Registered: Mar 2012
Posts: 5

Rep: Reputation: Disabled
To disable USB port


Hello Everyone
How can i Disable USB?
I had already tried usb-storage kernal module and modprobe as well . is there any other way? kindly reply at this front. thanks in advance/
 
Old 03-06-2012, 12:28 AM   #2
Cultist
Member
 
Registered: Feb 2010
Location: Chicago, IL
Distribution: Slackware64 14.1
Posts: 777

Rep: Reputation: 102Reputation: 102
not adding anyone to the plugdev user group should accomplish the same thing as disabling usb ports I think
 
Old 03-13-2012, 03:20 PM   #3
nini09
Senior Member
 
Registered: Apr 2009
Posts: 1,058

Rep: Reputation: 88
Removing usb-storage module should be working. What problem do you get, module is in use?
 
Old 03-15-2012, 05:41 AM   #4
viveck
LQ Newbie
 
Registered: Mar 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
hi

In my system modprobe -r not working. i had also tried to blacklist usb-storage the module but it's not worth
 
Old 03-15-2012, 04:02 PM   #5
nini09
Senior Member
 
Registered: Apr 2009
Posts: 1,058

Rep: Reputation: 88
Do you try another command, rmmod, if modprobe -r didn't work?
 
Old 03-16-2012, 12:06 AM   #6
viveck
LQ Newbie
 
Registered: Mar 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
rmmod is also not working. can u tel me which particular file is responsible to mount the usb? or the exact communication when i attached a usb?
 
Old 03-16-2012, 03:25 PM   #7
nini09
Senior Member
 
Registered: Apr 2009
Posts: 1,058

Rep: Reputation: 88
The module-init-tools packet include insmod, rmmod, modprobe and so on.
 
Old 03-19-2012, 03:10 PM   #8
nini09
Senior Member
 
Registered: Apr 2009
Posts: 1,058

Rep: Reputation: 88
The USB mount doesn't use special functionality in mount module. The util-linux package include mount tool.
 
Old 03-23-2012, 01:00 AM   #9
viveck
LQ Newbie
 
Registered: Mar 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
Thanks
 
Old 03-23-2012, 03:45 AM   #10
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,718

Rep: Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904
Easy way- go into your BIOS, turn off all the USB ports, reboot. Finished.

*edit- dont turn off the USB keyobard/mouse ports if you are using USB input devices.
 
Old 04-15-2012, 05:29 AM   #11
WizadNoNext
Member
 
Registered: Nov 2009
Posts: 126

Rep: Reputation: 9
You can try unbind driver from device. I think this better solution, then trying to remove driver. Just look in /sys/module/usb-storage/ for unbind file (in subdirectory) and echo device along bus number to unbind file (as root, sudo doesn't work!)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB port disable in Ubuntu 9.04 Kiwi89 Linux - Hardware 2 11-09-2011 07:07 AM
Disable USB port Himangshu Mandal Linux - Newbie 1 12-22-2010 03:00 PM
Disable USB drive only not port. skg.shiv Linux - Newbie 3 06-21-2010 02:46 AM
How to disable the USB port on a machine? resetreset Linux - Hardware 8 03-02-2010 01:06 PM
how to disable USB port visitnag Linux - Desktop 6 12-31-2008 02:28 PM


All times are GMT -5. The time now is 11:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration