LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices



Reply
 
Search this Thread
Old 05-13-2012, 04:14 PM   #1
tmerriam
Member
 
Registered: Dec 2008
Distribution: slackware
Posts: 50

Rep: Reputation: 16
tmpfs not being used?


One of my partitons is running out of space, I can't resize it right now, so I'm trying to mount one of the temp file directories on tmpfs.

Code:
/etc/fstab
...
/var/tmp/kdecache-user tmpfs tmpfs nodev,nosuid,size=512M 0 0
Reboot, and...

Code:
mount:
...
/var/tmp/kdecache-user on /tmpfs type tmpfs (rw,nodev,nosuid,size=512M)
Code:
df -h
...
Filesystem             Size Used Avail Mounted on
/var/tmp/kdecache-user 512M    0  512M /tmpfs
ls shows that there are files in /var/tmp/kdecache-user, so why isn't this working?
 
Old 05-13-2012, 04:19 PM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,653
Blog Entries: 2

Rep: Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095
To mount a directory to RAM should work like you want, but you have mixed up the order of the statements in your fstab, it should be
Code:
tmpfs /var/tmp/kdecache-user tmpfs nodev,nosuid,size=512M 0 0
 
Old 05-13-2012, 07:33 PM   #3
tmerriam
Member
 
Registered: Dec 2008
Distribution: slackware
Posts: 50

Original Poster
Rep: Reputation: 16
D'oh!

Ok, I fixed that part but it still doesn't work. I added the uid, gid, and mode options to the fstab entry, and set the permissions on the mount point, but KDE is just making another folder instead! I tried putting the mount point in /mnt and linking to it from /var/tmp, but I have the same issue. Any ideas as to how to trick KDE into using the tmpfs?
 
Old 05-15-2012, 08:51 PM   #4
tmerriam
Member
 
Registered: Dec 2008
Distribution: slackware
Posts: 50

Original Poster
Rep: Reputation: 16
I couldn't get just /var/tmp/kdecache into tmpfs, so I mounted on /var/tmp instead. Took off the uid, gid, and mode option from the mount entry, too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/etc/fstab "tmpfs /tmp tmpfs defaults 0 0" ramfs?! HOW? xcislav Linux - General 2 06-04-2011 04:03 AM
TmpFS ?? jdecoto Red Hat 2 12-10-2006 09:55 PM
tmpfs mnotgninnep Debian 6 03-06-2006 05:52 PM
tmpfs akuate Linux - General 9 08-15-2004 02:02 PM
tmpfs seazon Linux - General 1 09-07-2003 05:45 AM


All times are GMT -5. The time now is 06:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration