LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-26-2013, 09:58 AM   #1
rdx
Member
 
Registered: Apr 2007
Location: Dallas
Distribution: Slackware 11, 14.1 :: Slackware64 14.1
Posts: 109

Rep: Reputation: 22
X11 troubles, HP p7-1512 with Intel onboard grapics, HP LE1911 monitor


I have a new HP Pavilion p7-1512 computer and I just installed a 2nd drive for Slackware 14. I ran Xorg then tweeked the sync rates to match what the monitor manual specifies. When I run Xorg the screen goes black and when I <Cntl-alt-BS> it returns to cli mode. The log seems to have correct values. But when I run xinit the monitor says "going to sleep" and I lose touch with the system and I have to cycle power to get it back. All the hardware works together fine under the Win 8 OS shipped with the machine. I don't do Linux installs very often I last did a Slackware version 11 years ago so I forget how one time to the next. Can someone give me some guidance please?
 
Old 10-26-2013, 01:59 PM   #2
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,150

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
What happens if you don't "tweek" the sync rates, etc. (The X-server reads those from the EDID of the monitor.) In fact, what happens if you delete (or rename) your xorg.conf file and then start the X-server? (Current X-server implementations only need an xorg.conf file for very unusual drivers and/or monitors, and yours seems quite standard.)
 
Old 10-26-2013, 07:17 PM   #3
rdx
Member
 
Registered: Apr 2007
Location: Dallas
Distribution: Slackware 11, 14.1 :: Slackware64 14.1
Posts: 109

Original Poster
Rep: Reputation: 22
Okay, I took your advice and it seems to work a bit better but in the end the same thing happened. When I start xinit a screen comes on which first shows a HDD, then crossed wrenches or something then a couple other icons come on as the program progresses. With the xorg.conf I tweeked, the monitor went to sleep after the wrenches. Removing the xorg.conf causes more icons to appear before the monitor passes out. One immediate problem is that the monitor prefers a 1280x1024x60 resolution but xorg doesn't seem to like that. 24 bpp is also preferred as opposed to 32 bpp. Anyway, I'm not sure this solution is progress but thanks just the same.

I don't don't know if it's relevant but this is a quad-core 64-bit Intel processor.

Last edited by rdx; 10-26-2013 at 07:19 PM. Reason: add processor info
 
Old 10-28-2013, 01:25 PM   #4
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,150

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
From your description it seems to me that you're booting a KDE desktop manager. Perhaps a different desktop might work better, or - this is unlikely - a different login manager. (Um, I assume you're loading kdm with kde, but, if not, you could try that.)

Another thought: Try moving ~/.kde to, say, ~/.kde_old and rebooting. That should force KDE to regenerate you desktop settings. (You might also consider looking at /etc/kderc, and the default files that setup program references, to see if there is anything strange in them.)

Note: If you're doing all this from a terminal, and you haven't already done so, installing the "Midnight Commander" package (or, if you've used it, emacs) might make your life somewhat easier.
 
1 members found this post helpful.
Old 10-29-2013, 01:19 AM   #5
rdx
Member
 
Registered: Apr 2007
Location: Dallas
Distribution: Slackware 11, 14.1 :: Slackware64 14.1
Posts: 109

Original Poster
Rep: Reputation: 22
The problem is with KDE. Other window managers work but they have font glitches. Xinit alone works and brings up a screen I can work from. Thus the problems all appear to be software rather than hardware. Thanks.

The one remaining issue is that Xorg wants to use 24bpp and the monitor wants 32bpp. setting xorg.conf to 32bpp results in an error. Setting Xorg to 24bpp results is a screen which is generally right but has text hashed up and unreadable.

Last edited by rdx; 10-29-2013 at 04:20 AM.
 
Old 10-29-2013, 01:27 PM   #6
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,150

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Well, I don't know if I can offer much more advice. I only thought I have is that if you use the "Display and Monitor" item in the "Hardware" section of the "System Settings" application, those settings are restored when KDE starts. If you have incorrect values set there, they will override any xinit settings you make when KDE starts. (I use a dual monitor set system, and, if I detach one monitor but forget to change the KDE monitor settings, when I reboot I find things somewhat messed up.)

Also, when I boot KDE, the KDE boot screen is displayed on both screens until the boot is finished and the K in the box displayed. At that point, the left-most screen displays the final boot image, and the right screen is black. When you described your problem, I wondered if your system may, at some time, have been configured as a multiple monitor system, and those settings were somehow inherited by your current system. (That's part of why I suggested "grandfathering" ~/.kde and restarting de novo.) The newer KDE (the 4.11 series) is somewhat more intelligent about multiple monitors and desktops, but, still I thought it might be a (very remote) possibility.

So, my final thought is:
 
Old 11-15-2013, 07:42 AM   #7
rdx
Member
 
Registered: Apr 2007
Location: Dallas
Distribution: Slackware 11, 14.1 :: Slackware64 14.1
Posts: 109

Original Poster
Rep: Reputation: 22
Final solution to problem

After trying all sorts of configurations I decided to buy a graphics card so I picked up a GeForce 210 and deleted the xorg.conf file in /etc/X11. That solved all the problems. Apparently Xorg doesn't handle the Intel HD graphics.
 
  


Reply

Tags
hp, x11


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help Dual monitor setup -------[ATI pci-e and onboard Intel graphics HD2000/3000] venandane Red Hat 2 06-27-2012 10:43 AM
How to disable onboard intel graphic card on Toshiba M640 (Hybrid Intel/Nvidia) Marcelo Ruiz Linux - Laptop and Netbook 6 08-14-2010 09:59 AM
Problems for my Intel 82865G onboard display or monitor Netrookie Fedora 0 08-02-2010 01:30 AM
Configuring EVO onboard graphics for X11 gw1500se Mandriva 8 11-03-2008 07:16 AM
rc.gpm and X11 troubles chriscore Slackware 5 10-10-2004 06:56 AM


All times are GMT -5. The time now is 01:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration