LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-03-2007, 12:04 PM   #1
cspeter
LQ Newbie
 
Registered: Sep 2007
Posts: 3

Rep: Reputation: 0
where to specify fat32 AUTOmounting options in openSUSE


My problem is the default executable permission on all files with vfat and ntfs, in openSUSE 10.2. I hate it because it remains on normal files even after copying them to a unix partition, or making a tar archive, etc. I can switch off the executable flags by setting fmask=0133 in fstab for normal drives, but I cannot do the same with removable drives. Although a line like
UUID=09F2-8FB2 /media/WD\040Passport vfat umask=0022,fmask=0133 0 0
could be added, it produces other problems:
1. automounting does not seem to work after that, I have to mount the drive manually.
2. after creating a fixed /media/WD Passport directory, it will remain forever in "My Computer" even when not mounted.
3. I want to set fmask for *any* pendrive or removable hard drive with FAT32 or NTFS, not just for "09F2-8FB2".

Is there any better solution?
 
Old 09-03-2007, 01:06 PM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Coincidentally I just wrote the answer to this in another post. Have a look at this.
http://www.linuxquestions.org/questi...16&postcount=2
 
Old 09-04-2007, 07:11 AM   #3
cspeter
LQ Newbie
 
Registered: Sep 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Sorry, some corrections. In case of the mentioned workaround (mkdir /media/WD Passport + additional line in fstab), my WD Passport folder does not remain "forever" in My Computer. It disappears when I plug out the cable. However, manual mounting only works from command line. If I click the WD Passport folder to mount it, then a "Permissions denied" message appears.

Quote:
Originally Posted by stress_junkie View Post
Coincidentally I just wrote the answer to this in another post. Have a look at this.
http://www.linuxquestions.org/questi...16&postcount=2
Thanks for the answer, but this workaround does not seem to work in suse. I have the same "Permissions denied" message also if I set chmod 775 /media "/media/WD Passport" and chown root.users /media "/media/WD Passport", I can even add "user,gid=(100)" to the options it does not help. The other mentioned problems also remain.

I want the automatic mounting to be performed with the option I specify somewhere. I'm afraid this problem is unsolvable with fstab, because the program that automounts the removable drive does not really use it. I would just like to know what is this program. autofs or hal? Unfortunately, none of these programs appear to have a config file, where mount options could be specified...
 
Old 09-04-2007, 11:15 AM   #4
cspeter
LQ Newbie
 
Registered: Sep 2007
Posts: 3

Original Poster
Rep: Reputation: 0
It seems to be KDE/GNOME dependent. I found a /etc/opt/gnome/gconf/gconf.xml.schemas/schemas/system/storage/default_options/vfat/%gconf.xml file, I suppose the default mount options can be specified here in some way (no idea how exactly). But I use KDE. What is the corresponding file in KDE?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
automounting fat32 drive with correct permissions johannlo Linux - General 1 07-05-2005 08:37 PM
getting fat32 (Win98SE) part to mount with dmask and fmask options Simon Bridge Linux - General 3 06-22-2005 01:50 AM
External harddrive FAT32- VFAT options (uppercase to lowercase file name translation) pauquetb Linux - General 1 03-20-2004 12:52 PM
automounting options in Slackware 9.1 ZidanaX Slackware 2 03-07-2004 07:36 PM
2 fat32 partitions on fbsd5/w2k dual. Can only access one fat32 so far.. mipia *BSD 1 10-06-2003 02:10 AM


All times are GMT -5. The time now is 07:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration