LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 06-18-2009, 12:58 PM   #1
David Marks
LQ Newbie
 
Registered: Jun 2009
Posts: 5

Rep: Reputation: 0
Removing external drive causes boot failure: fsck.ext3: unable to resolve...


I am using an external SATA drive bay that allows for removing and swapping drives.

I'm not doing anything fancy with it... no hot swapping. However, I don't always want the drive present. If I turn off the external unit or remove the disk, when I attempt to boot up Fedora, the filesystem checker reports errors and does not let me boot up.

Code:
Checking filesystems
fsck.ext3: Unable to resolve 'UUID=08b7...'
... the system will automatically reboot.
On a successful boot, with the external drive present, I assume that SMART or FSCK has somewhere recorded the drive's UUID, and now expects the drive to always be there.

I'll be swapping a number of different drives in and out of this bay, so there is no guarantee what UUIDs will be there the next time I reboot.

Is there something I'm missing to tell the operating system that a device is removable?

Regards,
David Marks


Fedora 7 x86
Fedora 7 x86-64
Fedora 9 x86-64
Dell XPS 720
3Ware 9650SE-4LPME RAID controller with Sidecar
 
Old 06-18-2009, 01:16 PM   #2
noctilucent
Member
 
Registered: Jun 2009
Distribution: slackware
Posts: 123

Rep: Reputation: 25
What does /etc/fstab look like?
 
Old 06-18-2009, 02:07 PM   #3
David Marks
LQ Newbie
 
Registered: Jun 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Hah! You pointed me to my own dumb mistake.

It looks like I left some old mounting info in my fstab file. I deleted the two offending lines, shut down the system, removed the external drive, and rebooted without issue.

I can probably add some mount commands to a login script instead. At least there I would get errors intstead of a complete boot failure.

Thanks for the prompt help (and please forgive the newbie error!)
 
Old 06-18-2009, 02:42 PM   #4
bwayson
LQ Newbie
 
Registered: Nov 2006
Location: Ventura California USA
Distribution: openSUSE
Posts: 23

Rep: Reputation: 3
Just so you know, you can find all the UUIDs of attached disks under /dev/disk/by-uuid/. You may also be able to leave the lines for detached disks in your fstab file by giving them the options "noauto,user" (don't mount automagically, and allow mere mortals to mount) and making sure the two numbers at the end are both zeroes (which will disable any fsck-ing at boot time). That is, you should be able to do this unless the disks contain parts of the filesystem required for booting and running.
 
Old 06-19-2009, 12:42 AM   #5
David Marks
LQ Newbie
 
Registered: Jun 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bwayson View Post
Just so you know, you can find all the UUIDs of attached disks under /dev/disk/by-uuid/. You may also be able to leave the lines for detached disks in your fstab file by giving them the options "noauto,user" (don't mount automagically, and allow mere mortals to mount) and making sure the two numbers at the end are both zeroes (which will disable any fsck-ing at boot time).
Excellent! This is new to me!

So, if the drives aren't mounted automatically, what causes them to mount? Would I need to run 'mount -a'? Or does simply logging in trigger this?

I'm off to read more about fstab. Thanks for the hints.
 
Old 06-23-2009, 09:55 AM   #6
bwayson
LQ Newbie
 
Registered: Nov 2006
Location: Ventura California USA
Distribution: openSUSE
Posts: 23

Rep: Reputation: 3
I doubt you would be required to use the command line to mount them, though you could. "mount -a" won't work since the -a flag only mounts partitions not having the "noauto" option. Try, as root, "mount <mountpoint>" (e.g. mount /windows/D). I am not familiar with Fedora, but given that it uses Gnome as the user interface, you may see drive icons on the desktop representing all the 'noauto' (or 'user'?) partition; under the Places menu of the top menu bar; and in the Places panel of the Nautilus file browser. I believe that you'd just double-click any of these icons -- there is no need to become rooot -- to mount and browse the partitions.
 
Old 06-23-2009, 10:14 AM   #7
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
gnome has a "disk mounter" applet you can add to the panel, I usually put it up near the clock. then you can simply click on the drive icon and select Mount or Unmount.

I'm sure KDE has something similar.
 
  


Reply

Tags
external, fedora, fsckext3, sata


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fsck.ext3: unable to resolve 'LABEL=/' av.dubey Linux - Newbie 5 04-28-2010 05:23 AM
External USB Drive Ext3 Fsck Error on Boot macgyver007 Linux - Desktop 8 08-22-2009 12:02 AM
fsck.ext3: Unable to resolve 'LABEL= pm02368 Linux - Newbie 4 09-12-2006 07:15 PM
Getting Error "fsck.ext3 Unable to resolve 'LABEL=boot'" during Booting... salil.mehta Fedora 3 08-21-2006 08:39 AM
fsck.ext3 unable to resolve 'LABEL=/home yeehi Linux - General 2 10-20-2004 08:15 AM


All times are GMT -5. The time now is 10:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration