LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-01-2004, 09:49 AM   #1
ElPuello
Member
 
Registered: Apr 2004
Location: Copenhagen, Denmark
Distribution: Gentoo + Debian PPC
Posts: 44

Rep: Reputation: 15
Problems formatting NTFS partition


Hi,

I'm trying to convert my NTFS partition to ext3. However I'm having some problems doing so. I use fdisk to delete the old partition, create a new one in its stead, make it Linux(83) and write the partition table. Should be a cakewalk right? Well, when i reboot the machine and mount the partition, it won't accept ext3, it wants to be mounted as NTFS! Furthermore, all data is still on it. Really weird, because when I enter windooze(yes, I dual boot, and I'm ashamed ), it cant see the partition!

Here my partition table using fdisk:

Device Boot Start End Blocks Id System
/dev/hda1 * 1 2550 20482843+ 7 HPFS/NTFS
/dev/hda2 2551 16770 114222150 f W95 Ext'd (LBA)
/dev/hda3 16771 18620 14860125 83 Linux
/dev/hda4 18621 19928 10506510 83 Linux
/dev/hda5 2551 16708 113724103+ 7 HPFS/NTFS
/dev/hda6 16709 16770 497983+ 82 Linux swap


And when writing the partition table I get some strange message:


The partition table has been altered!

Calling ioctl() to re-read partition table.

WARNING: Re-reading the partition table failed with error 16: Device or resource busy.
The kernel still uses the old table.
The new table will be used at the next reboot.
Syncing disks.


Perhaps this has something to do with it??

Please help!
 
Old 11-01-2004, 10:10 AM   #2
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
Did you reformat the partition? Unmount it first then

mkfs.ext3 /dev/hda(you didn't say which partition it is)
 
Old 11-01-2004, 10:12 AM   #3
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
I am not an expert on this issue, but could it be that you need to create the filesystem first (like formating the partition)?

I think what you have done using fdisk has just changed the filesystem flag in your partition table, but the structure is still NTFS. You may need to run mkfs.ext3 to create the new filesystem.

You also need to unmount the partition first. That may has caused the "Device or resource busy" message.
 
Old 11-01-2004, 10:45 AM   #4
ElPuello
Member
 
Registered: Apr 2004
Location: Copenhagen, Denmark
Distribution: Gentoo + Debian PPC
Posts: 44

Original Poster
Rep: Reputation: 15
Thanks ppl, I just didn't know how to build the file system, but now it's cool!

Thx alot
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems Mount Ntfs Partition David2004 Red Hat 10 09-07-2006 10:48 PM
problems mounting ntfs partition wisdom Linux - Software 3 11-11-2005 04:48 AM
Formatting an NTFS partition under FC4? KiLLaWaBBiT Linux - Software 4 07-01-2005 06:45 PM
Problems formatting partition w/ FAT32!! KyngNothing Linux - Newbie 2 12-07-2003 10:26 PM
Problems viewing ntfs partition as user. voyta Linux - Newbie 3 10-28-2003 12:30 PM


All times are GMT -5. The time now is 12:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration