LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 11-05-2003, 07:04 AM   #1
nekromancer
Newbie
 
Registered: Nov 2003
Location: Niagara Falls, Canada
Distribution: Gentoo
Posts: 10

Rep: Reputation: 0
odd sound device settings in Gentoo 1.4


Hi,

I'm running Gentoo Linux 1.4, with AC97 sound devices and ATI-TV-Card
I listed them below..

Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 2).
IRQ 10.
Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 2).
IRQ 10.
Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio Controller (rev 80).
IRQ 11.

For some reason...

TV-Card is using /dev/sound/dsp /dev/sound/mixer
AC97 is using /dev/sound/dsp2 and /dev/sound/mixer2

Most programs can compensate for this when you specify which device to use.. but some don't. I am using KDE and OSS (open sound system).

I basically want to make my my AC97 sound device use /dev/sound/dsp
and my TV-card use some other one.

(previoulsy when I ran Debian, it all worked on /dev/dsp)

Anyone got any ideas on how to make /dev/sound/dsp my default sound device?

Thanks
 
Old 11-05-2003, 10:56 AM   #2
nekromancer
Newbie
 
Registered: Nov 2003
Location: Niagara Falls, Canada
Distribution: Gentoo
Posts: 10

Original Poster
Rep: Reputation: 0
Unhappy

Well since it was taking forever to get ANY reply.... I spent that time trying to solve the problem on my own and was successful

Exit out of X, go into Root.

ran $genkernel --config
and removed the bt878audio module
then let genkernel compile it and everything
Run LILO and modules-update to finalize it

reboot and linux is using /dev/sound/dsp as default and not dsp2

So if anyone on gentoo had the same problem as me.. there you go.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alsa compiling issues involving odd Gentoo dependancies, please help MattJT Linux - Software 0 12-28-2004 06:22 PM
Storing sound settings for the secondary audio device? Livino Linux - Newbie 17 12-02-2004 06:12 PM
Storing sound settings for the secondary audio device? Livino Linux - Hardware 1 11-24-2004 07:07 PM
Odd hd device in fstab... can I delete it? phlyersphan Linux - Hardware 6 07-11-2004 01:16 AM
Odd sound problem SeoushiSan Linux - General 2 12-04-2003 03:42 PM


All times are GMT -5. The time now is 11:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration