LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-14-2007, 01:47 PM   #1
redarrow
Member
 
Registered: Jul 2005
Location: South Africa
Distribution: Fedora Core
Posts: 32

Rep: Reputation: 15
Nvidia driver not working properlly when resuming S3 suspend.


Hello,

I just installed Fedora Core 6 on my system and the latest Nvidia driver (1.0-9631)..

Before installing the Nvidia driver, the S3 suspend function worked perfectly... after in stalling the driver it no longer resumes correctly.. the screen remains blank and nothing I do will wake it.. I tried switching to a terminal with Ctrl+Alt+F5.. nothing just blank..
The only thing I can do is reboot the machine..

Anyone have any ideas how I could work around this problem?

Thanks
 
Old 01-14-2007, 03:03 PM   #2
poweredbydodge
Member
 
Registered: Oct 2006
Location: Buffalo, NY
Distribution: Servers: Scientific Linux 5.x // Desktops: Fedora Core (latest)
Posts: 110

Rep: Reputation: 15
hey there - ran into similar junk when setting up my HTPC. Eventually I went back to FC5 for many reasons, but the short answer to what I believe you need is:

-- the beta driver 9742.

NVIDIA-Linux-x86-1.0-9742-beta-pkg1.run is what i have it named as.

You should be able to google it.

This driver worked for me, without a hitch, getting rid of the 'random blank screen' that I experienced with the previous driver(s).
 
Old 01-15-2007, 09:08 AM   #3
redarrow
Member
 
Registered: Jul 2005
Location: South Africa
Distribution: Fedora Core
Posts: 32

Original Poster
Rep: Reputation: 15
Thanks for the reply poweredbydodge!

Unfortunately the latest set of drivers no longer seem to support my outdated Geforce 4 MX440..

But I found a solution on the Nvidia forums..

Basically I just had to:

Boot the kernel with agp=off

and edit /etc/pm/functions-nvidia, just commenting out "/usr/sbin/vbetool post" in resume_video() like:

Code:
resume_video()
{
(
        ### /usr/sbin/vbetool post
        /usr/sbin/vbetool dpms on
        /usr/sbin/vbetool vbestate restore < /var/run/vbestate
) >/dev/null 2>&1
}
It's working now!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lock screen (requiring password to unlock) when resuming from suspend theoldman Linux - Laptop and Netbook 2 12-17-2009 09:35 PM
monitor does not turn on after resuming from suspend nappaji Puppy 2 08-24-2006 08:19 PM
cant suspend to disk with nvidia driver loaded qwijibow Linux - General 13 01-12-2005 02:45 PM
Software Suspend - freezes while resuming TazG Linux - Software 2 08-11-2004 10:19 AM
How to Add Password for Resuming from Suspend (Using apmsleep) Ian Linux - Hardware 0 05-03-2004 10:34 PM


All times are GMT -5. The time now is 08:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration