LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-20-2003, 04:44 AM   #1
forrestkoch
LQ Newbie
 
Registered: Sep 2003
Posts: 1

Rep: Reputation: 0
Unhappy need help with lexmark x73 usb scanner in redhat 9 using xsane


I am using redhat 9.0, the printer/scanner combo is called a lexmark x73. The printer is now currently working fine. The scanner is not however. I recently installed the latest sane backend which contained the gt68xx driver which supposably supports the x73 flatbed scanner. When I type $sane-find-scanner :
# No SCSI scanners found. If you expected something different, make sure that
# you have loaded a SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x043d, product=0x002d) at /dev/usb/scanner0
found USB scanner (vendor=0x043d, product=0x002d) at libusb:001:004
found USB scanner (vendor=0x0545, product=0x810a) at libusb:001:003
# Your USB scanner was (probably) detected. It may or may not be supported by
# SANE. Try scanimage -L and read the backend's manpage.

# Scanners connected to the parallel port or other proprietary ports can't be
# detected by this program.

# You may want to run this program as root to find all devices. Once you
# found the scanner devices, be sure to adjust access permissions as
# necessary.

typing scanimage -L produces:
device `gt68xx:/dev/usb/scanner0' is a Lexmark X73 flatbed scanner

when i type scanimage the scanner does a complete scan, however i have no idea where that image goes. xsane does not recognize the scanner even though scanimage does. typing xsane gt68xx:/dev/usb/scanner0 does not work. I"m at a loss could someone please help.

thanks Forrest Koch
wannabe unix geek
 
Old 09-20-2003, 11:53 AM   #2
linksocc
Member
 
Registered: Jul 2003
Location: US
Distribution: Mandrake 9.0 1st/9.1 2nd/Gentoo 1.4 now
Posts: 313

Rep: Reputation: 30
I had the same problem until I just copied this c:/windows/OSLO3071b2.usb from my windows partition and put it in /usr/local/share/sane/gt68xx/ and start the scanner module with

rmmod scanner; modprobe scanner vendor=0x55f product=0x21c

then open Xsane and you are ready to go
If you need the file just mail me and I'll send it to you.
 
Old 03-31-2004, 09:21 AM   #3
strestout1
LQ Newbie
 
Registered: Oct 2003
Posts: 17

Rep: Reputation: 0
i guess i never looked properly...ive been trying to get my scanner to work since forever! thanx!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lexmark X73 printer problem on Fedora Core 2 skippy1283 Linux - Hardware 1 04-05-2005 08:08 AM
Lexmark X73 and libusb cent20 Linux - Hardware 3 03-18-2005 11:13 AM
Lexmark X73 Firmware Jajamd Linux - Hardware 0 08-27-2004 01:19 PM
sane/xsane can't find usb scanner walterbyrd Linux - Hardware 0 07-24-2004 10:39 AM
Problems networking lexmark X73 blacksoul Linux - Hardware 0 09-09-2003 10:19 PM


All times are GMT -5. The time now is 07:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration