LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-31-2005, 12:10 PM   #1
t0k3n808
LQ Newbie
 
Registered: Aug 2005
Location: Hawaii
Posts: 10

Rep: Reputation: 0
Question MSI TV@nywhere


I'm running Mandriva LE 2005 x86_64 on a AMD Athlon64, GIGABYTE nForce4 Ultra Mobo, GeForce 6600FX 256MB, 1GB RAM, with a PCI MSI TV@nywhere card.

When I run tvtime i get this error:

Running tvtime 0.9.15.
rtctimer: Cannot set periodic interval: Inappropriate ioctl for device
rtctimer: Cannot set periodic interval: Inappropriate ioctl for device
Reading configuration from /etc/tvtime/tvtime.xml
Reading configuration from /home/t0k3n/.tvtime/tvtime.xml
videoinput: Cannot open capture device /dev/video0: No such device


I've also tried xawtv and I get this error:

This is xawtv-3.94, running on Linux/x86_64 (2.6.11-6mdksmp)
can't open /dev/video0: No such device
v4l-conf had some trouble, trying to continue anyway
v4l2: open /dev/video0: No such device
v4l2: open /dev/video0: No such device
v4l: open /dev/video0: No such device
no video grabber device available

I can get kdetv running but its not detecting my tv card. When I go into harddrake it detects correctly...I think. This is what it says:

Identification
Vendor: ‎Hauppauge
Description: ‎WinTV PCI card (88x chip based)
Media class: ‎MULTIMEDIA_VIDEO
Connection
Bus: ‎PCI
Bus PCI #: ‎1
PCI device #: ‎7
PCI function #: ‎0
Vendor ID: ‎5361
Device ID: ‎34816
Sub vendor ID: ‎65535
Sub device ID: ‎65535
Misc
Module: ‎cx8800

I followed instructions from another forum post that allowed me to create a /dev/video0 file from the terminal but that still didn't work. I tried modprobe bttv but that didn't help. When I run Modprobe cx8800 I get this "FATAL: Module cx8800 not found." Can someone help me out?
 
Old 08-31-2005, 06:17 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,378

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
the driver is "cx88" not "cx8800" http://linux.bytesex.org/v4l2/cx88.html
 
Old 08-31-2005, 11:31 PM   #3
t0k3n808
LQ Newbie
 
Registered: Aug 2005
Location: Hawaii
Posts: 10

Original Poster
Rep: Reputation: 0
I ran modprobe cx88 but I got this error:

FATAL: Module cx88 not found.

What exactly does modprobe do? I think I read somewhere that its the command that install the driver but I'm not sure. Do I need to download a new driver? Thanks for the help...
 
Old 09-01-2005, 05:16 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,378

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
yeah, modprobe basically loads the driver. it should be sitting in /lib/modules/2.X.Y/ somewhere... the driver has been included in the stock kernels for a little while now i thought, your distro shouldn't have any problems... run "find /lib/modules/2.x.y | grep cx" to see if it is there or not. if it's not then i guess you'd need to either recompile your kernel or install the single drvier itself. seems very odd that it's not there though. Can't think of a good reason to have it bult into the kernel... Mandrake do do odd things though...
 
Old 09-01-2005, 12:24 PM   #5
t0k3n808
LQ Newbie
 
Registered: Aug 2005
Location: Hawaii
Posts: 10

Original Poster
Rep: Reputation: 0
I'm not sure if it makes any difference but I installed from the x86_64 1 CD version. I've seen that there is a 3 CD verison and DVD version. But no one ever mentions the 1 CD version. I assume the 1CD verison comes with the least amout of software but I would have thought the kernels were the same. Anyway, when I run "find /lib/modules/2.6.11-6mdksmp | grep cx" this is what comes back.

/lib/modules/2.6.11-6mdksmp/kernel/3rdparty/snd2/pci/pcxhr
/lib/modules/2.6.11-6mdksmp/kernel/3rdparty/snd2/pci/pcxhr/snd-pcxhr.ko.gz
/lib/modules/2.6.11-6mdksmp/kernel/drivers/media/dvb/frontends/cx22700.ko.gz
/lib/modules/2.6.11-6mdksmp/kernel/drivers/media/dvb/frontends/cx22702.ko.gz
/lib/modules/2.6.11-6mdksmp/kernel/drivers/media/dvb/frontends/cx24110.ko.gz
/lib/modules/2.6.11-6mdksmp/kernel/drivers/media/video/btcx-risc.ko.gz
/lib/modules/2.6.11-6mdksmp/kernel/drivers/net/chelsio/cxgb.ko.gz
/lib/modules/2.6.11-6mdksmp/kernel/drivers/net/wan/cycx_drv.ko.gz
/lib/modules/2.6.11-6mdksmp/kernel/sound/oss/via82cxxx_audio.ko.gz

Since I don't see cx88 I guess that means the driver isn't installed. I saw that you posted a link in your first reply...I'll try that driver. But I haven't installed a driver in linux before so this should be interesting. Is there a 32-bit and 64-bit driver or are they all the same? Any info would be helpful. Thanks again...
 
Old 09-01-2005, 02:57 PM   #6
t0k3n808
LQ Newbie
 
Registered: Aug 2005
Location: Hawaii
Posts: 10

Original Poster
Rep: Reputation: 0
I can't even get the driver installed. I'm using http://icculus.org/~jcspray/wintv_cx88.html as the tutorial but I'm getting an error when trying to make the *.ko files. When I run the make command i get this error:

[t0k3n@Linux64 cx88-0.0.4]$ make
make -C /lib/modules/2.6.11-6mdksmp/build SUBDIRS=/home/t0k3n/cx88-0.0.4 modules
make: *** /lib/modules/2.6.11-6mdksmp/build: No such file or directory. Stop.
make: *** [default] Error 2

I tried running the command as root too but that didn't work. I'm really not sure what else to do. Can someone point in the right direction for installing the cx88 driver?
 
Old 09-02-2005, 10:55 PM   #7
t0k3n808
LQ Newbie
 
Registered: Aug 2005
Location: Hawaii
Posts: 10

Original Poster
Rep: Reputation: 0
I upgraded to Mandriva 2006 LE Beta but it still doesn't work. Can someone please help me out?
 
Old 09-03-2005, 12:14 AM   #8
t0k3n808
LQ Newbie
 
Registered: Aug 2005
Location: Hawaii
Posts: 10

Original Poster
Rep: Reputation: 0
I upgraded to Mandriva 2006 LE Beta but it still doesn't work. Can someone please help me out?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with tvtime and TV@nywhere Master doublea Linux - Newbie 3 03-29-2005 11:57 AM
MSI TV @nywhere kemplej Suse/Novell 0 10-19-2004 08:05 PM
a TV Tuner Card : Master TV@nywhere , HELP!! HeRCuLeSX Linux - Hardware 10 11-22-2003 10:46 AM
MSI TV@nywhere DrOzz Linux - Hardware 3 07-21-2003 05:45 PM
Msi Cr48-a2 danile3784 Linux - Hardware 0 04-04-2003 07:58 AM


All times are GMT -5. The time now is 03:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration