LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-21-2006, 08:28 PM   #46
sonicbhoc
Member
 
Registered: Aug 2006
Distribution: Gentoo
Posts: 61

Rep: Reputation: 15

I've been ripping my hair out trying to figure this crap out.

Someone help... I have a Compaq Easy Access Keyboard (8 key), running under PCLinuxOS.

I have xorg-x11 6.8.

uname -a prints:
2.6.16.27.tex1.lve #1 Mon Jul 31 15:59:12 WST 2006 i686 Pentium III (Coppermine) unknown GNU/Linux

in KDE, I set the keyboard option to my keyboard.

In xorg.conf, I have the proper keyboard layout (compaqeak8).

I can't get khotkeys working. I type it in and nothing happens.

I did, however, set up lineakd (Linux Easy Access Keys Daemon) with the proper options. However, the keycodes are all over 127 in the defs file.

I have the same setkeycodes issue that everyone else had (out of range, it only goes up to 127, etc)

I've been doing this forever and I can't get it. I have every other piece of hardware working nearly perfectly (DRI included). Once this is done, I can get this PC shipped out to my pastor. In other words, the sooner the better!
 
Old 08-28-2006, 11:23 PM   #47
amd_master
LQ Newbie
 
Registered: Aug 2006
Location: Australia
Distribution: Suse 10.1
Posts: 7

Rep: Reputation: 0
Howdy,
Bit of a noob at linux but am really enjoying it. With the help of this forum ive been able to get all my media buttons working except the usual 5 buttons (SMS,Itouch...etc). I did manage to get those buttons working (sort of) by following "lobocobra" guide on pg 2. By sort of i mean that i went into konsole became a super user and typed in "setkeycodes e011 112" ...etc for all 5 of them.
I then went into xev to get the keycodes for each button and then modified .Xmodmap to correspond the keycodes given with the "XF86messenger"
eg.
keycode 239 = XF86Messenger
keycode 222 = XF86WebCam
keycode 139 = XF86iTouch
keycode 123 = XF86Shop

Once i changed the keycodes to the right ones(as above) and then logged out and logged back in again thse keys could now be binded with khotkeys. It all worked great until...i rebooted. Now those buttons dont have keycodes when i chek with xev. It works fine (again) if i go into konsole->become a su-> type in that
"setkeycodes e011 127"...etc AGAIN! I dont have to do anything else after doin the setkeycode thing, which tells me that it has to be done every time i reboot (not log in) Which is fine as ill just setup a shortcut(or several) in ~.kde/autostart like i did with .Xmodmap. Problem is that u have to be super user to do that "setkeycodes...thing. Can any1 tell me if theres a place where i can put the shortcuts so that they are already in Super User mode, and so that i dont have to envoke them every time i restart. Or what i can do to make it automated.
I am running opensuse 10.1 with kde and Logitech Elite Keyboard (corded PS/2)
thanks in advance (suks to be a noob)
 
Old 08-29-2006, 11:33 PM   #48
sonicbhoc
Member
 
Registered: Aug 2006
Distribution: Gentoo
Posts: 61

Rep: Reputation: 15
There should be a file called "rc.local" or "local.start" or something along those lines in your /etc directory somewhere... I don't recall what it's called in SuSE, but that's where you would add the setkeycodes lines. and you can add other stuff in there too. Also I skipped the .Xmodmap step, I figured I was forgetting something <_<

I have to go see if I can get the keys working if I add the Xmodmap stuff.
 
Old 08-30-2006, 05:41 AM   #49
amd_master
LQ Newbie
 
Registered: Aug 2006
Location: Australia
Distribution: Suse 10.1
Posts: 7

Rep: Reputation: 0
sonnicbhoc,
yeah i sort of figured that out myself its not in the guide, but if you have a logitech elite PS/2 those "setkeycode"...things should work for you just type them all in (as su) run xev and the keycodes should be the same as the ones i have above then change .Xmodmap accordingly (make sure you have
"xmodmap ~/.Xmodmap" (as a shortcut) in your ~.kde/autostart) and log out and log in, then go xev to chek then do khotkeys. But just beware that if you reboot it wipes thos "setkeycode...thingy, but .Xmodmap and khotkeys will stay. Ill have a look at what you sed with etc/
 
Old 08-30-2006, 06:27 AM   #50
amd_master
LQ Newbie
 
Registered: Aug 2006
Location: Australia
Distribution: Suse 10.1
Posts: 7

Rep: Reputation: 0
HHHHHHEEEEEEEEEEELLLLLLLLLLLLLLLL YEAH!!!!!!!!!!!
5 other buttons work now.
For suse users read previous posts then go to
/etc/init.d/boot.local
Open with kwrite or kedit or whateva

add this to end
#For the messenger key
setkeycodes e011 112
# For the webcam key
setkeycodes e012 116
# For the shopping key
setkeycodes e014 118
# For the itouch key
setkeycodes e013 120
# For pushLeftWheel
setkeycodes e016 127

and save (will have to get permission)
Reboot=>Check with xev(to c if yor gettin keycodes)=>bind with khotkeys( or keyboard shortcuts)

HAve fun :-p
 
Old 08-30-2006, 06:32 AM   #51
amd_master
LQ Newbie
 
Registered: Aug 2006
Location: Australia
Distribution: Suse 10.1
Posts: 7

Rep: Reputation: 0
Success!
For Suse 10.1 KDE

Last edited by amd_master; 08-30-2006 at 06:33 AM.
 
Old 08-30-2006, 07:01 AM   #52
amd_master
LQ Newbie
 
Registered: Aug 2006
Location: Australia
Distribution: Suse 10.1
Posts: 7

Rep: Reputation: 0
Now i just need to no how to activate those bloody F-lock keys (new,reply,forward,send...etc)
I think i sort of have an idea.
Im not sure but "lobocobra" says that if i press all those buttons then go into /var/log/messages it should give me some jargon that i can then work with but ive been into it and it says bugger all to me. Can any1 tell me any other file that mite log stuff like unknown keys so i can use "setkeycodes"
I just checked again and that file doesnt log it (in between the times i checked there was nothing there)
 
Old 08-31-2006, 06:34 PM   #53
sonicbhoc
Member
 
Registered: Aug 2006
Distribution: Gentoo
Posts: 61

Rep: Reputation: 15
My keycodes got skewered when I set them, they jumped to 233 and stuff like that when I set them as onehundred something...

Anyway, I'm setting up my .Xmodmap file now. I hope this works...

I could never get khotkeys working, when I type "khotkeys" and press enter, nothing happens <_<

EDIT: I'm putting the line "xmodmap ~/.Xmodmap" in my ~/.xsession file instead, as per the instructions of the Gentoo how-to, but I'm pretty sure it doesn't matter which one I put it in. But, I know that X loads before KDE so I think it'd be a better idea to put xmodmap in to be started along with X instead of after it. Let's reboot and see if this thing works.

EDIT 2: that's weird, I have "xmodmap ~/.Xmodmap" in both xsession AND kde autostart, and it doesn't work. I have to type it in on the console manually! I wonder why?

Last edited by sonicbhoc; 08-31-2006 at 07:17 PM.
 
Old 09-01-2006, 02:46 AM   #54
amd_master
LQ Newbie
 
Registered: Aug 2006
Location: Australia
Distribution: Suse 10.1
Posts: 7

Rep: Reputation: 0
go to kmenu->Control Center->Regional And Accessablity-> Keyboard Shortcuts.
And i tried putting "xmodmap ~/.Xmodmap" in /etc/init.d/boot.local which is where i put those "keycodes...thingys" they work fine but xmodmap doesnt so i had to to put a shortcut back in ~.kde/autostart and worked fine. Im not sure if i have done it traditionally/efficient way but i just go into ~.kde/autostart with konkeror right click and choose create shorcut to application and then right click ion the shortcut i just created and go into properties click on the application tab and where it says command i type "xmodmap ~/.Xmodmap" and then go to permissions tab and tick "Item is executable" then press OK. When i start KDE an icon flashes for about 10s but the all buttons work straight away. Like i sed im a noob to linux so thats the way i figured to do it and it works so itl have to do. By the way i think that "xmodmap ~/.Xmodmap" is case sensitive so it has to be written exactly the same way the the file in ~
By the way i had to take "xmodmap ~/.Xmodmap" out of /etc/init.d/boot.local for xmodmap to work properly.
Also do you know where theres a log file for the kernel that would log unrecognised keys?

Also it doesnt matter what the keycodes are as long as there is no duplicates, you just have to make sure ~/.Xmodmap has the same key code assigned to the right action

eg in xev i get this when i press GO ( on the left hand side under scroll)

KeyPress event, serial 32, synthetic NO, window 0x3600001,
root 0x119, subw 0x0, time 32736698, (302,655), root1012,684),
state 0x10, keycode 233 (keysym 0x1008ff5f, XF86Go), same_screen YES,
XLookupString gives 0 bytes:
XmbLookupString gives 0 bytes:
XFilterEvent returns: False

KeyRelease event, serial 32, synthetic NO, window 0x3600001,
root 0x119, subw 0x0, time 32736949, (302,655), root1012,684),
state 0x10, keycode 233 (keysym 0x1008ff5f, XF86Go), same_screen YES,
XLookupString gives 0 bytes:

This is my ~.Xmodmap contents

keycode 144 = XF86AudioPrev
keycode 239 = XF86Messenger
keycode 222 = XF86WebCam
keycode 139 = XF86iTouch
keycode 123 = XF86Shop
keycode 153 = XF86AudioNext
keycode 160 = XF86AudioMute
keycode 162 = XF86AudioPlay
keycode 164 = XF86AudioStop
keycode 174 = XF86AudioLowerVolume
keycode 176 = XF86AudioRaiseVolume
keycode 178 = XF86HomePage
keycode 223 = XF86Standby
keycode 229 = XF86Search
keycode 230 = XF86Favorites
keycode 236 = XF86Mail
keycode 237 = XF86AudioMedia
keycode 233 = XF86Go
keycode 234 = XF86Back

Hope this helps :-)

Last edited by amd_master; 09-01-2006 at 07:29 AM.
 
Old 09-23-2006, 01:10 AM   #55
amd_master
LQ Newbie
 
Registered: Aug 2006
Location: Australia
Distribution: Suse 10.1
Posts: 7

Rep: Reputation: 0
Just lettin every1 no that i have been able to get all f-lock keys workin (My com, My doc, ...etc if you need to know post a reply.

For suse 10.1 kde 3.5.1 Logitech Elite Corded using ps/2

Last edited by amd_master; 09-23-2006 at 01:13 AM.
 
Old 09-23-2006, 05:45 AM   #56
BruceCadieux
Member
 
Registered: Apr 2002
Location: Wales MA.
Distribution: openSuSE 11.1
Posts: 409

Rep: Reputation: 32
Save your selves many headaches, and download keytouch It has very nice GUI to assign your keys functions, I am using it with a Logitech navigator, and all my keys function including the flock keys, messenger shopping..........every single one works after installing it. No messing about in editing files by hand. http://keytouch.sourceforge.net/

Here is a list of supported keyboards. http://keytouch.sourceforge.net/dl-keyboards.php

Last edited by BruceCadieux; 09-23-2006 at 05:47 AM.
 
Old 04-03-2008, 04:27 PM   #58
sleeplikewolves
LQ Newbie
 
Registered: Apr 2008
Posts: 1

Rep: Reputation: 0
Red face

I was given this keyboard (not the chordless one), without an instalation cd or anything. I could manage to install the drivers but every time i turn the computer off and back on, the f keys work but i can't type. Can anyone help with this problem?
 
Old 04-03-2008, 10:40 PM   #59
annekaelber
Member
 
Registered: Sep 2003
Location: Mesa, AZ
Distribution: Slackware
Posts: 49

Rep: Reputation: 15
Question What might cause the keycodes to CHANGE????

Greetings!

I've been struggling with an odd issue all this week. I'm running Slack 11 with a 2.6.21.5 kernel. My keyboard is the USB Logitech Cordless Elite Duo (the one with the receiver that charges the mouse). I've been trucking along just fine, using my media keys all over the place and quite happy. Then, sometime Saturday, something changed. After fiddling around a little, it appears the keycodes themselves have changed! I say this because I ran xev and the codes don't match the ones in my file which had been working perfectly. Most notably: my mute button now acts like my F-Lock button, most of my fwd/bkwd/play/pause/stop/vol keys either don't have a keycode or give the same code as another button in that grouping!

During testing, I removed my mouse (Logitech Trackman Wheel with cord) and keyboard from my KVM switch and plugged them into various different USB ports. This same keyboard is acting a little odd on my Windows computer as well.

Does anyone have any suggestions on how to get back to the original keycodes? I've tried re-connecting (random guess, no real reason to think it would work) to the receiver---no change.

Stumped on this one...

Anne.
 
  


Reply

Tags
access, compaq, config, elite, keyboard, keymapping, logitech, multimedia, xev, xmodmap, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
logitech elite duo keyboard prints a 'q' when hitting backspace telesto Linux - Hardware 20 08-18-2004 11:50 PM
logitech elite keyboard and keybindings wgodois Linux - Hardware 0 05-22-2004 03:32 PM
Logitech Elite Keyboard - Special buttons under linux nybble Linux - Hardware 2 01-06-2004 10:10 PM
Logitech Elite Duo help d0nny Linux - Hardware 1 10-06-2003 06:33 PM
Logitech Elite Keyboard, F# keys don't work? jstn Linux - Hardware 4 05-21-2003 01:29 PM


All times are GMT -5. The time now is 09:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration