LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 12-20-2006, 10:42 AM   #1
Zlipknott
LQ Newbie
 
Registered: Dec 2006
Location: Lithuania
Distribution: Debian Sid
Posts: 17

Rep: Reputation: 0
k750i mobile + bluetooth


I wanted to control amaroK with my mobile phone (Sony Ericsson k750i), so I bought bluetooth adapter. Downloaded this: kde-apps.org/content/show.php?content=45012 and uploaded to phone via bluetooth. So bluetooth works Going to Entertainment > Remote control > Amarok. Phone asks to select the device I want to control, I press OK. Phone searches for devices, but it doesn't finds my computer What I am doing wrong?

Debian Sid, KDE 3.5.5, kbluetoothd is installed (bluez too ofcourse).
 
Old 12-20-2006, 01:17 PM   #2
Shaddy
Member
 
Registered: Apr 2003
Location: Germany
Distribution: PC1: Xandros 4 Prof, PC2: Debian Sarge, NB: SLED10+Windows XP
Posts: 39

Rep: Reputation: 15
Hi,

I had the same problems. Control the following configurations...

1) Is your bluetooth dongle working?
"hcitool dev" should show your device

2) Can you connect your mobile phone?
"hcitool scan" should show your mobile phone, if it is visible. This command will also show you the hardware address of your phone, so you can try to connect with "hcitool con <hd-address>". I think the default configuration is using the pin in /etc/bluetooth/pin, this should be 1234. This is the pin you have to enter on your mobile phone.

3) If that all works, the last step is to activate HID, as remote controlling your amarok is nothing else but controlling your OS via a remote device. This is an entry in /etc/default/bluez-utilz, which is about "HIDD_ENABLE=0". You'll have to change 0 to 1.

4) Don't forget to restart bluetooth with /etc/init.d/bluez-utilz restart

5) Now try again to access your amarok. It's more safe to try first the desktop application on your k750i. If you can move your mouse with the stick, everything works fine. If amarok does not work, you'll have to set up your custom global hot keys, according to your configuration on your mobile phone. But i think the website http://stefans.datenbruch.de/k750i/remote.shtml will help you for these steps...

Have fun

Shaddy
 
Old 12-20-2006, 02:12 PM   #3
Zlipknott
LQ Newbie
 
Registered: Dec 2006
Location: Lithuania
Distribution: Debian Sid
Posts: 17

Original Poster
Rep: Reputation: 0
1)Yes.
Devices:
hci0 00:04:61:86:691

2)Hmm..
# hcitool con 00:16:20:CE:27:C6
Connections:

# hcitool cc 00:16:20:CE:27:C6

# hcitool con 00:16:20:CE:27:C6
Connections:
< ACL 00:16:20:CE:27:C6 handle 42 state 1 lm MASTER

Hmm, phone didn't asked for any pins...

3)Ooops, no bluez-utils, only bluetooth. Changed HIDD_ENABLED=1

4)# /etc/init.d/bluez-utilz restart
bash: /etc/init.d/bluez-utilz: No such file or directory

# /etc/init.d/bluetooth restart
Restarting bluetooth: hidd hcid sdpd hidd rfcomm.

5)Selected Desktop, bla bla, phone searches for devices. After 30 seconds or so: No devices found. Search again?

So my phone still doesnt finds my computer, but computer finds my phone (altho phone doesnt asks for any pins..).

Still dont having fun

And that site doesnt help at all.

Last edited by Zlipknott; 12-20-2006 at 02:18 PM.
 
Old 12-21-2006, 02:24 AM   #4
Shaddy
Member
 
Registered: Apr 2003
Location: Germany
Distribution: PC1: Xandros 4 Prof, PC2: Debian Sarge, NB: SLED10+Windows XP
Posts: 39

Rep: Reputation: 15
Can you post your config files?

/etc/bluetooth/hcid.conf
/etc/bluetooth/rfcomm.conf
 
Old 12-21-2006, 03:15 AM   #5
Zlipknott
LQ Newbie
 
Registered: Dec 2006
Location: Lithuania
Distribution: Debian Sid
Posts: 17

Original Poster
Rep: Reputation: 0
#
# HCI daemon configuration file.
#

# HCId options
options {
# Automatically initialize new devices
autoinit yes;

# Security Manager mode
# none - Security manager disabled
# auto - Use local PIN for incoming connections
# user - Always ask user for a PIN
#
security user;

# Pairing mode
# none - Pairing disabled
# multi - Allow pairing with already paired devices
# once - Pair once and deny successive attempts
pairing multi;

# Default PIN code for incoming connections
passkey "1234";
}

# Default settings for HCI devices
device {
# Local device name
# %d - device id
# %h - host name
name "%h-%d";

# Local device class
class 0x3e0100;

# Default packet type
#pkt_type DH1,DM1,HV1;

# Inquiry and Page scan
iscan enable; pscan enable;

# Default link mode
# none - no specific policy
# accept - always accept incoming connections
# master - become master on incoming connections,
# deny role switch on outgoing connections
lm accept;

# Default link policy
# none - no specific policy
# rswitch - allow role switch
# hold - allow hold mode
# sniff - allow sniff mode
# park - allow park mode
lp rswitch,hold,sniff,park;
}



---



#
# RFCOMM configuration file.
#

#rfcomm0 {
# # Automatically bind the device at startup
# bind no;
#
# # Bluetooth address of the device
# device 11:22:33:44:55:66;
#
# # RFCOMM channel for the connection
# channel 1;
#
# # Description of the connection
# comment "Example Bluetooth device";
#}
 
Old 12-21-2006, 08:02 AM   #6
Shaddy
Member
 
Registered: Apr 2003
Location: Germany
Distribution: PC1: Xandros 4 Prof, PC2: Debian Sarge, NB: SLED10+Windows XP
Posts: 39

Rep: Reputation: 15
Quote:
# HCId options
options {
...
...
security user;
With this option, you should be asked on both devices, mobile phone and PC for a PIN, which have to be identical. Set this option to "auto", so you can leave your prefered pin in /etc/bluetooth/pin for authentication.
The rest looks OK.


Have you already watched, which processes are running? Is hidd running?

Greets

Shaddy
 
Old 12-21-2006, 08:36 AM   #7
Zlipknott
LQ Newbie
 
Registered: Dec 2006
Location: Lithuania
Distribution: Debian Sid
Posts: 17

Original Poster
Rep: Reputation: 0
Changed to auto, no effect.
hidd is running.
And my phone doesn't locates my computer
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless internet with T-mobile, Knoppix, and bluetooth nbcthreat Linux - Wireless Networking 9 06-12-2006 12:34 AM
[FC4] BLuetooth, how to hook up my Mobile phone/headset to Fedora? polemon Linux - Newbie 3 06-03-2006 06:05 PM
DISCUSSION: USB Bluetooth and mobile file transfers Hammett LinuxAnswers Discussion 7 05-09-2006 07:32 AM
mobile + bluetooth seaeye Linux - Networking 0 10-31-2004 06:05 PM
Mobile Bluetooth Calender Sync startail Linux - Software 10 09-16-2004 12:49 PM


All times are GMT -5. The time now is 10:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration