LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 04-10-2006, 06:03 PM   #1
reh_42
LQ Newbie
 
Registered: Sep 2005
Posts: 29

Rep: Reputation: Disabled
ipod is read only - how do I change this?


I run Ubuntu 5.10 and have a 40 G iPod.

The ipod is mounted to my desktop automatically and gtkpod can read the db file, etc. I add songs to it but when I go to sync it, I receive an error message telling me that it is a read-only file system.

How can I go about mounting or changing the file permissions for it and what exactly do I type into the command line?

Thank you very much.

Ruth
 
Old 04-10-2006, 07:28 PM   #2
microsoft/linux
Senior Member
 
Registered: May 2004
Location: Sebec, ME, USA
Distribution: Debian Etch, Windows XP Home, FreeBSD
Posts: 1,445
Blog Entries: 9

Rep: Reputation: 45
what's it listed as in /etc/fstab? My iPod line reads
Code:
/dev/ipod       /mnt/IPOD       vfat    users,defaults,gid=1000,uid=1000,nosuid         0       0
Hope this helps!
 
Old 04-11-2006, 03:51 PM   #3
reh_42
LQ Newbie
 
Registered: Sep 2005
Posts: 29

Original Poster
Rep: Reputation: Disabled
My iPod is not shown in my /etc/fstab, but here is what it registers as in my /etc/mtab.


Code:
/etc/mtab/

/dev/sdb2 /media/ipod vfat rw,nosuid,nodev,quiet,shortname=winnt,uid=1000,gid=1000,umask=077,iocharset=utf8 0 0
 
Old 04-11-2006, 04:43 PM   #4
microsoft/linux
Senior Member
 
Registered: May 2004
Location: Sebec, ME, USA
Distribution: Debian Etch, Windows XP Home, FreeBSD
Posts: 1,445
Blog Entries: 9

Rep: Reputation: 45
I think what it needs it to be mounted with the "users" parameter. I don't use Ubuntu, and I don't know how to set the mount parameters when it's automounted. Perhaps there's a way to set it graphically? Like right clicking on it, and setting a parameter that way?

According to this it looks like you need to edit /etc/auto.master and set the parameter esers there.

Last edited by microsoft/linux; 04-11-2006 at 04:46 PM.
 
Old 04-11-2006, 04:51 PM   #5
reh_42
LQ Newbie
 
Registered: Sep 2005
Posts: 29

Original Poster
Rep: Reputation: Disabled
There is a way to use the GUI and change the permissions, but when you click the box an error message pops up declaring

"Error Setting Permissions
The permissions could not be changed.

Couldn't change the permissions of "ipod" because it is on a read-only disk."


Awesome, huh?
 
Old 04-11-2006, 05:09 PM   #6
microsoft/linux
Senior Member
 
Registered: May 2004
Location: Sebec, ME, USA
Distribution: Debian Etch, Windows XP Home, FreeBSD
Posts: 1,445
Blog Entries: 9

Rep: Reputation: 45
can you edit the file mentioned above? Try doing it as root, otherwise it won't stick.
 
Old 04-11-2006, 06:07 PM   #7
reh_42
LQ Newbie
 
Registered: Sep 2005
Posts: 29

Original Poster
Rep: Reputation: Disabled
I know how to change the /etc/fstab and /mtab, but I don't know how to edit the permissions.
 
Old 04-11-2006, 07:15 PM   #8
microsoft/linux
Senior Member
 
Registered: May 2004
Location: Sebec, ME, USA
Distribution: Debian Etch, Windows XP Home, FreeBSD
Posts: 1,445
Blog Entries: 9

Rep: Reputation: 45
look at post #4, and read that link. I have a feeling that that might be what you're problem is. Try what's there first.
 
Old 04-19-2006, 12:27 PM   #9
reh_42
LQ Newbie
 
Registered: Sep 2005
Posts: 29

Original Poster
Rep: Reputation: Disabled
Sorry that it has taken me so long to reply: School is getting hectic with finals, etc.

So, I went back to thread no. 4 and checked out the link. After completing Step 1, I had to stop. In Step 2, the author says to add a line of code to " /etc/auto.master "

I am having a small problem: I have no /etc/auto.master. I don't even have an /etc/auto. Should I just go ahead and create a new directory, or should I find a better way to accomplish this task?
 
  


Reply

Tags
ipod, mounting, readonly, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
IPod mounts to wrong place, gtkpod can't read DB. dark_prancer Linux - Hardware 1 09-24-2005 09:13 PM
ipod read only??? nomass Mandriva 1 06-18-2005 07:07 PM
ubuntu 5.04 iPod mounting read-only johnnybezak Linux - Hardware 3 06-17-2005 01:04 AM
iPod mounting read-only FishieFishie Linux - Hardware 3 06-03-2005 07:32 PM
Change from Read only to Read Write File System? justiceisblind Linux - Newbie 3 03-03-2002 07:23 PM


All times are GMT -5. The time now is 03:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration