LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 03-21-2004, 01:41 AM   #1
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,349

Rep: Reputation: 42
Hp Office Jet


Still can't get my office jet K60 to work. Tried localhost:631 and redhat-config-printer. I'm sure it's just the url is wrong.
I think Linux is looking in the wrong place for it. Under Red Hat printer config I get the message unable to open usb:/dev/usb/lp0. If I could set the path to /dev/usb/lp0 it should work. Where is the config file with the path in it???
I have hpijs and hpoj installed. I'm sure it's just a path problem. Help!!
 
Old 03-21-2004, 02:03 AM   #2
tvn
Member
 
Registered: Mar 2004
Posts: 96

Rep: Reputation: 15
what happens when you use the cups web interface http://localhost:631 ? I don't use Redhat but I configure my printers via the web interface of cups
 
Old 03-21-2004, 03:34 AM   #3
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
What I read there a lot of problems setting up CUPS through Redhat. You can try Mandrake or another distribution.

Parallel port is easy to configure under LINUX than USB. Try setting up one of the printers using parallel port to see if it works. If it does work, you can get a card with parallel port and set it that way.

My CUPS config is located in /etc/cups. You can try there. I think printers.conf is the file.
 
Old 03-21-2004, 08:31 AM   #4
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,349

Original Poster
Rep: Reputation: 42
Well I found printers.conf and edited it to /dev/usb/lp0 but that didn't help.
I will try buying a parallel cable and see if that does it.
localhost:631 just sets it up wrong too.
I can of course carry it upstairs and try it on the other computer, running Mandrake 9.2
Thanks for the help anyway.
 
Old 03-21-2004, 12:53 PM   #5
tvn
Member
 
Registered: Mar 2004
Posts: 96

Rep: Reputation: 15
That could mean the printer is not yet recognized by the computer when you plug it in

type # tail -f /var/log/syslog , unplug and plug the printer and see if it recognizes it when it is unplugged and plugged in
 
Old 03-21-2004, 04:05 PM   #6
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
The address localhost is for only the computer that is running an HTTP, FTP, SSH, etc service. If you want to connect to it over the network. You have to know the IP address.

The problem with USB is it changes every time you disconnect and connect the device. You have to write a script that finds out the vendor ID, device ID, and what device node that LINUX created for it. Then the script will make or remake a symbolic link to the device. The path that CUPS has pointed to will be the name of the symbolic link something like /dev/hpijs and /dev/hpoj. The script will also help you if for some reason some one disconnects the printers.

Its also hard in Windows but I think LINUX is a little easier to control when dealing with USB devices.

I do not think CUPS has a driver for your printer.

You can try VMware if it does not work with CUPS.
 
Old 03-28-2004, 11:28 AM   #7
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,349

Original Poster
Rep: Reputation: 42
Thanks for the help, but it still won't work. I have hpoj and hpijs, newest versions.
I read through ptal help htmls.
ptal-connect can't connect.
ptal-setup can't setup. I am baffled. If I connect my Epson CUX42 or whatever it's called, works first time. And under win the OJ K60 works fine. Linux just can't handle it, afraid to say!
 
Old 04-07-2004, 08:26 PM   #8
r_jensen11
Senior Member
 
Registered: Apr 2003
Location: Minnesota, USA
Distribution: Slack 10.0 w/2.4.26
Posts: 1,032

Rep: Reputation: 45
Quote:
Originally posted by Electro
The problem with USB is it changes every time you disconnect and connect the device. You have to write a script that finds out the vendor ID, device ID, and what device node that LINUX created for it. Then the script will make or remake a symbolic link to the device. The path that CUPS has pointed to will be the name of the symbolic link something like /dev/hpijs and /dev/hpoj. The script will also help you if for some reason some one disconnects the printers.
Wait, I don't follow, but from what I think I understand, it fits my situation:

When I set up my printer, it CUPS saw my printer on USB1, but none of the documents actually printed to the printer, although all the programs (Including KDE's print manager and CUPS) claimed that the prints were completed. Then I turned off the printer, turned it back on, seeing if that would do anything. Now CUPS doesn't see the printer on USB1 when I choose where the source is (It just lists off USB1-8, etc, no names next to the device names).

So what are you saying I have to do with my K60, Electro?
 
Old 04-08-2004, 12:02 AM   #9
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Every device has a vendor ID and device ID that is hard coded in the firmware. If you check dmesg from any user you will see the vendor ID and device ID that LINUX has found. You have to add a line in usb.distmap found in hotplug directory. Make a script called printer and put it under ../hotplug/usb. Usually hotplug directory is located in /etc. The script should find if the printers are connected or removed. Using a utility like lsusb will help you. Then it should make a backup of your printer.conf from the cups directory. Next the script should edit the printer.conf to change to the new usb port. Finally, restart cups.

I have problems with Windows when using USB printers. I have to make sure to change to the right USB port before printing documents.

IMO, when printing, stick with parallel ports. They always work when they supposed to. You do not have to change configs every time you turn on the printer or plug it in a port.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HP Scan Jet 4200 C and Thin Clinets LoNeLyZoRa Linux - Hardware 0 10-11-2004 02:34 PM
HP Desk jet 952C and Suse 9.1? Lola Kews Linux - Hardware 1 06-02-2004 05:00 PM
Desk Jet 640 configuration on Mandrake 9.1 neranjana Mandriva 1 02-08-2004 08:26 PM
Tiger Jet modem Sandrocchio_0.1 Linux - Hardware 0 12-29-2003 05:22 PM
Canon i850 Bubble Jet Printer aherm Linux - Hardware 3 08-18-2003 01:42 PM


All times are GMT -5. The time now is 11:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration