LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-02-2004, 02:29 AM   #1
halcyon
LQ Newbie
 
Registered: May 2004
Posts: 5

Rep: Reputation: 0
harddisk read speed is too slow


My box is Debian sid
kernel 2.6.7

I compiled the kernel 2.6.7 and i work well, but today i boot my computer, it took a long time to boot up.

Here is the test results of the harddisk.
#hdparm -v /dev/hda
/dev/hda:
multcount = 0 (off)
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 256 (on)
geometry = 65535/16/63, sectors = 40020664320, start = 0

#hdparm -tT /dev/hda
/dev/hda:
Timing cached reads: 408 MB in 2.02 seconds = 202.41 MB/sec
Timing buffered disk reads: 4 MB in 4.87 seconds = 841.89 kB/sec

#hdparm -i /dev/hda
/dev/hda:

Model=ST340810A, FwRev=3.39, SerialNo=3FB25C2X
Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs RotSpdTol>.5% }
RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=4
BuffType=unknown, BuffSize=2048kB, MaxMultSect=16, MultSect=off
CurCHS=4047/16/255, CurSects=16511760, LBA=yes, LBAsects=78165360
IORDY=on/off, tPIO={min:240,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5
AdvancedPM=yes: unknown setting WriteCache=enabled
Drive conforms to: device does not report version:

* signifies the current active mode

So i come back to the old kernel 2.4.18
here is the results under kernel2.4.18
#hdparm -v /dev/hda
/dev/hda:
multcount = 0 (off)
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 8 (on)
geometry = 4865/255/63, sectors = 40020664320, start = 0

#hdparm -tT /dev/hda
/dev/hda:
Timing cached reads: 1008 MB in 2.00 seconds = 504.00 MB/sec
Timing buffered disk reads: 82 MB in 3.00 seconds = 27.33 MB/sec

The kernel 2.6.7 is compiled by myself and work fine for a long time.

How can I solve the problem?

Help!

Last edited by halcyon; 10-02-2004 at 02:31 AM.
 
Old 10-02-2004, 05:38 AM   #2
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
You can try adding the flags -m16 and -c3 to the hdparm command. Just man hdparm to see what these options actually do. It's a bit long-winded to explain fully, but it basically enables multiple sector mode and 32-bit I/O support.

Baldrick
 
Old 10-02-2004, 05:06 PM   #3
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
The option -c3 enables 32 bit I/O with sync. You may want to turn on unmaskirq. What it will do is make the computer do other jobs while the hard drive is finding the file. Though not all drives work well with multicount and read-ahead, so you have to experiment.
 
Old 10-03-2004, 01:33 AM   #4
emrahunal
LQ Newbie
 
Registered: Oct 2004
Location: Ankara
Distribution: Debian Unstable
Posts: 4

Rep: Reputation: 0
Hey Halcyon
Are you sure you enabled specific support for your ide-chipset at kernel compilation?
This is what I can think of, when you mentioned the difference between previous- and your custom kernel.

Emrah Unal
 
Old 10-05-2004, 09:26 AM   #5
halcyon
LQ Newbie
 
Registered: May 2004
Posts: 5

Original Poster
Rep: Reputation: 0
I have tried all the method mentioned above. But it has no effects.
My computer's hardware:

Mainboard: ECS K7S5A
CPU: Athlon XP1600+
Harddisk: Segate ST340810A & WDC WD300BB-32CCBO
CDRW: LG GCE-8400B

Segate is the master of the first channel and the WD is the slave. GCE is the master of the second channel.

The kernel that i compiled worked well. The reading speed was in a normal state, and it is about 27M/s.

This problem was suddenly happened.
I found that if I close the 'ACPI aware OS' in the BIOS, the reading speed under kernel 2.6 is good. But after I set this, the other system on my computer, Windows, couldn't boot up, it just reboot again and again.

Any advice will be thankful.

//bow
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Read only Harddisk problem novkhan Linux - Hardware 2 11-05-2005 09:57 PM
Set cdrom read speed McCloud Linux - Hardware 2 04-19-2005 07:31 PM
cdparanoia and --force-read-speed drisay Linux - Software 1 12-19-2004 08:58 AM
How to read the whole tracks from harddisk? yukchan Programming 2 11-13-2001 07:58 AM
read blocks directly from the harddisk Gregory Programming 0 03-08-2001 11:51 AM


All times are GMT -5. The time now is 06:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration