LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 06-17-2006, 02:48 PM   #1
RhysBJ
LQ Newbie
 
Registered: Jun 2006
Distribution: Fedora Core
Posts: 17

Rep: Reputation: 0
glx trouble, xorg nvidia drivers


I have tried installing the latest nVidia drivers by looking at both these sites:
http://www.fedorafaq.org/#nvidia
http://www.nvnews.net/vbulletin/showthread.php?t=68681

However it has not worked, and after I enabled them my computer would not get passed loading the windows system when logging in.

glxinfo displays this:
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x21 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x22 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None


I have looked at /etc/X11/xorg.conf and made sure Load "glx" was not commented out, and that Load "dri" and Load GLcore were.

Also somewhere along the way I seem to have lost the init command:
bash: init: command not found
I have no idea how that happened, but it was after I installed the drivers and so may give some clue as to the cause of the problem.
Also I get the same error for setsebool

glxinfo was working before I installed the drivers.

If anymore info is needed please tell me.


Edit: my card is a 7900GTX, if that helps

I just noticed that trying to used lsmod gives the same error as init

Last edited by RhysBJ; 06-17-2006 at 03:24 PM.
 
Old 06-18-2006, 01:21 AM   #2
elroacho
LQ Newbie
 
Registered: Oct 2005
Posts: 8

Rep: Reputation: 0
My xorg.conf looks like this:

Code:
Section "Module"
  Load         "dbe"
  Load         "type1"
  Load         "freetype"
  Load         "extmod"
  Load         "glx"
  Load         "v4l"
EndSection

Section "Device"
  BoardName    "GeForce 6800 GT"
  BusID        "1:0:0"
  Driver       "nvidia"
  Identifier   "Device[0]"
  Option       "usevnc" "no"
  VendorName   "NVidia"
EndSection
Make sure the Driver is "nvidia" and not "nv", "nv" is gereric and has no opengl(glx) capabilities. Which distro? Fedora?

Did you look here: http://www.nvidia.com/object/linux_d..._1.0-8762.html
 
Old 06-18-2006, 05:13 AM   #3
RhysBJ
LQ Newbie
 
Registered: Jun 2006
Distribution: Fedora Core
Posts: 17

Original Poster
Rep: Reputation: 0
The reason it was not working was (I think) because I was not logging in as root, even though I was using su to (I thought) do that.
After logging in a root from the login screen I followed the step here again and it worked.

Can anyone tell me the difference between logging in as root and using su?
 
Old 06-18-2006, 04:25 PM   #4
elroacho
LQ Newbie
 
Registered: Oct 2005
Posts: 8

Rep: Reputation: 0
"su" and "su -" are different. "su" will run commands as your user with root privileges, "su -" will run the command as root.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no display: Xorg, Nvidia driver broken after Etch update; Failed to load module "glx" forgox Debian 19 07-12-2010 12:26 PM
Nvidia GeForce 4 MX 440 poor performance nvidia glx drivers jollyjoice Linux - Hardware 7 06-07-2006 09:02 AM
Problem installing Nvidia glx drivers YellowFin Ubuntu 2 01-28-2006 03:47 PM
Nvidia 5328 drivers - damn poor GLX madlinux Fedora 3 01-05-2004 11:50 AM
Nvidia Drivers and GLX klatu Linux - Hardware 9 11-17-2003 04:43 PM


All times are GMT -5. The time now is 04:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration