LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-06-2005, 06:09 AM   #1
sixth_sense
Member
 
Registered: Mar 2004
Distribution: RedHat
Posts: 99

Rep: Reputation: 15
Flash disk automount


Hi,

I am using a Imation flash disk, I can use it with my linux pc, I made this entry in my /etc/ftab file:

/dev/sda1 /mnt/flash auto noauto,user 0 0


the problem is I need to make the stick automatic mounted whenever I plug it in...
everytime, I need to type those boring commands to make it mounted. (mount /mnt/flash)

Anyway, Is there any way solve it ?

Thanks,
 
Old 08-06-2005, 10:41 AM   #2
aysiu
Senior Member
 
Registered: May 2005
Distribution: Ubuntu with IceWM
Posts: 1,776

Rep: Reputation: 66
This probably isn't the answer you want to hear, but you need to get a new distribution. Hotplug/automount abilities in Linux have been refined a lot in the last few months/year. For example, when I used Mepis 3.3, it wouldn't hotplug and automount USB drives (external hard drive/flash drive), but when I upgraded to Mepis 3.3.1 (which came out only a couple of months ago), it did.

Ubuntu also does great automounting of external media.
But I think any up-to-date distro should do it.

What are you using--Red Hat 9.0? If you like Red Hat, I can't vouch for this, but I believe Fedora Core 4 would be the most up-to-date distro to use that's sort of like Red Hat.
 
Old 08-06-2005, 04:10 PM   #3
bp12345
Member
 
Registered: Jun 2005
Distribution: Debian testing, Kubuntu 5.04
Posts: 104

Rep: Reputation: 15
If there is usb support, hotplug support, a recent kernel, and fstab is set up correctly, USB drives should auto-mount.
By definition, 'noauto' in fstab prevents a USB drive from auto-mounting. Remove it and it shold work.
 
Old 08-07-2005, 04:54 PM   #4
basileus
Member
 
Registered: Nov 2004
Location: Turku, Finland
Distribution: Debian, Ubuntu, Gentoo
Posts: 388

Rep: Reputation: 30
I have tested "dbus-1" - "hald" - "gnome-volume-manager" - "2.6 -kernel" combination recently. Even though I've had some problems with it (media lockups) it seems to work adequately. I still don't trust it - although I don't yet trust any automounter daemons

With Gentoo or Mandrake you might be using "supermount". I've tried "autofs" and it works, but is (or was) rather clumsy. There is also something that's called "submount", but I have not tried that myself.

As what comes to /etc/fstab and the option "noauto"... it simply means that the filesystem is not mounted _at boot time_. It is completely unrelated to volume automounting.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB flash disk taoweijia Linux - Hardware 2 12-28-2005 04:30 AM
Mandriva 2006 USB flash Drive Automount casperbg Linux - Hardware 4 10-20-2005 01:43 PM
Automount USB disk at startup becho4 Linux - Software 1 07-08-2005 08:36 AM
USB flash disk help bakazer Solaris / OpenSolaris 1 06-24-2005 09:30 AM
wierd characters in external disk name after Gnome automount nsk078 Linux - General 0 11-27-2004 05:32 PM


All times are GMT -5. The time now is 02:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration