LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 03-01-2013, 03:37 PM   #1
SharpyWarpy
Member
 
Registered: Feb 2003
Location: Florida
Distribution: Fedora 18
Posts: 862

Rep: Reputation: 90
Fedora 18 x64, xsane won't detect scanner even though sane-find-scanner does


Did a search here and found a similar post from '06 so I need some help getting xsane to find my HP PSC1200 series scanner. It prints fine, just doesn't scan.
Code:
cat /etc/sane.d/dll.conf
# enable the next line if you want to allow access through the network:
net
abaton
agfafocus
apple
avision
artec
artec_eplus48u
as6e
bh
canon
canon630u
canon_dr
#canon_pp
cardscan
coolscan
#coolscan2
coolscan3
#dc25
#dc210
#dc240
dell1600n_net
dmc
epjitsu
#epson
epson2
fujitsu
#gphoto2
genesys
gt68xx
hp
hp3900
hpsj5s
hp3500
hp4200
hp5400
hp5590
hpljm1005
hs2p
ibm
kodak
kodakaio
kvs1025
kvs20xx
leo
lexmark
ma1509
magicolor
matsushita
microtek
microtek2
mustek
#mustek_pp
mustek_usb
mustek_usb2
nec
niash
#p5
pie
pint
pixma
plustek
#plustek_pp
#pnm
qcam
ricoh
rts8891
s9036
sceptre
sharp
sm3600
sm3840
snapscan
sp15c
#st400
#stv680
tamarack
teco1
teco2
teco3
#test
u12
umax
#umax_pp
umax1220u
v4l
xerox_mfp
Code:
cat /etc/sane.d/hp.conf
# scsi HP
# Uncomment the following if you have "Error during device I/O" on SCSI
#   option dumb-read
#
# The usual place for a SCSI-scanner on Linux
/dev/scanner
#
# USB-scanners supported by the hp-backend
# HP ScanJet 4100C
# usb 0x03f0 0x0101
# HP ScanJet 5200C
# usb 0x03f0 0x0401
# HP ScanJet 62X0C
# usb 0x03f0 0x0201
# HP ScanJet 63X0C
# usb 0x03f0 0x0601
usb 0x03f0 0x2f11
#
# Uncomment the following if your scanner is connected by USB,
# but you are not using libusb
# /dev/usb/scanner0
#   option connect-device
There are other HP configuration files in /etc/sane.d but isn't editing /etc/sane.d/hp.conf enough? The line "usb 0x03f0 0x2f11" in /etc/sane.d/hp.conf I got from running "sane-find-scanner":
Code:
sane-find-scanner 

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x03f0 [Hewlett-Packard], product=0x2f11 [psc 1200 series]) at libusb:002:004
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.
I should mention here the printer will copy fine using the panel on the printer. Thanks in advance.

Last edited by SharpyWarpy; 03-01-2013 at 03:45 PM. Reason: additional info
 
Old 03-02-2013, 08:41 AM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,851

Rep: Reputation: 432Reputation: 432Reputation: 432Reputation: 432Reputation: 432
Your scanner is supported by the HPLIP driver package, according to this link:

-->http://hplipopensource.com/hplip-web...es.html#note11

I'm assuming you have a recent version of HPLIP installed. Check the version, make sure you have the minimum version 0.9.5 installed. If not, you will need to get a newer version.

Follow the download link above, there are instructions on how to download and install HPLIP on various distros. Fed 18 is listed. See this link:

-->http://hplipopensource.com/hplip-web...dora_core.html

There are dependencies. Make sure you have them. Note your user(s) have to added to the lp and sys groups. You might try accessing the scanner as root, if that works, adding the user to the correct groups is most likely the all that is needed.
 
Old 03-02-2013, 11:48 AM   #3
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 3,126

Rep: Reputation: 792Reputation: 792Reputation: 792Reputation: 792Reputation: 792Reputation: 792Reputation: 792
It's also a good idea to set up HP devices with their own tool rather than the usual printer and scanner configuration methods.
http://hplipopensource.com/hplip-web...ges/setup.html
 
Old 03-05-2013, 07:10 AM   #4
utoddl
LQ Newbie
 
Registered: Oct 2005
Location: Sanford, NC
Distribution: Fedora, Ubuntu
Posts: 3

Rep: Reputation: 1
It's a packaging issue. For some reason the actual sane drivers for the scanners aren't installed. You need to issue the following command as root or under sudo:

yum -y install sane-backends-drivers-scanners

That should fix you right up.
 
Old 03-06-2013, 01:25 PM   #5
SharpyWarpy
Member
 
Registered: Feb 2003
Location: Florida
Distribution: Fedora 18
Posts: 862

Original Poster
Rep: Reputation: 90
Thank you guys, I don't have access to my computer right now but as soon as I can I'll report back here after I've tried your suggestions. Thanks again.
 
Old 03-07-2013, 12:45 AM   #6
SharpyWarpy
Member
 
Registered: Feb 2003
Location: Florida
Distribution: Fedora 18
Posts: 862

Original Poster
Rep: Reputation: 90
Okay I have the following HPLIP packages installed:

hplip-3.12.11-1.fc18.x86_64
hplip-gui-3.12.11-1.fc18.x86_64
hplip-common-3.12.11-1.fc18.x86_64
hplip-libs-3.12.11-1.fc18.x86_64

I also installed sane-backends-drivers-scanners with yum. I used the hp-setup utility. Now xsane starts, prompting for a choice of devices, USB camera and the hp 1200 MFP. When I choose the hp 1200 it freezes and I have to kill it.
 
Old 03-07-2013, 08:02 AM   #7
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,851

Rep: Reputation: 432Reputation: 432Reputation: 432Reputation: 432Reputation: 432
Only thing I can suggest at this point, is go to this link

-->http://hplipopensource.com/node/333

It lists some trouble shooting that may help.
 
Old 03-07-2013, 08:21 PM   #8
SharpyWarpy
Member
 
Registered: Feb 2003
Location: Florida
Distribution: Fedora 18
Posts: 862

Original Poster
Rep: Reputation: 90
Quote:
Originally Posted by camorri View Post
Only thing I can suggest at this point, is go to this link

-->http://hplipopensource.com/node/333

It lists some trouble shooting that may help.
I read the page for which you provided a link. I ran hp-check then hp-check --fix and xsane still hangs when choosing the scanner instead of USB camera. The package "polkit" is reported as missing or incompatible. I installed a BUNCH of packages hp-check said were missing, a large part being development packages. I don't understand why it asks for development packages, I'm not compiling anything.
 
Old 03-17-2013, 06:18 PM   #9
SharpyWarpy
Member
 
Registered: Feb 2003
Location: Florida
Distribution: Fedora 18
Posts: 862

Original Poster
Rep: Reputation: 90
Quote:
Originally Posted by SharpyWarpy View Post
I read the page for which you provided a link. I ran hp-check then hp-check --fix and xsane still hangs when choosing the scanner instead of USB camera. The package "polkit" is reported as missing or incompatible. I installed a BUNCH of packages hp-check said were missing, a large part being development packages. I don't understand why it asks for development packages, I'm not compiling anything.
I got xsane to work with this scanner by disabling the USB camera (webcam). I just wish I could get iscan to work with my film negative scanner now, an Epson Photo 3170 Perfection. Thanks to everyone for the help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
usb scanner premissions issue when running sane-find-scanner vlsd Linux - Hardware 4 08-20-2009 02:20 PM
Problem with my Canon Lide 25 scanner and Sane/XSane hansdezwart Linux - Hardware 1 08-22-2007 06:10 AM
Sane/Xsane can't find HP scanner Mark_in_Hollywood Linux - Newbie 4 04-19-2006 12:21 AM
Sane in Breezy won't detect scanner GreatBrak Ubuntu 0 11-06-2005 10:43 AM
sane/xsane can't find usb scanner walterbyrd Linux - Hardware 0 07-24-2004 10:39 AM


All times are GMT -5. The time now is 04:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration