LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-18-2006, 11:58 AM   #16
cubdukat
Member
 
Registered: Mar 2006
Posts: 48

Original Poster
Rep: Reputation: 15

Okay, I took a look at the /dev folder last night, and I didn't find ttsX. I think ttyS1 is the actual character device. It's permissions are read and write for root, user and group, and it belongs to root and tty.

So I'm thinking that all I should need to do is add my user to the tty group, but wouldn't it work in root, since theoretically root should belong to every group?

Should I also check the ownership of pppd, KInternet, KPPP and wvdial? And to what should I change them?
 
Old 05-18-2006, 11:30 PM   #17
xode
Member
 
Registered: Aug 2003
Distribution: Mandrake 9.0; FC4; FC8; SUSE 10.3; SUSE 12.1
Posts: 537
Blog Entries: 1

Rep: Reputation: 43
Quote:
From cubdukat

I think ttyS1 is the actual character device.
You don't need to guess; you can know. While looking at /dev/ttyS1 with your GUI file manager (i.e. konqueror), put the mouse cursor over /dev/ttyS1's icon. The icon should become highlighted in some manner to let you know that it has noticed the mouse cursor over it. Then, press the right mouse button. That should pull up a little menu window on which one of the selections says properties. Select properties with the left mouse button and another window should pop up. On that other window look for either something that says "points to..." or something that states a file size. If there is a "points to..." on that other window, then /dev/ttyS1 is a link and you need to look at what /dev/ttyS1 points to. In either case post back here what you find out.

Quote:
From cubdukat

Should I also check the ownership of pppd, KInternet, KPPP and wvdial? And to what should I change them?
Let's leave that alone for now.

Quote:
From cubdukat

but wouldn't it work in root, since theoretically root should belong to every group?
root doesn't need to belong to any group or own any file, and yet root can still do anything. Linux automatically bypasses all security checks in regards to anything that root (i.e. uid 0) tells linux to do. Let's try to get this working with your regular user account, however.

Quote:
From cubdukat

So I'm thinking that all I should need to do is add my user to the tty group
Try this and let's see what happens. Of course, it goes without saying, that you will need to run as root in order to add your regular user to the tty group and if you have a GUI program for that you should use that. Make sure that you save any changes that you make as you go along and before you exit the program. Look for something to the effect of SuSE Configuration Tools, SuSE Control Center, etc. If you find such a GUI program, when you try to run it, it should prompt you for root's password.
 
Old 05-19-2006, 01:19 PM   #18
cubdukat
Member
 
Registered: Mar 2006
Posts: 48

Original Poster
Rep: Reputation: 15
Well, I did a check last night and found that my regular user didn't belong to tty, so I put them in that group.

When I restarted I was able to connect and download the security updates, but this morning, I'm back to the same thing again.

Unfortunately, I have a more important issue to tend to--AfterStep has taken over my user account, so I uninstalled it, and now it won't go into anything else. I'm thinking that I could probably get away with reinstalling it and just selecting KDE again. If not, then maybe I'll try Ubuntu again.

I knew I should have backed up the system!
 
Old 05-25-2006, 06:20 AM   #19
staham
LQ Newbie
 
Registered: May 2006
Posts: 26

Rep: Reputation: 15
An easy way to test this is by running the command:
echo "ATZ" > /dev/ttyS0

or ttyS1,S2, until you hear the modem responding to the command.

ATZ resets the modem. You can also try, for example "ATA" that picks up the receiver,
and you should hear a dial tone if your speaker is switched on.

Obviously, if you don't have permission to write to the device you'll get an error message.

You might try this as root first, just to find the right device.

Last edited by staham; 05-25-2006 at 06:23 AM.
 
Old 05-25-2006, 01:37 PM   #20
xode
Member
 
Registered: Aug 2003
Distribution: Mandrake 9.0; FC4; FC8; SUSE 10.3; SUSE 12.1
Posts: 537
Blog Entries: 1

Rep: Reputation: 43
My recommendation at this point: (1) save your data to CD; (2) wipe your hard drive clean; (3) do a clean SuSE install (without AfterStep); (4) try the above fixes (e.g. adding your regular user to the tty group) on your clean SuSE.

If

"...When I restarted I was able to connect and download the security updates, but this morning, I'm back to the same thing again...."

persists, then you want to look and see if the regular user that you added to tty has been removed from the group.
 
Old 05-27-2006, 10:03 PM   #21
cubdukat
Member
 
Registered: Mar 2006
Posts: 48

Original Poster
Rep: Reputation: 15
Sounds like that's what I'm going to have to do, because now the modem seems to have disappeared altogether, along with the tty group. /dev/ttyS1 now belongs to the uucp group. What would make it switch groups like that?

I've resolved the AfterStep issue, in that my non-root user is now permanently locked into using KDE (I put "exec startkde" into .xinitrc)--which I don't necessarily mind, since I like KDE, but I would like some variation.

I'll probably do it tomorrow night, after the Indy 500 ends. Installing Suse takes a while. And this time, NO AFTERSTEP! As much as I like the look, it's not worth the hassle.

I might try Enlightenment, if I can ever get it to work.

I'm also looking at getting out of the external modem altogether and going with a cheap internal Winmodem I saw at Wal-Mart (not to worry; it's Agere-powered). The external's seven or eight years old and the last upgrade for it was three years ago and I've already done it, plus I've all but crushed it once or twice when I stepped on it (apparently Zoom external modems are not built to withstand 190 pounds of pressure )

Before I get rid of it, though, I'll try to flash it to see if I can get it to do V.92. Maybe Suse will recognize it better then.

And above all, the minute I get the system back up and running, the system will be backed up! I've been putting it off, but if I get the modem working again, I want a snapshot of the system in that state.
 
Old 05-27-2006, 10:23 PM   #22
xode
Member
 
Registered: Aug 2003
Distribution: Mandrake 9.0; FC4; FC8; SUSE 10.3; SUSE 12.1
Posts: 537
Blog Entries: 1

Rep: Reputation: 43
Quote:
From cubdukat

I'm also looking at getting out of the external modem altogether and going with a cheap internal Winmodem I saw at Wal-Mart (not to worry; it's Agere-powered).
You don't want to do that. Winmodem manufacturers are notorious for not providing support for linux and, based on my experience, in the case of the few that do, the drivers cause linux to become unstable. Of course, as you would expect, the instability is not immediately obvious but mprime certainly picks it up as in continuous "Illegal Sumout!" error messages (meaning that the modem driver kernel module is not properly saving the CPU state). You want to stay with a hardware (controller based) modem even if it is an internal one.
 
Old 05-30-2006, 02:23 PM   #23
cubdukat
Member
 
Registered: Mar 2006
Posts: 48

Original Poster
Rep: Reputation: 15
Really? I wasn't aware of that.

Could you recommend a good USB and/or serial modem that should work off the bat with Suse 10? And yes, I know that all serial modems should work, but given my current experiences, apparently some don't.

I just want something that I don't have to screw around with for days just to get it to work.
 
Old 05-30-2006, 10:00 PM   #24
xode
Member
 
Registered: Aug 2003
Distribution: Mandrake 9.0; FC4; FC8; SUSE 10.3; SUSE 12.1
Posts: 537
Blog Entries: 1

Rep: Reputation: 43
I suspect that your problem might stem from the 2.6 kernel since I heard that it abandoned a lot of legacy hardware support. I have a Zoom 3048 56K V.92/V.90 external serial modem connected to COM1 myself and I can use Netzero in Windows 95 running under Win4Lin under my Mandrake 9.0 to connect to the internet. However, Mandrake 9.0 uses a 2.4 kernel which has legacy hardware support. But, I just got FC4 (which uses a 2.6 kernel) installed and running on my other computer and I just saw that it isn't seeing the U.S. Robotics hardware modem that I have in that computer. So, I suspect that what it takes for me to solve that problem will be similar to the solution to your problem. So, I don't have an immediate answer to your question as to what modem to use but I will find out since I want that other computer to be able to dip into the internet via Netzero as well.
 
Old 05-31-2006, 04:03 AM   #25
pianiccia
LQ Newbie
 
Registered: May 2006
Posts: 1

Rep: Reputation: 0
Hi, I have exactly the same problem with 10.1 for x86_64, I tried most of the tricks listed here, nothing works !

my modem is connected to /dev/ttyS0, statserial sees it (bits change when I switch it on/off), but typing echo "ATZ" > /dev/ttyS0 even as root fails !

Don't think it's a kernel problem since Mandriva & FC5 use a 2.6 kernel and I had no problem with these distros.

-------------------------------------
Asus A8N-E
AMD 64X2 4400+
2 Gb RAM
 
Old 05-31-2006, 07:01 PM   #26
cubdukat
Member
 
Registered: Mar 2006
Posts: 48

Original Poster
Rep: Reputation: 15
I thought it might have been a kernel issue, since I had the same results with Mandriva and Fedora Core 5, both of which have the 2.6 kernel, but it's worked on Suse, however infrequently.

If it is a kernel issue, it's an intermittent one. Either way, I have lost patience with it. I'm chucking the modem and getting a newer one. If that doesn't work, the screw Linux. I'm no fan of Windows, but at least I will be able to get online with it without a lot of hassle. Unfortunately for me, broadband access is not currently an option.
 
Old 06-02-2006, 02:31 AM   #27
xode
Member
 
Registered: Aug 2003
Distribution: Mandrake 9.0; FC4; FC8; SUSE 10.3; SUSE 12.1
Posts: 537
Blog Entries: 1

Rep: Reputation: 43
Looks like you might be giving up on linux too soon. I know that this has given you a lot of hassle, but I just found out how to make my modem talk. This is what I think might work for you.

(1) Do a clean install of your linux.

(2) at a root console, type: dmesg | grep tty (this was the key for me).

The result should be a list of all of your serial ports, including your modem and the IRQs that are tied to them.

(3) if /dev/modem doesn't exist, as it didn't in my FC4, make a symbolic link from /dev/modem to where your modem is.

You should then be able to access your modem via /dev/modem using KPPP, at least as root, as I was. Test this to see if /dev/modem survives a reboot. If /dev/modem doesn't survive a reboot, then remake the link. In either case, see if KPPP can still access your modem via /dev/modem. If it can, then you should be up and running with your modem, at least as root.
 
Old 06-02-2006, 07:39 PM   #28
cubdukat
Member
 
Registered: Mar 2006
Posts: 48

Original Poster
Rep: Reputation: 15
I'll try that tonight.

If it doesn't survive the reboot, how do I proceed?

It seems like it makes the change just to humor me, then it just changes it back to what it was before.
 
Old 06-02-2006, 10:12 PM   #29
xode
Member
 
Registered: Aug 2003
Distribution: Mandrake 9.0; FC4; FC8; SUSE 10.3; SUSE 12.1
Posts: 537
Blog Entries: 1

Rep: Reputation: 43
Quote:
From cubdukat

If it doesn't survive the reboot, how do I proceed?
By "it" I assume that you mean the /dev/modem link. If /dev/modem did survive a reboot, then immediately see if you can access your modem through KPPP as root, to see if the reboot caused any changes in how you are able to access the modem. If /dev/modem doesn't survive a reboot, then immediately remake the link and then check to see if you can access your modem through KPPP as root, to see if the reboot caused any changes in how you are able to access the modem.

If the reboot did not cause any changes in how you are able to access your modem through KPPP, regardless of whether or not /dev/modem survived the reboot, then, if /dev/modem did not survive the reboot, add the link making command (i.e. "ln -s ... /dev/modem") to your startup script (probably /etc/rc.d/rc.local). Then, do a second reboot, to verify that /dev/modem now always comes back (since you now remake it each time) and that you can access your modem through KPPP as root.
 
Old 06-12-2006, 02:17 AM   #30
xode
Member
 
Registered: Aug 2003
Distribution: Mandrake 9.0; FC4; FC8; SUSE 10.3; SUSE 12.1
Posts: 537
Blog Entries: 1

Rep: Reputation: 43
What's the latest? As of this point, as a regular user, I have MSDOS running in qemu (a virtual machine program) in FC4 able to see /dev/ttyS14 as if it were COM1. I did have to add my regular user to the uucp group (probably your equivalent of the tty group in your SuSE linux) to allow access to /dev/ttyS14.
 
  


Reply

Tags
external, kernel, modem, module, name


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
External U.S robotics Modem under Suse problem ahnaqsh Linux - Hardware 12 11-06-2006 02:50 PM
Configure problem while building rpm with krpmbuilder on SUSE 10.0 OSS Zsub Suse/Novell 4 09-15-2006 10:39 PM
Suse 10.0 OSS multimedia problem winsnomore Suse/Novell 25 11-23-2005 05:21 PM
Problems installing SmartLink 56.6k External USB Modem on SuSE 9.2 Jongi Suse/Novell 18 06-10-2005 02:04 AM
external modem problem jamaso Linux - Hardware 5 10-20-2004 06:08 AM


All times are GMT -5. The time now is 01:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration