LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 12-15-2004, 05:48 AM   #1
himm
LQ Newbie
 
Registered: Sep 2004
Posts: 21

Rep: Reputation: 15
/dev/modem and /dev/ttyLT0 keep disappearing (ltmodem)


I'm on Fedora Core 3.
I installed the ltmodem drivers from source.
./build_module
./ltinst2
./autoload
./checkout

The modem works fine and I can connect and browse websites.
But when i reboot, it no longer works. That's because there's no longer any /dev/modem or /dev/ttyLT0 present. The drivers do load up properly during startup. lsmod shows them to be detected. They're present in modprobe.conf.

alias /dev/modem lt_serial
alias char-major-62 lt_serial
alias /dev/tts/LT0 lt_serial

I can get them to work by installing the drivers again...until I reboot.

Anyone know what can be done to stop /dev/modem and its symlinks from disappearing?
 
Old 12-15-2004, 02:17 PM   #2
himm
LQ Newbie
 
Registered: Sep 2004
Posts: 21

Original Poster
Rep: Reputation: 15
wvdial confirms this problem: I get a message complaining that there is no /dev/modem.

also, just in case this never works, does this modem seem ok?
http://www.dse.co.nz/cgi-bin/dse.sto...ct/View/XH1154
It says it's compatible with Linux, but it then goes on to say that it "uses the host computer's CPU to replace the modem's controller," which sounds pretty winmodm-ish.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I cannot access EITHER CD drive! And there's no /dev/hdc or /dev/hdd or /dev/cdrom! Dmalic Linux - Hardware 13 11-18-2005 07:11 PM
Disappearing devices in /dev/ thew00t Linux - Hardware 3 04-11-2005 07:09 AM
Things disappearing from /dev drr104 Debian 1 12-04-2004 11:04 AM
How to create /dev/ttyLT0? TheOneAndOnlySM Linux - General 4 03-15-2004 09:05 PM
/dev/modem Keeps Disappearing cam34 Linux - Software 1 09-01-2003 04:40 PM


All times are GMT -5. The time now is 10:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration