LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 12-17-2005, 04:12 PM   #1
Pandamatak
LQ Newbie
 
Registered: Sep 2005
Location: Menlo Park, CA
Posts: 8

Rep: Reputation: 0
Can't get LAN to be detected on any of my Intel motherboards (RH9.0)


Hello

I just can't seem to find info on this anywhere on this forum by searching, nor through Google. Maybe I am not looking hard enough, please forgive me.

I've built two RH9.0 systems using Intel 915GEV boards and am building three RH9.0 systems using the D945Gtp mother boards. Unfortunately, I just can't seem to get the on-board LAN to be detected. In the past (for the two GEV systems), I got around this by installing separate ethernet cards and not using the on-board LAN. But now I have the three that I'm building with the D945GTP boards that present the same problem. That is, ethernet is not detected at RH install time (which is what usually happens if I have a working LAN card). Moreover, I can't seem to identify the right drivers to install even after the OS install. The Intel support website doesn't help, I'm afraid, since it only has driver downloads for RH Enterprise Linux.

Yet I'm sure this must be a common problem. Aren't there folks out there who've build RH9 servers using Intel motherboards? Can someone help please? I need to build several more systems for my server farm and would rather not go and buy lots of ethernet cards.

Much appreciated. Thanks.

avenk
 
Old 12-17-2005, 05:31 PM   #2
pddm
Member
 
Registered: Sep 2005
Distribution: Slackware 13.37
Posts: 111

Rep: Reputation: 15
Chack this thread, I had problems with LAN on my Intel Motherboard:
http://www.linuxquestions.org/questi...d.php?t=391668
 
Old 12-18-2005, 11:09 AM   #3
Pandamatak
LQ Newbie
 
Registered: Sep 2005
Location: Menlo Park, CA
Posts: 8

Original Poster
Rep: Reputation: 0
Still no luck (LAN on Intel D945GTP)

Pddm, I followed the thread you pointed me at and tried all of the modprobes. Unfortunately, this is what I get:

[root@zeta-003 grub]# /sbin/modprobe e100
/lib/modules/2.4.20-6smp/kernel/drivers/net/e100/e100.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-6smp/kernel/drivers/net/e100/e100.o: insmod /lib/modules/2.4.20-6smp/kernel/drivers/net/e100/e100.o failed
/lib/modules/2.4.20-6smp/kernel/drivers/net/e100/e100.o: insmod e100 failed
[root@zeta-003 grub]# /sbin/modprobe eepro
/lib/modules/2.4.20-6smp/kernel/drivers/net/eepro.o: init_module: Device or resource busy
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-6smp/kernel/drivers/net/eepro.o: insmod /lib/modules/2.4.20-6smp/kernel/drivers/net/eepro.o failed
/lib/modules/2.4.20-6smp/kernel/drivers/net/eepro.o: insmod eepro failed
[root@zeta-003 grub]# /sbin/modprobe eepro100
/lib/modules/2.4.20-6smp/kernel/drivers/net/eepro100.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-6smp/kernel/drivers/net/eepro100.o: insmod /lib/modules/2.4.20-6smp/kernel/drivers/net/eepro100.o failed
/lib/modules/2.4.20-6smp/kernel/drivers/net/eepro100.o: insmod eepro100 failed

Dmesg shows:
eepro100.c:v1.09j-t 9/29/99 Donald Becker http://www.scyld.com/network/eepro100.html
eepro100.c: $Revision: 1.36 $ 2000/11/17 Modified by Andrey V. Savochkin <saw@saw.sw.com.sg> and others
eepro_init_module: Probe is very dangerous in ISA boards!
eepro_init_module: Please add "autodetect=1" to force probe
eepro_init_module: Probe is very dangerous in ISA boards!
eepro_init_module: Please add "autodetect=1" to force probe
eepro100.c:v1.09j-t 9/29/99 Donald Becker http://www.scyld.com/network/eepro100.html
eepro100.c: $Revision: 1.36 $ 2000/11/17 Modified by Andrey V. Savochkin <saw@saw.sw.com.sg> and others

and lspci -v shows:

...
06:08.0 Ethernet controller: Intel Corp.: Unknown device 27dc (rev 01)
Subsystem: Intel Corp.: Unknown device 308d
Flags: bus master, medium devsel, latency 32, IRQ 11
Memory at 50004000 (32-bit, non-prefetchable) [size=4K]
I/O ports at 1100 [size=64]
Capabilities: [dc] Power Management version 2
...

I went out and got some cheap US Robotics ethernet cards, for 7.99 apiece from Fry's because I was stuck for time and these worked like a charm. Practically plug and play. Still I would have liked to have the native solution going! I'm sure there's a fix somewhere.

If there is a simple fix, I have the same question an earlier poster asked. Why aren't these posted on the Intel support website?

Thanks.

&
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hang-->agpgart:Detected Intel 440 IrZack Linux - Newbie 17 10-05-2007 11:29 AM
Assigning eth0 / eth1 or multi-LAN motherboards? Eastside Linux - Networking 5 06-13-2005 10:34 PM
proper support for intel i915 chipset motherboards? TheOneAndOnlySM Linux - Hardware 8 02-15-2005 12:07 AM
Powersupply Issue with Intel Motherboards adler321 Linux - Hardware 1 11-30-2004 08:40 PM
Intel 875P motherboards + kernel 2.6 vrln Linux - Hardware 2 06-23-2004 07:41 AM


All times are GMT -5. The time now is 12:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration