LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-12-2004, 12:13 AM   #1
chalichalupa
LQ Newbie
 
Registered: Jan 2004
Location: philippines
Posts: 16

Rep: Reputation: 0
Badly Needing Help : Nic Problems




TO ALL MANDRAKE EXPERTS HELP ME

THE SITUATION:
MY OPERATING SYSTEM IS LINUX MANDRAKE AND LINUX SLACKWARE.
I BOOT FROM MANDRAKE.
I HAVE TW0 NIC THE 3COM 3C509B AND BROADCOM BCM94306.
ALL THOSE TWO NIC'S ARE CONNECTED TO THE INTERNET.
I AM CONNECTED TO A PROXY SERVER.
I USED MY 3COM NIC TO CONNECT ME TO THE INTERNET.
I USED STATIC IP FOR THIS NIC(3COM).
I USED THE COMMAND modprobe 3c509 for my 3com nic.
(nevermind the Broadcom)

MY PROBLEM:
only my slackware can connect me to the internet.
my mandrake cannot,
ive tried pinging my ip or my loopback .. it did replied ,,
but if i ping my proxy server the says network destination unreachable.
It is important for me to connect my mandrake to the internet, because i will be using it for some important purposes.

I have tried reconfiguring all network configuration of mandrake. but it has no effect.

PLS GIVE ME TIPS OR HINT IN CONFIGURING MANDRAKE.

Last edited by chalichalupa; 01-12-2004 at 12:16 AM.
 
Old 01-12-2004, 01:57 AM   #2
TheBlackUnicorn
Member
 
Registered: Jan 2004
Distribution: Debian and Gentoo
Posts: 39

Rep: Reputation: 15
No need to yell

Can you post the output of ifconfig (run as root) ? Preferably those of both slackware and mandrake, so we can see what's different.

Can you ping an external ip ? E.g. ping 216.239.59.99 (google.com). If you can, make sure your DNS configuration is correct. You can find that in /etc/resolv.conf

Also, with the two cards, are you sure it is the right one that you have configured. Perhaps you have configured the broadcom instead of the 3com
 
Old 01-12-2004, 04:54 AM   #3
chalichalupa
LQ Newbie
 
Registered: Jan 2004
Location: philippines
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by TheBlackUnicorn
No need to yell
Can you post the output of ifconfig (run as root) ? Preferably those of both slackware and mandrake, so we can see what's different.
Can you ping an external ip ? E.g. ping 216.239.59.99 (google.com). If you can, make sure your DNS configuration is correct. You can find that in /etc/resolv.conf
Also, with the two cards, are you sure it is the right one that you have configured. Perhaps you have configured the broadcom instead of the 3com

[B]ive tried pinging my proxy server this the output from my Linux slackware(my os that can connect to the internet)
root@stn33:~# ping 172.17.1.126
PING 172.17.1.126 (172.17.1.126): 56 octets data
64 octets from 172.17.1.126: icmp_seq=0 ttl=64 time=0.6 ms
64 octets from 172.17.1.126: icmp_seq=1 ttl=64 time=0.5 ms
and so on

--- 172.17.1.126 ping statistics ---
10 packets transmitted, 10 packets received, 0% packet loss
round-trip min/avg/max = 0.5/0.5/0.7 ms

my slackwares ifconfig

root@stn33:~# ifconfig
eth0 Link encap:Ethernet HWaddr 00:A0:24C:25:74
inet addr:172.17.1.66 Bcast:172.17.1.127 Mask:255.255.255.128
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1566 errors:0 dropped:0 overruns:0 frame:0
TX packets:803 errors:0 dropped:0 overruns:0 carrier:0
collisions:18 txqueuelen:100
RX bytes:390247 (381.1 Kb) TX bytes:125557 (122.6 Kb)
Interrupt:5 Base address:0x220

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:128 errors:0 dropped:0 overruns:0 frame:0
TX packets:128 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:10400 (10.1 Kb) TX bytes:10400 (10.1 Kb)

I HAVE ALSO USED THIS COMMAND lspci -v and this is some info from my nic card

00:07.0 ISA bridge: VIA Technologies, Inc. VT82C596 ISA [Mobile South] (rev 23)
Subsystem: Giga-byte Technology VT82C596/A/B PCI to ISA Bridge
Flags: bus master, stepping, medium devsel, latency 0
THIS IS MY ETC/RESOLVE.CONF
search r.org


MY MANDRAKES IFCONFIG
[root@1 guest]# ifconfig
eth0 Link encap:Ethernet HWaddr 00:A0:24C:25:74
inet addr:172.17.1.66 Bcast:172.17.1.127 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:444 (444.0 b)
Interrupt:5 Base address:0x220

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:50 errors:0 dropped:0 overruns:0 frame:0
TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3296 (3.2 Kb) TX bytes:3296 (3.2 Kb)


MY MANDRAKES LSPCI -V
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C596 ISA [Mobile South] (rev 23)
Subsystem: Giga-byte Technology VT82C596/A/B PCI to ISA Bridge
Flags: bus master, stepping, medium devsel, latency 0

pinging my proxy server
PING 172.17.1.126 (172.17.1.126) 56(84) bytes of data.
From 172.17.1.66 icmp_seq=1 Destination Host Unreachable
From 172.17.1.66 icmp_seq=2 Destination Host Unreachable
From 172.17.1.66 icmp_seq=3 Destination Host Unreachable

--- 172.17.1.126 ping statistics ---
6 packets transmitted, 0 received, +3 errors, 100% packet loss, time 5041ms
, pipe 3

MY MANDRAKES /etc/resolve.conf
search mpsc.ph local

Last edited by chalichalupa; 01-12-2004 at 05:18 AM.
 
Old 01-12-2004, 06:21 AM   #4
TheBlackUnicorn
Member
 
Registered: Jan 2004
Distribution: Debian and Gentoo
Posts: 39

Rep: Reputation: 15
I can see one difference in the network addresses : your slackware has a
netmask of 255.255.255.128 whereas your mandrake has 255.255.255.0. Try changing that.

Could you also please post the output of 'route' from both systems ? I would like to know the settings of your default gateway
 
Old 01-13-2004, 02:48 AM   #5
chalichalupa
LQ Newbie
 
Registered: Jan 2004
Location: philippines
Posts: 16

Original Poster
Rep: Reputation: 0
THIS IS THE SOLUTION
With lilo you can do this by selecting the os you would like to boot, lets say it is named mandrake and add the option to it.

boot: mandrake acpi=off


THANKS TO THE ONE WHO HEPLED ME
" Hertattack "
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I badly need help john0908 Programming 1 02-18-2005 07:54 PM
need help BADLY!! zdos Linux - Newbie 2 05-23-2004 02:45 PM
Badly Needing Help In Configuring Nic Problems chalichalupa Linux - Software 3 01-13-2004 02:49 AM
I badly need your help! rookieter Linux - Networking 1 08-20-2003 10:04 AM
badly need some help here :P katana Linux - General 4 01-23-2002 09:41 PM


All times are GMT -5. The time now is 09:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration