LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 12-10-2012, 03:38 AM   #1
Peleus
Member
 
Registered: Mar 2003
Posts: 77

Rep: Reputation: 15
AWUS036NHA / AR9271 Issues


Hi everyone.

I'm trying to get this Alfa card working. Plenty of irony as I bought this one to hopefully have a more trouble free backtrack experience but alas it doesn't seem so at this stage

Anyway, I've gone through and (I believe) correctly installed the compat-wireless drivers. Ath9k is associated with the card etc, but unfortunately I just can't get it recognized in ifconfig. Any help as to where I could go from here is greatly appreciated.

Initial Dmesg, I've got no idea why it's failing
Code:
root@bt:~# dmesg | grep ath
[    8.912805] usb 2-1.3: ath9k_htc: Firmware htc_9271.fw requested
[    8.912817] usbcore: registered new interface driver ath9k_htc
[    9.196323] usb 2-1.3: ath9k_htc: Transferred FW: htc_9271.fw, size: 51272
[   10.192919] ath9k_htc 2-1.3:1.0: ath9k_htc: Target is unresponsive
[   10.192931] ath9k_htc: Failed to initialize the device
[   10.201992] usb 2-1.3: ath9k_htc: USB layer deinitialized
lsmod
Code:
root@bt:~# lsmod | grep ath9k
ath9k_htc              90944  0 
mac80211              539998  1 ath9k_htc
ath9k_common           13604  1 ath9k_htc
ath9k_hw              389542  2 ath9k_htc,ath9k_common
ath                    23032  3 ath9k_htc,ath9k_common,ath9k_hw
cfg80211              205053  3 ath9k_htc,mac80211,ath
compat                 19385  5 ath9k_htc,mac80211,ath9k_common,ath9k_hw,cfg8021
lsusb
Code:
root@bt:~# lsusb
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 003: ID 046d:c066 Logitech, Inc. 
Bus 005 Device 002: ID 058f:9254 Alcor Micro Corp. Hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 003: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
After a while I pull it out / replug it in, it seems to initialize correctly...
Code:
root@bt:~# dmesg | grep ath9k
[    8.912805] usb 2-1.3: ath9k_htc: Firmware htc_9271.fw requested
[    8.912817] usbcore: registered new interface driver ath9k_htc
[    9.196323] usb 2-1.3: ath9k_htc: Transferred FW: htc_9271.fw, size: 51272
[   10.192919] ath9k_htc 2-1.3:1.0: ath9k_htc: Target is unresponsive
[   10.192931] ath9k_htc: Failed to initialize the device
[   10.201992] usb 2-1.3: ath9k_htc: USB layer deinitialized
[  241.702859] usb 2-1.3: ath9k_htc: Firmware htc_9271.fw requested
[  241.986525] usb 2-1.3: ath9k_htc: Transferred FW: htc_9271.fw, size: 51272
[  242.221482] ath9k_htc 2-1.3:1.0: ath9k_htc: HTC initialized with 33 credits
[  242.408728] ath9k_htc 2-1.3:1.0: ath9k_htc: FW Version: 1.3
[  242.414171] Registered led device: ath9k_htc-phy1
But it still doesn't register
Code:
root@bt:~# modprobe ath9k_htc
root@bt:~# ifconfig
eth0      Link encap:Ethernet  HWaddr 50:e5:49:c9:4e:bb  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:46 Base address:0xe000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:64 errors:0 dropped:0 overruns:0 frame:0
          TX packets:64 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
Like I said, any help is really appreciated.
 
Old 12-11-2012, 02:44 PM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,623
Blog Entries: 2

Rep: Reputation: 4078Reputation: 4078Reputation: 4078Reputation: 4078Reputation: 4078Reputation: 4078Reputation: 4078Reputation: 4078Reputation: 4078Reputation: 4078Reputation: 4078
Which distro/version?
What is the output of
Code:
iwconfig
if the device is recognized?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AR9271 driver slackunix Slackware 8 10-04-2012 05:52 PM
AWUS 036NHA (AR9271 Chipset) for Slack 13.37 Mercury305 Slackware 7 08-01-2012 04:52 PM
AWUS036NHA in Master Mode TheMac Linux - Hardware 2 10-30-2011 01:59 AM
[SOLVED] USB stick TP-Link TL-WN422g V.2 ar9271 ukiuki Linux - Wireless Networking 0 05-29-2010 02:35 PM
Looking for AR9271 driver nakarake Linux - Wireless Networking 1 03-13-2010 12:55 PM


All times are GMT -5. The time now is 05:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration